Results 1 to 9 of 9

Thread: problem after update Tumbleweed

  1. #1

    Default problem after update Tumbleweed

    Hello

    I am an old user of opensuse since 2006, now use Tumbleweed GNOME

    The problem begins after system update on May 26

    1- Firefox no longer works
    2- After logging onto Yast I can not open the repository and manage the programs.

    I Found solution

    Code:
    sudo rpm -i --force http://download.opensuse.org/tumbleweed/repo/oss/suse/x86_64/libmodman1-2.0.1-17.7.x86_64.rpm
    Code:
    zypper dup --no-allow-vendor-change
    Code:
    zypper update
    Now I'm working on Firefox
    But I can not longer access to:
    1- program manager and repository
    2- repository manager
    3- Files manager
    4- Libreoffice
    5- Epiphany
    What is the solution to this problem

  2. #2
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: problem after update Tumbleweed

    Quote Originally Posted by malhargan View Post
    Hello

    I am an old user of opensuse since 2006, now use Tumbleweed GNOME

    The problem begins after system update on May 26

    1- Firefox no longer works
    2- After logging onto Yast I can not open the repository and manage the programs.

    I Found solution

    Code:
    sudo rpm -i --force http://download.opensuse.org/tumbleweed/repo/oss/suse/x86_64/libmodman1-2.0.1-17.7.x86_64.rpm
    Code:
    zypper dup --no-allow-vendor-change
    Code:
    zypper update
    Now I'm working on Firefox
    But I can not longer access to:
    1- program manager and repository
    2- repository manager
    3- Files manager
    4- Libreoffice
    5- Epiphany
    What is the solution to this problem
    solution to what?
    did you originally run zypper dup without the no-allow-vendor-change
    what graphic card and driver do you use?
    post your repo list
    Code:
    zypper lr -d

  3. #3

    Default Re: problem after update Tumbleweed

    Code:
    --------------------------------------------------------+-------
    1 | games                               | games                       | نعم  | (r ) نعم      | نعم   |   99     | rpm-md | http://download.opensuse.org/repositories/games/openSUSE_Tumbleweed/ |       
    2 | google                              | google                      | نعم  | (r ) نعم      | نعم   |   99     | rpm-md | http://dl.google.com/linux/chrome/rpm/stable/x86_64                  |       
    3 | http-download.opensuse.org-7d982da7 | openSUSE:Leap:42.2          | نعم  | (r ) نعم      | نعم   |   99     | yast2  | http://download.opensuse.org/distribution/leap/42.2/repo/oss/        |       
    4 | openSUSE-20170510-0                 | openSUSE-20170510-0         | نعم  | (r ) نعم      | نعم   |   99     | yast2  | http://download.opensuse.org/tumbleweed/repo/oss                     |       
    5 | packman                             | packman                     | نعم  | (r ) نعم      | نعم   |   99     | rpm-md | http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Tumbleweed/  |       
    6 | repo-debug                          | openSUSE-Tumbleweed-Debug   | لا   | ----          | ----  |   99     | NONE   | http://download.opensuse.org/debug/tumbleweed/repo/oss/              |       
    7 | repo-non-oss                        | openSUSE-Tumbleweed-Non-Oss | نعم  | (r ) نعم      | نعم   |   99     | yast2  | http://download.opensuse.org/tumbleweed/repo/non-oss/                |       
    8 | repo-source                         | openSUSE-Tumbleweed-Source  | لا   | ----          | ----  |   99     | NONE   | http://download.opensuse.org/source/tumbleweed/repo/oss/             |       
    9 | repo-update                         | openSUSE-Tumbleweed-Update  | نعم  | (r ) نعم      | نعم   |   99     | rpm-md | http://download.opensuse.org/update/tumbleweed/                      |
    solution to what?

    to run:
    1- program manager and repository
    2- repository manager
    3- Files manager
    4- Libreoffice
    5- Epiphany

  4. #4
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,746

    Default Re: problem after update Tumbleweed

    Note repo 3 is for 42.2 not tumbleweed. DO NOT MIX REPOS

  5. #5

    Default Re: problem after update Tumbleweed

    OK
    I deleted it, I do not know how it was added

    did you originally run zypper dup without the no-allow-vendor-change = yes
    what graphic card and driver do you use? = intel


    then What

  6. #6
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: problem after update Tumbleweed

    Quote Originally Posted by malhargan View Post
    OK
    I deleted it, I do not know how it was added

    did you originally run zypper dup without the no-allow-vendor-change = yes
    what graphic card and driver do you use? = intel


    then What
    that was your problem zypper dup downloaded leap packages I'm amazed your system booted
    the solution is 3 steps
    #1 remove the leap repo
    Code:
    zypper rr 3
    #2 do a full vendor change to the TW repo to get rid of LEAP packages (when you remove repo 3 repo 4 will become repo 3)
    Code:
    zypper dup --from 3
    #3 do a full vendor change to packman to get multimedia working (packman is #5 but will become #4)
    Code:
    zypper dup --from 4
    as a lot of system packages will change vendor a reboot is recommended

  7. #7

    Thumbs up Re: problem after update Tumbleweed

    Thank you so much
    computer back like Ferrari

  8. #8

    Default Re: problem after update Tumbleweed

    There are some outstanding problems

    Solved this way

  9. #9
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: problem after update Tumbleweed

    Quote Originally Posted by malhargan View Post
    There are some outstanding problems

    Solved this way
    That was supposed to be done in step 3
    #3 do a full vendor change to packman to get multimedia working (packman is #5 but will become #4)
    Code:
    zypper dup --from 4

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •