Page 1 of 6 123 ... LastLast
Results 1 to 10 of 58

Thread: Afhankelijk heden programma en of updaten van 42.1 naar 42.2

  1. #1

    Default Afhankelijk heden programma en of updaten van 42.1 naar 42.2

    Wat is het probleem ?

    Leap 42.1 heeft het eind van zijn leven bereikt.

    Ik moet dus naar 42.2 als ik nog updates wil krijgen.

    Nu heb ik echter net een programma zelf gecompileerd, LMMS rc 1.2 en dat is elke keer vooral lastig, omdat je alle afhankelijkheden moet zoeken.
    Er is wel een lijst van de afhankelijkheden ( dependecies), maar daar ontbreken dingen aan.

    Ik ben al dagen aan het zoeken geweest, maar vind geen duidelijk antwoord waar ik wat aan heb.

    Vraag1
    Begrijp ik het nou goed, dat als ik een update uitvoer, en ik mazzel heb, ik LMMS niet opnieuw hoef te compilen ? ( ik weet even niet wat compilen in het nederlands is )

    Vraag 2
    Kan ik een lijst maken van de afhankelijkheden, van de LMMS versie die ik zelf gecompileerd heb? Via de opdracht prompt ?
    Op mijn computer staat nu ook een andere versie van lmms, van packman, die is op de normale manier via yast geïnstalleerd is.

    Vraag 3
    Is een update uitvoeren (42.1 -> 42.2) ipv een gewone installatie, vragen om problemen, als je de nvidia drivers gebruikt ?

    Beetje off topic, ik heb de 42.2 iso natuurlijk al met bittorrent binnen gehaald, helaas ging het branden van de dvd mis, en dat was waarschijnlijk het einde van mijn huidige brander.
    Ik heb inmiddels een nieuwe dvd brander binnen. Je blijft lachen met die computers.

    Ik haal altijd mijn openSUSE iso's altijd binnen met Bit torrent, stukje traditie inmiddels. Gebruik ik bit torrent tenminste af en toe ook waar het voor gemaakt is.

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    16,628
    Blog Entries
    13

    Default Re: Afhankelijk heden programma en of updaten van 42.1 naar 42.2

    Quote Originally Posted by Gps2010 View Post
    Wat is het probleem ?

    Leap 42.1 heeft het eind van zijn leven bereikt.

    Ik moet dus naar 42.2 als ik nog updates wil krijgen.

    Nu heb ik echter net een programma zelf gecompileerd, LMMS rc 1.2 en dat is elke keer vooral lastig, omdat je alle afhankelijkheden moet zoeken.
    Er is wel een lijst van de afhankelijkheden ( dependecies), maar daar ontbreken dingen aan.

    Ik ben al dagen aan het zoeken geweest, maar vind geen duidelijk antwoord waar ik wat aan heb.

    Vraag1
    Begrijp ik het nou goed, dat als ik een update uitvoer, en ik mazzel heb, ik LMMS niet opnieuw hoef te compilen ? ( ik weet even niet wat compilen in het nederlands is )

    Vraag 2
    Kan ik een lijst maken van de afhankelijkheden, van de LMMS versie die ik zelf gecompileerd heb? Via de opdracht prompt ?
    Op mijn computer staat nu ook een andere versie van lmms, van packman, die is op de normale manier via yast geïnstalleerd is.

    Vraag 3
    Is een update uitvoeren (42.1 -> 42.2) ipv een gewone installatie, vragen om problemen, als je de nvidia drivers gebruikt ?

    Beetje off topic, ik heb de 42.2 iso natuurlijk al met bittorrent binnen gehaald, helaas ging het branden van de dvd mis, en dat was waarschijnlijk het einde van mijn huidige brander.
    Ik heb inmiddels een nieuwe dvd brander binnen. Je blijft lachen met die computers.

    Ik haal altijd mijn openSUSE iso's altijd binnen met Bit torrent, stukje traditie inmiddels. Gebruik ik bit torrent tenminste af en toe ook waar het voor gemaakt is.
    Je kunt de 42.1 in je repos vervangen door 42.2 en dan
    Code:
    zypper dup
    draaien. Is nooit meteen definitief, dwz je moet ja/nee kiezen, maar wordt openQA getest en zou gewoon moeten werken.
    Overigens is zelf compileren op deze manier niet de 'way to go'. Dan loop je altijd, per definitie, tegen dit soort dingen aan.

    Waarom trouwens nog branden op DVD? Imagewriter of dd gebruiken en je zet 't op USB-stick, en die 8GB dingen kosten geen drol meer.
    - Athlon X6 3.6 GHz, 16 GB DDR3, 64 GB SSD, 3 TB of disks, openSUSE Leap 42.2
    - ASUS A73SD, 6 GB, 2 x 120 GB SSD, Tumbleweed+Leap
    - VPS, 150 GB SSD, 3 TB, Tumbleweed

    Failure is just one of your options.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3

    Default Re: Afhankelijk heden programma en of updaten van 42.1 naar 42.2

    Quote Originally Posted by Knurpht View Post
    Je kunt de 42.1 in je repos vervangen door 42.2 en dan
    Code:
    zypper dup
    draaien. Is nooit meteen definitief, dwz je moet ja/nee kiezen, maar wordt openQA getest en zou gewoon moeten werken.
    Overigens is zelf compileren op deze manier niet de 'way to go'. Dan loop je altijd, per definitie, tegen dit soort dingen aan.

    Waarom trouwens nog branden op DVD? Imagewriter of dd gebruiken en je zet 't op USB-stick, en die 8GB dingen kosten geen drol meer.
    Bedankt.
    Tja waarom nog dvd, is denk ik vooral gewoonte, maar met de prijzen van usb sticks is dat eigenlijk wel achterhaalt.


    Dat zelf compilen, heeft er mee te maken, dat er problemen zijn met opensuse leap 42.2 (en andere distro's) met LMMS.
    Met leap 42.1 geen probleem met LMMS.

    Om misverstanden te voorkomen, het probleem in deze is LMMS, niet ons favoriete besturingssysteem.
    De versie die we van Packman krijgen werkt op 42.1 wel goed, maar op 42.2 mist er iets. ( dat is ook waarom ik geen haast had om te updaten, want ik weet al, dat als ik update naar 42.2, ik een probleem heb met lmms van packman )

    LMMS is gratis en heeft hulp nodig ook van mensen als mij. Ik had dus een poging gedaan om te kijken of de nieuwste release kandidaat goed wilde compilen op 42.1.
    Het goede nieuws in deze is, dat ook op 42.2 al een opensuse gebruiker succes vol was met het compilen van de release kandidaat.


    Het is wel cynisch dat een programma dat eigenlijk Linux Multi Media Studio heet, tegenwoordig zoveel problemen heeft op Linux.

    Voorlopig is voor mij en vele andere helaas de enige optie compileer LMMS zelf, want packman gaat voor ons geen beta versies en release kandidaten compileren.
    ( Daar hebben ze wat mij betreft 100% gelijk in )
    Of zie ik een optie over het hoofd ?

    Tot slot over
    Code:
     zypper dub
    Ik had nou juist ook op dit forum gelezen, dat het beter was om een dvd te branden of een usb stick te maken, en vanaf daar de update te doen.
    Dat zou minder kans op problemen geven.

    Spreek me gerust tegen als dit niet zo is.
    42.1 veranderen in 42.2 ( en voor de zekerheid even de niet standaard repositories uitzetten ) is natuurlijk de makkelijkste manier om te updaten.

  4. #4
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    16,628
    Blog Entries
    13

    Default Re: Afhankelijk heden programma en of updaten van 42.1 naar 42.2

    Over 'zypper dup' na verandering van de repos: deze manier is zelfs beter dan via de DVD, zeker als je de online bronnen niet inschakelt, of niet kunt inschakelen omdat je dan tegen de nare bug in de NL vertaling aanloopt. Zonder die bronnen kun je de pakketten die niet op de dvd staan, maar die je wel geïnstalleerd had, kwijt raken. Met 'zypper dup' heb je dat probleem niet.
    Overigens worden beide methoden via openqa.opensuse.org getest. Als je op deze pagina naar beneden scrollt kun je dat ook zien. Zelfs upgrade van 13.1, 13.2 worden zo getest. Wat daar gebeurt is nadoen wat een gebruiker ook zou doen. Bijv. Loopt de installatie zoals het moet, herstart het systeem OK na installatie, start Firefox op en krijg je dan netjes de startpagina? En dus niet of de NL talige installatie goed loopt, anders zou die test mislukt zijn, er een bugreport uitrollen en het voor release gefixt zijn. Klik daar maar eens wat rond, en kijk vooral naar met lichtblauw gemerkte zaken, dat zijn lopende/komende tests, als je dat 's gezien hebt spreekt het meer.

    Over LMMS en 42.2: als je LMMS vanuit een terminal opstart, zou je moeten kunnen zien wat er mist/misgaat. Met de Packman versie dan hè.
    - Athlon X6 3.6 GHz, 16 GB DDR3, 64 GB SSD, 3 TB of disks, openSUSE Leap 42.2
    - ASUS A73SD, 6 GB, 2 x 120 GB SSD, Tumbleweed+Leap
    - VPS, 150 GB SSD, 3 TB, Tumbleweed

    Failure is just one of your options.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  5. #5

    Default Re: Afhankelijk heden programma en of updaten van 42.1 naar 42.2

    Ik ga het proberen, als het echt misgaat moet ik nog wel de leap 42.1 dvd hebben.
    Het behouden van geïnstalleerde pakketten klinkt als wat ik wil.


    Over LMMS, ik had het al gemeld bij packman, en hun antwoord was dat dit upstream gerepareerd moet worden.

    Upstream is in dit geval LMMS.

    Op detail niveau gaat het mij boven de pet, maar er is iets waardoor het compilen op bijna alle Distro's fout gaat.

    Ook met leap 42.1 is er dezelfde foutmeding bij het compileren, maar toch werkt het op 42.1 wel.


    LMMS heeft zoals alle soortgelijke muziek programma's een plugin container. Deze ontbreekt als je lmms van packman installeert op 42.2.
    Ik denk niet dat het zinvol is dat ik daar verder op inga, tenzij er hier lmms gebruikers zijn met problemen.

    De oplossing is voorlopig om de laatste versie van lmms zelf te compileren.
    De lijst met afhankelijk heden voor ons ( leap ) moet inmiddels redelijk compleet zijn. ( lmms web pagina's )

    Een 42.2 gebruiker en ik, hebben namelijk een aanvulling gedaan.

  6. #6
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    16,628
    Blog Entries
    13

    Default Re: Afhankelijk heden programma en of updaten van 42.1 naar 42.2

    Even terzijde: als je dichter op upstream wilt zitten, zou je ook Tumbleweed kunnen overwegen. De lmms versie van Packman start hier in ieder gevak goed. Om meer te kunnen zeggen is 't te lang geleden dat ik er mee gespeeld heb. Ik weet niet hoe je zit me de ruimte op je systeem, maar je zou zelfs 42.2 en TW allebei kunnen installeren, gebruik makend van dezelfde homedir. Heb ik op mijn laptop en dat werkt prima.
    - Athlon X6 3.6 GHz, 16 GB DDR3, 64 GB SSD, 3 TB of disks, openSUSE Leap 42.2
    - ASUS A73SD, 6 GB, 2 x 120 GB SSD, Tumbleweed+Leap
    - VPS, 150 GB SSD, 3 TB, Tumbleweed

    Failure is just one of your options.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  7. #7

    Default Re: Afhankelijk heden programma en of updaten van 42.1 naar 42.2

    Ik gok dat je zeker Carla, maar veel belangrijker VeSTige mist in LMMS ? ( Met Vestige dat ook wine gebruikt, zijn overigens de meeste problemen )
    Links onder instrument plugins.
    Of misschien makkelijker ik denk dat je versie lmms 1.1.3 krijgt van packman ( op thumble weed ? )





    Los van LMMS klinkt het wel interessant om ook Thumble weed te gebruiken met de zelfde home dir.
    Gebruikt Thumble weed dan ook de zelfde swap ?

    Harde schijf is 1 terra , daar kan wel 20 gig vanaf voor de root van thumble weed.
    Gaat denk ik niets oplossen met lmms, maar is minimaal leuk omdat het kan.

  8. #8
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    16,628
    Blog Entries
    13

    Default Re: Afhankelijk heden programma en of updaten van 42.1 naar 42.2

    Beetje veel vragen, maar op bijna alles: ja dat kan.

    Wat jij compileert heeft bepaalde dingen/modules/componenten ( gaat voor zover ik weet over VST (Vestige) die niet overall vrij mogen worden verspreid ( zoals voorheen ook mp3 ) ) aan staan en bij Packman mag dat niet. Er wordt gewerkt aan andere oplossingen, zodat het codecs gedoe etc. echt opgelost worden.
    - Athlon X6 3.6 GHz, 16 GB DDR3, 64 GB SSD, 3 TB of disks, openSUSE Leap 42.2
    - ASUS A73SD, 6 GB, 2 x 120 GB SSD, Tumbleweed+Leap
    - VPS, 150 GB SSD, 3 TB, Tumbleweed

    Failure is just one of your options.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  9. #9

    Default Re: Afhankelijk heden programma en of updaten van 42.1 naar 42.2

    Bedankt.

    Ik weet dat lmms aan een Linux installer werkt. Ik als Linux fan weet niet of ik daar echt blij mee ben.
    De gebruiker in mij ziet het wel zitten. ( als het maar werkt )

    Probleem voor veel gebruikers is wel, dat een muziek programma dat geen vst kan gebruiken, eigenlijk geen optie is.
    Verder weet ik dat vst van Steinberg is, en daar zal wel het probleem zitten, qua licenties.

    Een voorbeeld van een leuke vst, de mini moog.
    Een software versie van een legendarische syntjesizer.

    Gary Numan - are friend electirc ? bijvoorbeeld. ( maar de lijst is lang )

  10. #10
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    16,628
    Blog Entries
    13

    Default Re: Afhankelijk heden programma en of updaten van 42.1 naar 42.2

    Quote Originally Posted by Gps2010 View Post
    Gary Numan - are friend electirc ? bijvoorbeeld. ( maar de lijst is lang )
    Geweldig nummer. Ik ben van de generatie die de (mini)moog wel kent.

    Je zou voor de aardigheid 's naar OBS moeten kijken, de open build service. Zou je nu veel meer moeten zeggen, omdat je zelf LMMS gecompileerd hebt. Als je bijv. hier https://build.opensuse.org/package/s...ZB/par2cmdline kijkt zie je
    - een zip file met de sources
    - een .changes file met daarin een changelog ( in deze staat niks )
    - een .spec file, waarin eigenlijk staat wat je nu allemaal met de hand gedaan hebt. Van ieder pakket is ook een ...src...rpm, als je die opent met Ark zie je de spec file die erbij hoort. Voor LMMS zou ik dan beginnen met die van Packman, en die aanpassen waar nodig.

    De voordelen:
    - Bouwen voor meerdere openSUSE ( evt. andere distros ) tegelijk
    - Je krjigt niet al die -devel pakketten op je systeem
    - Je kunt het binnentrekken van nieuwere sources automatiseren, het opnieuw bouwen van de pakketten wordt dan automatisch in gang gezet.
    - Andere pakketten in OBS als voorbeeldmateriaal

    Bij Packman gebruiken ze ook OBS, dus met hun spec file zou je al een heel eind moeten komen.
    - Athlon X6 3.6 GHz, 16 GB DDR3, 64 GB SSD, 3 TB of disks, openSUSE Leap 42.2
    - ASUS A73SD, 6 GB, 2 x 120 GB SSD, Tumbleweed+Leap
    - VPS, 150 GB SSD, 3 TB, Tumbleweed

    Failure is just one of your options.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

Page 1 of 6 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •