Results 1 to 4 of 4

Thread: DNS leak with openvpn

  1. #1

    Default DNS leak with openvpn

    Dear all,

    I'm having a DNS leak tested using dnsleaktest.com

    There's a suggestion using block-outside-dns but it's not recognized.

    I'm using latest openvpn from vpn repos

    Please help

  2. #2

    Default Re: DNS leak with openvpn

    Quote Originally Posted by asiansaga View Post
    Dear all,

    I'm having a DNS leak tested using dnsleaktest.com

    There's a suggestion using block-outside-dns but it's not recognized.

    I'm using latest openvpn from vpn repos

    Please help
    Search/Yast2Modules/Network Card Setup/Address/Statically Assigned IP Address:


    Choose the fastest VPN server and type its IP address there. In general option, disable IPv6. Save, exit and reboot. See if it works? If not, set it back to Dynamic Address. This method works fine in *u when its leaking, but it may be slower at startup.


    What is your VPN Client?

  3. #3
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,273
    Blog Entries
    2

    Default Re: DNS leak with openvpn

    To configure your DNS servers to be changed automatically whenever you either establish an OpenVPN connection or disconnect (returning to your normal network settings),

    https://wiki.archlinux.org/index.php/OpenVPN#DNS

    Else,
    There are a number of different ways you can manually change DNS... The above post is one way, another way is to edit /etc/resolv.conf directly (your edits will survive until the next reboot), etc.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  4. #4

    Default Re: DNS leak with openvpn

    Quote Originally Posted by AMD17 View Post
    Search/Yast2Modules/Network Card Setup/Address/Statically Assigned IP Address:


    Choose the fastest VPN server and type its IP address there. In general option, disable IPv6. Save, exit and reboot. See if it works? If not, set it back to Dynamic Address. This method works fine in *u when its leaking, but it may be slower at startup.


    What is your VPN Client?
    i'm connecting to wireless network using Network Manager on my laptop, so signing static IP is not an option for me


    Quote Originally Posted by tsu2 View Post
    To configure your DNS servers to be changed automatically whenever you either establish an OpenVPN connection or disconnect (returning to your normal network settings),

    https://wiki.archlinux.org/index.php/OpenVPN#DNS

    Else,
    There are a number of different ways you can manually change DNS... The above post is one way, another way is to edit /etc/resolv.conf directly (your edits will survive until the next reboot), etc.

    TSU
    thank you, i manage to automatically change DNS using VPN using the script in the link

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •