Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: zypper recommends conflicting packages?

  1. #1
    Join Date
    May 2015
    Location
    Italy
    Posts
    379

    Default zypper recommends conflicting packages?

    Today I wanted to install wine and wine-32bit. Zypper told me it would also install two recommended packages: wine-mp3 and wine-mp3-32bit (they are from packman).

    But as soon as it tried to install the packages it found conflicts among the requested packages and the recommended ones:

    Code:
    cris@PolariSuse [~]$ sudo zypper in wine wine-32bit
    [sudo] password for root:  
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...
    
    The following 6 NEW packages are going to be installed:
      libGLU1-32bit libglvnd-32bit wine wine-32bit wine-mp3 wine-mp3-32bit
    
    The following 2 applications are going to be REMOVED:
      Cuttlefish Desktop
    
    The following 2 recommended packages were automatically selected:
      wine-mp3 wine-mp3-32bit
    
    6 new packages to install.
    Overall download size: 221,8 KiB. Already cached: 38,5 MiB. After the operation, additional 352,9 MiB will be used.
    Continue? [y/n/...? shows all options] (y): 
    In cache libglvnd-32bit-0.1.1~20161222~dc16f8c-3.1.x86_64.rpm                                                                                     (1/6), 175,5 KiB (  1,0 MiB unpacked)
    Retrieving package libGLU1-32bit-9.0.0-12.3.x86_64                                                                                                (2/6), 179,4 KiB (485,8 KiB unpacked)
    Retrieving: libGLU1-32bit-9.0.0-12.3.x86_64.rpm .................................................................................................................................[done]
    In cache wine-32bit-2.6-1.5.x86_64.rpm                                                                                                            (3/6),  18,6 MiB (166,3 MiB unpacked)
    In cache wine-2.6-1.5.x86_64.rpm                                                                                                                  (4/6),  19,7 MiB (184,9 MiB unpacked)
    Retrieving package wine-mp3-32bit-1.1.39-19.2.x86_64                                                                                              (5/6),  21,1 KiB ( 83,1 KiB unpacked)
    Retrieving: wine-mp3-32bit-1.1.39-19.2.x86_64.rpm ...............................................................................................................................[done]
    Retrieving package wine-mp3-1.1.39-19.2.i586                                                                                                      (6/6),  21,2 KiB ( 83,1 KiB unpacked)
    Retrieving: wine-mp3-1.1.39-19.2.i586.rpm .......................................................................................................................................[done]
    Checking for file conflicts: ...................................................................................................................................................[error]
    Detected 2 file conflicts:
    
    File /usr/lib/wine/winemp3.acm.so
      from install of
         wine-32bit-2.6-1.5.x86_64 (Main Repository (OSS))
      conflicts with file from install of
         wine-mp3-1.1.39-19.2.i586 (Packman Repository)
    
    File /usr/lib/wine/winemp3.acm.so
      from install of
         wine-32bit-2.6-1.5.x86_64 (Main Repository (OSS))
      conflicts with file from install of
         wine-mp3-32bit-1.1.39-19.2.x86_64 (Packman Repository)
    
    File conflicts happen when two packages attempt to install files with the same name but different contents. If you continue, conflicting files will be replaced losing the previous con
    tent.
    Continue? [yes/no] (no): 
    
    Problem occurred during or after installation or removal of packages:
    Installation aborted by user                                                                                                                                                           
    
    Please see the above error message for a hint.
    
    Is this expected behavior?

    Thank you in advance
    Cris
    Desktop: OpenSUSE Tumbleweed (x86_64) - AMD FX-8350 Eight-Core Processor, 16Gb RAM, 120GB Samsung Evo 840 SSD
    Laptop: OpenSUSE Tumbleweed (x86_64) - Thinkpad T440 - Intel i5-4210U, 12Gb RAM, 250GB Samsung EVO 750 SSD

  2. #2

    Default Re: zypper recommends conflicting packages?

    Yes.
    wine is built with mp3 support nowadays.

    Uninstall wine-mp3 and all should be fine.

    The dependencies have been fixed meanwhile btw, in the next snapshot wine should properly uninstall wine-mp3...

  3. #3
    Join Date
    May 2015
    Location
    Italy
    Posts
    379

    Default Re: zypper recommends conflicting packages?

    Thank you wolfi323.
    In the meantime I bypassed the problem by installing with --no-recommends.

    Cris
    Desktop: OpenSUSE Tumbleweed (x86_64) - AMD FX-8350 Eight-Core Processor, 16Gb RAM, 120GB Samsung Evo 840 SSD
    Laptop: OpenSUSE Tumbleweed (x86_64) - Thinkpad T440 - Intel i5-4210U, 12Gb RAM, 250GB Samsung EVO 750 SSD

  4. #4

    Default Re: zypper recommends conflicting packages?

    On 05/24/2017 06:56 PM, wolfi323 wrote:
    >
    > Yes.
    > wine is built with mp3 support nowadays.
    >
    > Uninstall wine-mp3 and all should be fine.
    >
    > The dependencies have been fixed meanwhile btw, in the next snapshot
    > wine should properly uninstall wine-mp3...
    >
    >


    Wine is not the only package having conflicts:

    Code:
    *********************************

    File /usr/bin/dvdauthor
    from install of
    dvdauthor-0.7.2-1.1.x86_64 (openSUSE-Tumbleweed-Oss)
    conflicts with file from package
    dvdauthor07-0.7.2-1.1.x86_64 (@System)

    File /usr/bin/dvdunauthor
    from install of
    dvdauthor-0.7.2-1.1.x86_64 (openSUSE-Tumbleweed-Oss)
    conflicts with file from package
    dvdauthor07-0.7.2-1.1.x86_64 (@System)

    File /usr/bin/mpeg2desc
    from install of
    dvdauthor-0.7.2-1.1.x86_64 (openSUSE-Tumbleweed-Oss)
    conflicts with file from package
    dvdauthor07-0.7.2-1.1.x86_64 (@System)

    File /usr/bin/spumux
    from install of
    dvdauthor-0.7.2-1.1.x86_64 (openSUSE-Tumbleweed-Oss)
    conflicts with file from package
    dvdauthor07-0.7.2-1.1.x86_64 (@System)

    ***********************************************

    There are others as well.

    --
    Ken
    linux since 1994
    S.u.S.E./openSUSE since 1996

  5. #5

    Default Re: zypper recommends conflicting packages?

    On 05/25/2017 09:35 AM, Ken Schneider wrote:
    > On 05/24/2017 06:56 PM, wolfi323 wrote:
    >>
    >> Yes.
    >> wine is built with mp3 support nowadays.
    >>
    >> Uninstall wine-mp3 and all should be fine.
    >>
    >> The dependencies have been fixed meanwhile btw, in the next snapshot
    >> wine should properly uninstall wine-mp3...
    >>
    >>

    >
    > Wine is not the only package having conflicts:
    >
    > Code:
    > *********************************
    >
    > File /usr/bin/dvdauthor
    > from install of
    > dvdauthor-0.7.2-1.1.x86_64 (openSUSE-Tumbleweed-Oss)
    > conflicts with file from package
    > dvdauthor07-0.7.2-1.1.x86_64 (@System)
    >
    > File /usr/bin/dvdunauthor
    > from install of
    > dvdauthor-0.7.2-1.1.x86_64 (openSUSE-Tumbleweed-Oss)
    > conflicts with file from package
    > dvdauthor07-0.7.2-1.1.x86_64 (@System)
    >
    > File /usr/bin/mpeg2desc
    > from install of
    > dvdauthor-0.7.2-1.1.x86_64 (openSUSE-Tumbleweed-Oss)
    > conflicts with file from package
    > dvdauthor07-0.7.2-1.1.x86_64 (@System)
    >
    > File /usr/bin/spumux
    > from install of
    > dvdauthor-0.7.2-1.1.x86_64 (openSUSE-Tumbleweed-Oss)
    > conflicts with file from package
    > dvdauthor07-0.7.2-1.1.x86_64 (@System)
    >
    > ***********************************************
    >
    > There are others as well.
    >


    It appears to me that with the latest tumbleweed update (201705822) that
    several packages have had their name changed causing a reinstall with
    the new name without a corresponding "obsoletes" in the spec file for
    the package with the old name. I'll also report this in the factory list.

    --
    Ken
    linux since 1994
    S.u.S.E./openSUSE since 1996

  6. #6
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,078

    Default Re: zypper recommends conflicting packages?

    On Thu, 25 May 2017 17:50:22 +0000, Ken Schneider wrote:

    > It appears to me that with the latest tumbleweed update (201705822) that
    > several packages have had their name changed causing a reinstall with
    > the new name without a corresponding "obsoletes" in the spec file for
    > the package with the old name. I'll also report this in the factory
    > list.


    Yup, there was something on the factory list about this from dimstar.
    Something related to anything linking to ncurses being rebuilt in order
    to resolve a crash issue.

    Jim



    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

  7. #7

    Default Re: zypper recommends conflicting packages?

    Quote Originally Posted by kensch View Post
    It appears to me that with the latest tumbleweed update (201705822) that
    several packages have had their name changed causing a reinstall with
    the new name without a corresponding "obsoletes" in the spec file for
    the package with the old name.
    Not really.
    Your problem is dvdauthor07 which never was part of the distribution (it only was available on Packman).
    If you uninstall that, your conflicts should be gone.

    dvdauthor has been added to the distribution/Tumbleweed a month ago, the package has been removed completely from Packman (for Tumbleweed at least).
    As there never was a dvdauthor07 in the distribution, the new packagers probably didn't think about obsoleting it (maybe they don't even know that this package existed).
    Last edited by wolfi323; 25-May-2017 at 11:25.

  8. #8
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,778
    Blog Entries
    3

    Default Re: zypper recommends conflicting packages?

    Quote Originally Posted by kensch View Post
    On 05/25/2017 09:35 AM, Ken Schneider wrote:
    > On 05/24/2017 06:56 PM, wolfi323 wrote:

    > File /usr/bin/dvdauthor
    > from install of
    > dvdauthor-0.7.2-1.1.x86_64 (openSUSE-Tumbleweed-Oss)
    > conflicts with file from package
    > dvdauthor07-0.7.2-1.1.x86_64 (@System)
    I saw something like that recently, but not with "dvdauthor". I don't remember the details.

    The important point here is that when it shows "(@System)", that's a package that is already installed, but is no longer in any of the repos.

    In a case like that, I normally say "yes" (i.e. ignore the conflicts).

    And, once the update is done, I go to Yast Software Management and then select the "Package Groups" view. There, I click on "orphaned packages", and that should list whatever is installed that is not in any enabled repo. I usually just delete those orphaned packages, though of course there might be special cases where you want to keep some.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  9. #9

    Default Re: zypper recommends conflicting packages?

    On 05/25/2017 01:53 PM, Jim Henderson wrote:
    > On Thu, 25 May 2017 17:50:22 +0000, Ken Schneider wrote:
    >
    >> It appears to me that with the latest tumbleweed update (201705822) that
    >> several packages have had their name changed causing a reinstall with
    >> the new name without a corresponding "obsoletes" in the spec file for
    >> the package with the old name. I'll also report this in the factory
    >> list.

    >
    > Yup, there was something on the factory list about this from dimstar.
    > Something related to anything linking to ncurses being rebuilt in order
    > to resolve a crash issue.
    >
    > Jim
    >
    >
    >


    Since dimstar has reported it no need for me to produce anymore noise.

    --
    Ken
    linux since 1994
    S.u.S.E./openSUSE since 1996

  10. #10

    Default Re: zypper recommends conflicting packages?

    Quote Originally Posted by kensch View Post
    Since dimstar has reported it no need for me to produce anymore noise.
    The only thing dimstar "reported" was that all packages using ncurses have been rebuilt to fix them crashing.

    Nothing has been renamed though, and that's totally unrelated to your dvdauthor file conflict.
    If you want to have that "fixed" in the package, you should definitely report it, either on the Factory mailinglist or even a bug report.
    To "fix" it on your own system, uninstall dvdauthor07 as mentioned, it's orphaned...
    Last edited by wolfi323; 26-May-2017 at 05:07.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •