Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Leap 42.3 Beta: tvtime fails to start

  1. #1
    Join Date
    Jun 2009
    Location
    Mangfall, Germany
    Posts
    1,490

    Default Leap 42.3 Beta: tvtime fails to start

    hi,

    after recent updates tvtime no longer works on Leap 42.3 Beta

    when staring from the cmd-prompt the following is returned

    Code:
    A780GM-m1<2017-05-23 11:25:03><~>... tvtime
    Running tvtime 1.0.11.
    Reading configuration from /etc/tvtime/tvtime.xml
    Reading configuration from /home/michael/.tvtime/tvtime.xml
    xvoutput: No XVIDEO port which supports YUY2 or YV12 or I420 images found.
    *** tvtime requires hardware overlay support from your video card
    *** If unsure, please check with your distribution to see if your
    *** X driver supports hardware overlay surfaces.
    A780GM-m1<2017-05-23 11:25:14><~>...
    qv4l2, motv and mtt work fine

    tvtime worked ok with Leap 42.2 and on Leap 42.3 and Alpha (initially) but has not worked on Tumbleweed for a long time!

    anyone any ideas what's missing?
    or
    what needs to be done?


    cheers
    Last edited by malcolmlewis; 30-May-2017 at 09:37. Reason: Fix Prefix

  2. #2
    Join Date
    Jun 2009
    Location
    Mangfall, Germany
    Posts
    1,490

    Default Re: Leap 42.3 Beta: tvtime fails to start

    ps.

    vlc also ok for watching tv streams

  3. #3
    Join Date
    Jun 2009
    Location
    Mangfall, Germany
    Posts
    1,490

    Default Re: Leap 42.3 Beta: tvtime fails to start

    just sharing

    tvtime-1.0.11-1.mga6.x86_64 runs ok on Leap 42.3 Beta, see quote

    but same problem still there when run on Tumbleweed
    with Mesa-17.1.0-162.1.x86_64 and xorg-x11-server-1.19.3-1.1.x86_64

    run out of time!

    Comment # 5 on bug 84478

    Tvtime finally got one update and since version 1.0.9 have this patch:

    "Add support for planar yuv formats"

    I'm using tvtime 1.0.11, the latest version, and it works fine in mesa 17.1 using AMDGPU, so GLAMOR as xv

    So tvtime do not need anymore the YUY2, i do not know if any other app uses YUY2

    Comment # 6 on bug 84478

    tvtime-1.0.2-269.2.x86_64 replaced with tvtime-1.0.11-1.mga6.x86_64
    with

    tvtime starts and runs ok

    thanks for the info
    hth someone else

  4. #4

    Default Re: Leap 42.3 Beta: tvtime fails to start

    Well, the problem seems to be obvious:
    Quote Originally Posted by keellambert View Post
    Code:
    xvoutput: No XVIDEO port which supports YUY2 or YV12 or I420 images found.
    *** tvtime requires hardware overlay support from your video card
    *** If unsure, please check with your distribution to see if your
    *** X driver supports hardware overlay surfaces.
    Apparently there either has been a change to the graphics driver you are using (e.g. XVIDEO support removed), or maybe you are using a different video driver that doesn't support it in the first place.
    (e.g. AFAIK for certain intel chips, "modesetting" is now used by default instead of "intel")

    PS: tvtime 1.0.11 is available in the multimedia:apps repo for 42.3 too, you don't need to install a Mageia package...

  5. #5
    Join Date
    Jun 2009
    Location
    Mangfall, Germany
    Posts
    1,490

    Default Re: Leap 42.3 Beta: tvtime fails to start

    fwiw

    on Leap 42.3 Beta, tvtime works with the following setup

    graphics driver : "saa7134"
    card : "LifeView FlyVIDEO3000"
    bus_info : "PCI:0000:03:05.0"
    version : 4.11.3

    and

    xorg-x11-server-7.6_1.18.3-15.5
    on Tumbleweed (update as of today) tvtime does not work with setup

    graphics driver : saa7134
    card : LifeView FlyVIDEO3000
    Bus info : PCI:0000:03:05.0
    Driver version : 4.11.2

    and

    xorg-x11-server-1.19.3-1.1
    tvtime did not run on Tumbleweed after updating graphics driver to version 4.11.3

    ==========================================================

    Tumbleweed and xorg-x11-server-7.6_1.18.3-15.5 are not yet compatible SO BE WARNED!

    cheers

  6. #6

    Default Re: Leap 42.3 Beta: tvtime fails to start

    Quote Originally Posted by keellambert View Post
    graphics driver : "saa7134"

    That's not the graphics driver, but the driver for your TV card.

    Tumbleweed and xorg-x11-server-7.6_1.18.3-15.5 are not yet compatible SO BE WARNED!
    As I wrote, it probably depends on the actual *graphics* driver in use.

    I don't think they are "incompatible" in general.
    But I cannot test as I don't run Tumbleweed (nor 42.3 beta), nor do I have an analog TV card here any more.
    Last edited by wolfi323; 31-May-2017 at 10:11.

  7. #7
    Join Date
    Jun 2009
    Location
    Mangfall, Germany
    Posts
    1,490

    Default Re: Leap 42.3 Beta: tvtime fails to start

    hi,

    on Leap 42.3 Beta, installed are
    libdrm_radeon1-2.4.76-1.2.x86_64
    libdrm_radeon1-32bit-2.4.76-1.2.x86_64

    Graphics: Advanced Micro Devices [AMD/ATI] RS780 [Radeon HD 3200]
    Display Server: X.Org 1.18.3 drivers: ati,radeon (unloaded: modesetting,fbdev,vesa)
    Resolution: 1680x1050@59.95hz, 1920x1080@60.00hz
    GLX Renderer: Gallium 0.4 on AMD RS780 (DRM 2.49.0 / 4.10.15-2-default, LLVM 3.8.0)
    GLX Version: 3.0 Mesa 17.0.4 Direct Rendering: Yes

    on Tumbleweed, installed are
    libdrm_radeon1-2.4.80-1.1.x86_64
    libdrm_radeon1-32bit-2.4.80-1.1.x86_64
    Graphics: Advanced Micro Devices [AMD/ATI] RS780 [Radeon HD 3200]
    Display Server: X.Org 1.19.3 driver: radeon
    Resolution: 1680x1050@59.95hz, 1920x1080@60.00hz
    GLX Renderer: Gallium 0.4 on llvmpipe (LLVM 4.0, 128 bits)
    GLX Version: 3.0 Mesa 17.1.0 Direct Rendering: Yes

    cheers

  8. #8
    Join Date
    Jun 2009
    Location
    Mangfall, Germany
    Posts
    1,490

    Default Re: Leap 42.3 Beta: tvtime fails to start

    fwiw

    to remove xorg-x11-server-7.6_1.18.3-15.5 from Tumbleweed an upgrade was done from DVD

    this re-installed xorg-x11-server-1.19.3-1.2.x86_64 and lots of other changes

    tvtime works ok in the modified Tumbleweed

    end of saga?

    thanks again for the reply's

  9. #9

    Default Re: Leap 42.3 Beta: tvtime fails to start

    Quote Originally Posted by keellambert View Post
    to remove xorg-x11-server-7.6_1.18.3-15.5 from Tumbleweed an upgrade was done from DVD

    this re-installed xorg-x11-server-1.19.3-1.2.x86_64 and lots of other changes
    xorg-x11-server-7.6_1.18.3 is an *older* version that 1.19.3. Only the non-sensical 7.6_ has been removed from the version.

    "zypper dup" should have upgraded that as well, and that's the reason why "zypper dup" is the preferred way to update Tumbleweed.
    (if you use additional repos, you can/should add the "--no-allow-vendor-change" option to prevent zypper switching packages to versions from other repos)

    Btw, that upgrade happened months ago already.
    No wonder that you have problems with the old version, yes that is "incompatible" with the rest of Tumbleweed.
    Actually you are lucky that only tvtime didn't work I suppose...

  10. #10
    Join Date
    Jun 2009
    Location
    Mangfall, Germany
    Posts
    1,490

    Default Re: Leap 42.3 Beta: tvtime fails to start

    Quote Originally Posted by wolfi323 View Post
    "zypper dup" should have upgraded that as well, and that's the reason why "zypper dup" is the preferred way to update Tumbleweed.
    zypper dup identifies xorg-x11-server-7.6_1.18.3.x86_64 as an upgrade for xorg-x11-server-1.19.3-1.2.x86_64
    so the incorrect logic prevails or not?

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •