Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: 2.1 What is Old! Don.t hurt me no more Perl 5.18 in Leap 42.3.

  1. #1

    Angry 2.1 What is Old! Don.t hurt me no more Perl 5.18 in Leap 42.3.

    opensuse 13.2 - perl 5.20.

    buggy regex utf8 in 5.18 with problem like this https://foswiki.org/Tasks/Item13817.


    • Perl 5.20.2: 0m1.97 seconds
    • Perl 5.18.4: 11m17.921s
    • Perl 5.18.4: 2m24.405s (patched)

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,153

    Default Re: 2.1 What is Old! Don.t hurt me no more Perl 5.18 in Leap 42.3.

    Sorry, but what is the question?

    In any case openSUSE 13.2 is out of support already for some time.
    Henk van Velden

  3. #3

    Exclamation Re: 2.1 What is Old! Don.t hurt me no more Perl 5.18 in Leap 42.3.

    Quote Originally Posted by hcvv View Post
    Sorry, but what is the question?
    Question is "why in unsupport version opensuse 13.2 perl version newer then leap 42.3?

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,153

    Default Re: 2.1 What is Old! Don.t hurt me no more Perl 5.18 in Leap 42.3.

    There is no Leap 42.3 yet. They are putting it together and testing it. They start with the 42.2 packages and then decide product by product what newer version to put in. I guess they are not already busy with Perl. Wait until at least some beta release comes out to check what is in 42.3.
    Henk van Velden

  5. #5

    Default Re: 2.1 What is Old! Don.t hurt me no more Perl 5.18 in Leap 42.3.

    Quote Originally Posted by vicplus View Post
    Question is "why in unsupport version opensuse 13.2 perl version newer then leap 42.3?
    Because Leap 42 is based on SLE 12, which is *older* than 13.2 (and perl is one of the packages coming from SLE and maintained by SUSE).

    TBH, I very much doubt that they would upgrade perl to a newer version in 42.3 (i.e. SLE 12 SP 3), especially considering that they didn't do that for 42.1 or 42.2 too. SLE 12 SP 3 and Leap 42.3 are actually in Beta already, yesterday was the deadline for "major package updates" (https://en.opensuse.org/openSUSE:Roadmap).
    SLE 15 (and therefore Leap 15) will once again be fully based on/synced with Tumbleweed (at the beginning at least), so it likely will get the latest perl at the time.

    If you have a specific problem with the perl in Leap 42.2/42.3, you should file a bug report at http://bugzilla.opensuse.org (same username/password as here). Maybe the fixes/improvements can be backported.

  6. #6
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,846
    Blog Entries
    15

    Default Re: 2.1 What is Old! Don.t hurt me no more Perl 5.18 in Leap 42.3.

    Quote Originally Posted by vicplus View Post
    opensuse 13.2 - perl 5.20.

    buggy regex utf8 in 5.18 with problem like this https://foswiki.org/Tasks/Item13817.


    • Perl 5.20.2: 0m1.97 seconds
    • Perl 5.18.4: 11m17.921s
    • Perl 5.18.4: 2m24.405s (patched)
    Hi
    Copying and pasting some text from a application bug probably won't glean any help (in fact may be construed as trolling).

    So do you use the application? Can you provide your own use case where the error/bug shows up? If so, then best to raise a bug report openSUSE:Submitting bug reports - openSUSE

    Since the application is not part of the openSUSE distribution you may have a hard time convincing the perl maintainers it's an issue...
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  7. #7

    Default Re: 2.1 What is Old! Don.t hurt me no more Perl 5.18 in Leap 42.3.

    Quote Originally Posted by hcvv View Post
    There is no Leap 42.3 yet. They are putting it together and testing it. They start with the 42.2 packages and then decide product by product what newer version to put in. I guess they are not already busy with Perl. Wait until at least some beta release comes out to check what is in 42.3.
    ok. I just wanted to pay attention

    https://build.opensuse.org/package/show/openSUSE%3ALeap%3A42.3/perl


  8. #8

    Default Re: 2.1 What is Old! Don.t hurt me no more Perl 5.18 in Leap 42.3.

    Quote Originally Posted by malcolmlewis View Post
    Hi
    in fact may be construed as trolling
    Its just constructed like that, but perl in opensise looks like its not mainteined.


    This error was not fixed at the end 2015, I think it will never be fixed and do not see the point of sending bugreport. Especially when the latest versions of perl support Unicode much better. I just wanted to pay attention about very old version perl in Leap.

  9. #9
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,846
    Blog Entries
    15

    Default Re: 2.1 What is Old! Don.t hurt me no more Perl 5.18 in Leap 42.3.

    Quote Originally Posted by vicplus View Post
    Its just constructed like that, but perl in opensise looks like its not mainteined.


    This error was not fixed at the end 2015, I think it will never be fixed and do not see the point of sending bugreport. Especially when the latest versions of perl support Unicode much better. I just wanted to pay attention about very old version perl in Leap.
    Hi
    Perhaps you don't understand the openSUSE Leap/ SUSE Linux Enterprise model, bug fixes and security fixes are backported (not necessarily features), the version numbers doesn't mean something isn't fixed, you need to inspect the changelog first.

    Likewise if a particular bug is not reported so the maintainers can review and see if it's fixable, then it won't get fixed.

    Code:
    rpm -q perl --changelog | grep utf
    - fix regex engine hanging on bad utf8 [bnc976584] [CVE-2015-8853]
      new patch: perl-badutf8hang.diff
    - fix memory leak in 'use utf8' handling [bnc#928292]
      new patch: perl-utf8leak.diff
    - fixed utf8 handling in Net::Cmd [bnc#493978]
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  10. #10
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: 2.1 What is Old! Don.t hurt me no more Perl 5.18 in Leap 42.3.

    you can get perl 5.24 for LEAP from a user repo try
    https://software.opensuse.org/package/perl
    I think there is an updated LEAP version in the devel:languages:perl repo
    http://download.opensuse.org/reposit...nguages:/perl/
    but not for 42.3 as it's not out yet

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •