Results 1 to 7 of 7

Thread: KDE - multi monitor weird behavior

  1. #1
    Join Date
    May 2015
    Location
    Italy
    Posts
    371

    Default KDE - multi monitor weird behavior

    Hi all,
    since about two week I have a weird issue with my dual-monitor setup.

    Whenever I move a window from the primary display to the secondary, as soon as the window enters completely the secondary monitor it disappears.
    Upon closer inspection, it turns out that the window is translated downwards till it is completely outside of the viewport, with only a tiny 1-pixel line still visible.
    If I maximize the window it correctly fills the secondary monitor. If I restore it, it hides again.
    If I grab the tiny 1-pixel line of the upper border of the window I can resize it, so a bigger part of it is shown in the secondary monitor. However, as soon as I try to move it, it is hidden again.

    Anybody else seeing this?
    Is it an upstream KDE problem? I have found nothing by googling around.

    Thank you in advance
    Cris

    p.s. don't know if it's relevant but my plasmashell is v5.9.5
    Last edited by Cris70; 20-May-2017 at 03:09. Reason: add more info
    Desktop: OpenSUSE Tumbleweed (x86_64) - AMD FX-8350 Eight-Core Processor, 16Gb RAM, 120GB Samsung Evo 840 SSD
    Laptop: OpenSUSE Tumbleweed (x86_64) - Thinkpad T440 - Intel i5-4210U, 12Gb RAM, 250GB Samsung EVO 750 SSD

  2. #2
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    2,844

    Default Re: KDE - multi monitor weird behavior

    It's possible that the relative position between monitors is incorrect - something like the second monitor is to the right *and* above of the first one, for example, instead of only to the right.

    You can check it in system settings > Screen and Monitor > Screen configuration (or similar, depending on translation).

  3. #3
    Join Date
    May 2015
    Location
    Italy
    Posts
    371

    Default Re: KDE - multi monitor weird behavior

    Hi Bruno, and thank you for your reply.

    Quote Originally Posted by brunomcl View Post
    It's possible that the relative position between monitors is incorrect - something like the second monitor is to the right *and* above of the first one, for example, instead of only to the right.
    You can check it in system settings > Screen and Monitor > Screen configuration (or similar, depending on translation).
    Yes, that was my first thought, too.
    Unfortunately everything seems correct: the left monitor is at (0,0) and the right monitor is at (1920,0). Both are identical monitors configured for 1920x1080 resolution.

    This is what xrandr has to say (DP2-2 is the left monitor, DP2-3 is the right one):
    Code:
    cristiano@xmper8q3 [~]$ xrandr --listmonitors
    Monitors: 2
     0: +*DP2-3 1920/480x1080/270+1920+0  DP2-3
     1: +DP2-2 1920/480x1080/270+0+0  DP2-2
    
    Seems correct to me...

    Cris
    Desktop: OpenSUSE Tumbleweed (x86_64) - AMD FX-8350 Eight-Core Processor, 16Gb RAM, 120GB Samsung Evo 840 SSD
    Laptop: OpenSUSE Tumbleweed (x86_64) - Thinkpad T440 - Intel i5-4210U, 12Gb RAM, 250GB Samsung EVO 750 SSD

  4. #4

    Default Re: KDE - multi monitor weird behavior

    New panel created on the second screen lately?

    May something to do with:

    https://bugs.kde.org/show_bug.cgi?id=371199

    If so, tough luck, I do not think KDE will repair it in the next few years.foreseeable future
    Not important enough

  5. #5
    Join Date
    May 2015
    Location
    Italy
    Posts
    371

    Default Re: KDE - multi monitor weird behavior

    Yes, thank you nietgiftig!!

    That's exactly the behavior I see, and I just changed the setup of one of my panels so that it is vertical and it is placed between the two monitors.
    I added my comment to the bug report, let's hope it gets fixed sooner than what you think.

    Anyway, for anyone reading this thread, one comment in the bug report says that dragging with the ALT key is a workaround, so if you're affected try that trick.
    I won't be able to try it until tomorrow.

    Cris
    Desktop: OpenSUSE Tumbleweed (x86_64) - AMD FX-8350 Eight-Core Processor, 16Gb RAM, 120GB Samsung Evo 840 SSD
    Laptop: OpenSUSE Tumbleweed (x86_64) - Thinkpad T440 - Intel i5-4210U, 12Gb RAM, 250GB Samsung EVO 750 SSD

  6. #6
    Join Date
    May 2015
    Location
    Italy
    Posts
    371

    Default Re: KDE - multi monitor weird behavior

    I can now confirm that dragging a window while pressing the ALT key is a workaround for the bug.

    Thank you!

    Cris
    Desktop: OpenSUSE Tumbleweed (x86_64) - AMD FX-8350 Eight-Core Processor, 16Gb RAM, 120GB Samsung Evo 840 SSD
    Laptop: OpenSUSE Tumbleweed (x86_64) - Thinkpad T440 - Intel i5-4210U, 12Gb RAM, 250GB Samsung EVO 750 SSD

  7. #7

    Default Re: KDE - multi monitor weird behavior

    You can try to use Latte dock as panel on the left of the right monitor.
    Maybe that does not give you the problem as with a normal panel.
    I'm keeping for the moment my trysty mint kde 17.3 (KDE4) as main so I cannot try this.

    Strange Development from KDE, when it is almost finished they throw everything away, and start blanco.
    KDE3 -> KDE4 -> KDE5

    KDE has only hobbyist developers I guess.
    So if there is not a Dev who uses the same setup and has troubles with it, it will not be patched.

    Would like they spend more time on the functionality of the DE than on all those applications.
    meh, such is life

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •