Results 1 to 3 of 3

Thread: Special Window/Application Settings inconsistent and/or non-persistent

  1. #1
    Join Date
    Apr 2013
    Location
    Sydney, AU
    Posts
    243

    Default Special Window/Application Settings inconsistent and/or non-persistent

    My daily workflow is dependant upon multi-monitors (4) utilising multi-desktops (4) across multi-activities (5)

    Each combination of these is set with specific applications to be loaded at boot.

    While this area of KDE is clearly still maturing IMO, under 42.1 i at least I was able work with the couple of bugs after becoming acquainted with them.

    After upgrading to 42.2 however it is clear that this area ...-viz- Special Window Settings / Special Application Setting ... has been upset dramatically to the point where it is usable/unreliable/inconsistent.

    There is such inconsistency in behaviour between window/application settings that i cannot find a common thread.

    Broadly speaking settings are either completely lost and/or not adhered to ... but this behaviour is not consistent across all windows and applications???

    This is major for me as readjusting and/or setting up workflow across desktops/activities/screens every time i restart the machine is tedious and time wasting.

    I cannot find a lot of feedback on this topic across the forums.

    I hope somebody can help however .. in the meantime am forced back to 42.1 where i can get some work done

    Code:
      Hardware Class: graphics card
      Model: "nVidia GK106 [GeForce GTX 650 Ti]"
      Vendor: pci 0x10de "nVidia Corporation"
      Device: pci 0x11c6 "GK106 [GeForce GTX 650 Ti]"
    openSUSE Leap 15.1 | KDE Plasma 5.12.8 | Frameworks 5.55.0 | Qt 5.9.7 | Kernel 4.12.14-lp151.27-default | Procs 4 x i5-2500 CPU @ 3.3.GHz | 15.6 GiB RAM | 4 Monitors

  2. #2
    Join Date
    Apr 2013
    Location
    Sydney, AU
    Posts
    243

    Default Re: Special Window/Application Settings inconsistent and/or non-persistent

    UPDATE:

    Upon further investigation i do believe i have narrowed down the cause of this issue .. well for the major part at any rate.

    Loading applications using AUTOSTART ignores/misreads/mis-interprets configuration instructions (Size and Position) saved under 'Special Window Settings" and/or "Special Application Settings.

    Workaround is to disable AUTOSTART and load applications manually after system startup using the Application Menu Launcher (Start Menu) ..... each is then loaded as per the Window Rules created using Special Window and Application Settings as expected.
    openSUSE Leap 15.1 | KDE Plasma 5.12.8 | Frameworks 5.55.0 | Qt 5.9.7 | Kernel 4.12.14-lp151.27-default | Procs 4 x i5-2500 CPU @ 3.3.GHz | 15.6 GiB RAM | 4 Monitors

  3. #3

    Default Re: Special Window/Application Settings inconsistent and/or non-persistent

    I read this thread a little late in the day to reply and just wanted to mention that my 42.2 / KDE restores the desktop as it was when I logged out or powered down without me doing anything.. Firefox for instance appears in one place and then jumps to where it was.

    Sort of suggests that all people need do is leave what ever they had up alone and just power down and it will be restored when they log in. I only use one monitor though.

    John
    -
    Leap 42.2 KDE 5.26
    3.6gig Xeon, 64bit SATA Raid home - Linux Raid 1
    All software on a flash drive, SATA swap & Temp files,

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •