Results 1 to 6 of 6

Thread: puddletag 1.2.0 doesn't start

  1. #1

    Default puddletag 1.2.0 doesn't start

    I am posting this issue here on the forum just in case someone else encounters the same or a similar issue and knows how to fix it. I have filed a bugzilla report, complete with an strace log.

    On a fully updated Tumbleweed, I did install puddletag 1.2.0 from the openSUSE multimedia repos. Installation itself ran smoothly, pulling along tons of packages (I guess for python 2 as compared to 3). Remark: No previous install of puddletag 1.0.5 from the "regular" openSUSE Tumbleweed repos.

    Unfortunately, puddletag just won't start under Tumbleweed. It does work fine under Leap 42.2 though. Any ideas out there? As stated above, an official bug report has been filed yesterday and is hopefully being processed. Thanks in advance for any ideas, fixes, confirmations of encountering the same issue or confirmations of seeing puddletag 1.2.0 run fine under Tumbleweed.

  2. #2

    Default Re: puddletag 1.2.0 doesn't start

    My posting here as well as my bugzilla filing with an strace log being sent with it) are almost three weeks old, but NOTHING has happened on either side yet. Thus, I was trying to get more clarity into the issue.

    puddletag 1.2.0 just doesn't start under Tumbleweed, only the bouncing icon for a little moment, then nothing. Under Leap 42.2., all is fine with puddletag 1.2.0. For both operating systems, the multimedia:apps and multimedia:libs repos needed to be pulled in to get the latest puddletag version.

    Calling puddletag 1.2.0 from the terminal, the output is:
    Code:
    Traceback (most recent call last):
      File "/usr/bin/puddletag", line 317, in <module>
        from PyQt4.QtGui import QApplication, QPixmap, QSplashScreen, QIcon
    ImportError: No module named sip
    The problem seems to be with SIP. Under Leap 42.2., there is a package called python-sip installed from one of the official release repos. I suppose it is this package which helps puddletag start up. Under Tumbleweed, there is no package pyton-sip in the official release repos; this one only is in unstable repos as of now. On the other hand, Tumbleweed has two official packages called python2-sip and python3-sip, which are not installed. Well, I just don't feel like installing the latter two and eventually pull along many more packages bloating my system in order to try to find out if at all and under what conditions I could get puddletag 1.2.0 to work under Tumbleweed. (Moreover, pythonN-sip seems to come in various versions depending on KDE and Qt versions, looks like dangerous territory to me...)

    Please, I would be happy to receive comments from the forum community, advice and what else. Moreover, I would be happy if one or more of the Tumbleweed package maintainers could give this issue (cf. also the bugzilla report) a closer look and get it ironed out.

    Well, this is just what I gather from looking at Leap and Tumbleweed installations in comparison. Not necessarily correct, no insult intended towards package maintainers. Anyway, this issue seems to be kind of stupid, and it might just take a little fix for Tumbleweed to shine again!

  3. #3

    Default Re: puddletag 1.2.0 doesn't start

    Well, figured some do-it-yourself might help more than hoping for any response from package maintainers...

    I google'd python-sip and I checked the YaST remarks, dependencies etc. for the various python-sip and pythonN-sip packages carefully. Alas, the python2-sip package carries this little note to replace python-sip < 4.19.2. This caused me to manually install python2-sip, and - guess what? - puddletag 1.2.0 starts fine now.

    SO, THIS NOW DEFINITELY IS THE TASK FOR THE PACKAGE MAINTAINERS OF openSUSE TUMBLEWEED, who seem to have forgotten to take python-sip to a higher version called python2-sip in the package dependencies of puddletag 1.2.0.

  4. #4

    Default Re: puddletag 1.2.0 doesn't start

    Another annoying issue does show up now, though: puddletag 1.2.0 uses a small point size for all its typefaces all over the place, in the menu bar, the data display windows etc. This looks quite awful as compared to all other applications under Tumbleweed KDE !

    Any ideas out there for this issue now? Thanks.

  5. #5

    Default Re: puddletag 1.2.0 doesn't start

    Quote Originally Posted by 111MilesToGo View Post
    SO, THIS NOW DEFINITELY IS THE TASK FOR THE PACKAGE MAINTAINERS OF openSUSE TUMBLEWEED, who seem to have forgotten to take python-sip to a higher version called python2-sip in the package dependencies of puddletag 1.2.0.
    Maybe it would help if you didn't file the bug report against the "Software Portal", which is the package search page...
    The puddletag package maintainer(s) won't even see this, and I think the current assignee is no longer active.

    In the future, if you are not sure against which product/component to file the bug report, choose Other or 3rd party software. Then the screening team will take a look at it.
    (may take a while until it is assigned properly, but better than assigning it to the wrong or maybe even missing people in the first place...)

    And yes, the package has no dependency on python(2)-sip at all, this probably would need to be added.

  6. #6

    Default Re: puddletag 1.2.0 doesn't start

    Thanks, wolfi323, for all this help. Sorry for filing my original bug against s.th. wrong - will do better next time.

    As to puddletag, this thread could be marked "almost solved" if there were such a thing.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •