Results 1 to 5 of 5

Thread: System can't find installed dependencies

  1. #1

    Default System can't find installed dependencies

    I was trying to install wine first from yast when I encountered an error about missing dependencies, which noone was providing. Somehow by manually installing proper dependencies I've got it running.
    Now I have the same problem with steam. In other OpenSUSE versions with gnome3 or xfce I could always do that in 1 click, but now something is really weird happening, it is trying to find a dependency which is already installed on my computer

    https://pp.userapi.com/c638827/v6388...QK6yEiyEmw.jpg
    The zypper install command says exactly this:

    Problem: nothing is providing libglvd0-32bit >= 0.1.0, which is required for Mesa-libGL1-32bit-17.0.5-161.1.x86_64
    Solution 1: don't install steam~
    Solution 2: damage Mesa-libGL1-32bit-17.0.5-161.1.x86_64, ignoring one of its dependencies

    Opensuse 64 bit with KDE

    It actually IS in installed in my pc, but just can't find it. I can't install Mesa-libGL1 32 bit either because it needs the same package

  2. #2
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,882

    Default AW: System can't find installed dependencies

    libglvnd0 is not libglvnd.

  3. #3

    Default Re: AW: System can't find installed dependencies

    Quote Originally Posted by Sauerland View Post
    libglvnd0 is not libglvnd.
    anyway, it doesn't install with yast as usual. Should I just wait until repositories update their package lists?

  4. #4

    Default Re: AW: System can't find installed dependencies

    Quote Originally Posted by Sauerland View Post
    libglvnd0 is not libglvnd.
    I have just found a 2days old subreddit topic about this

    "The library changed its name to libglvnd, without the zero at the end." - Gnome tumbleweed staff replied...maybe i should just really wait

  5. #5
    Join Date
    May 2015
    Location
    Italy
    Posts
    371

    Default Re: System can't find installed dependencies

    Today I tried to update but I get a lot of messages like this:
    Code:
    File /usr/lib/libEGL.so.1.0.0
      from install of
         libglvnd-32bit-0.1.1~20161222~dc16f8c-3.1.x86_64 (Main Repository (OSS))
      conflicts with file from package
         libglvnd0-32bit-0.1.1~20161222~dc16f8c-2.1.x86_64 (@System)
    By looking for information on those packages I get this:
    Code:
    cris@PolariSuse [~]$ zypper se -s libglvnd
    Loading repository data...
    Reading installed packages...
    
    S | Name                     | Type    | Version                    | Arch   | Repository
    --+--------------------------+---------+----------------------------+--------+--------------------------
    i | libglvnd                 | package | 0.1.1~20161222~dc16f8c-3.1 | x86_64 | Main Repository (OSS)
    v | libglvnd                 | package | 0.1.1~20161222~dc16f8c-3.1 | i586   | Main Repository (OSS)
      | libglvnd-32bit           | package | 0.1.1~20161222~dc16f8c-3.1 | x86_64 | Main Repository (OSS)
      | libglvnd-debuginfo       | package | 0.1.1~20161222~dc16f8c-3.1 | x86_64 | openSUSE-Tumbleweed-Debug
      | libglvnd-debuginfo       | package | 0.1.1~20161222~dc16f8c-3.1 | i586   | openSUSE-Tumbleweed-Debug
      | libglvnd-debuginfo-32bit | package | 0.1.1~20161222~dc16f8c-3.1 | x86_64 | openSUSE-Tumbleweed-Debug
      | libglvnd-debugsource     | package | 0.1.1~20161222~dc16f8c-3.1 | x86_64 | openSUSE-Tumbleweed-Debug
      | libglvnd-debugsource     | package | 0.1.1~20161222~dc16f8c-3.1 | i586   | openSUSE-Tumbleweed-Debug
    i | libglvnd-devel           | package | 0.1.1~20161222~dc16f8c-3.1 | x86_64 | Main Repository (OSS)
    v | libglvnd-devel           | package | 0.1.1~20161222~dc16f8c-3.1 | i586   | Main Repository (OSS)
      | libglvnd-devel-32bit     | package | 0.1.1~20161222~dc16f8c-3.1 | x86_64 | Main Repository (OSS)
    i | libglvnd0-32bit          | package | 0.1.1~20161222~dc16f8c-2.1 | x86_64 | (System Packages)


    So yes, it seems it changed name from
    libglvnd0-32bit to libglvnd-32bit.

    Now, how do I clear the mess?
    Should I simply reply "yes" when zypper asks me this question?
    Code:
    File conflicts happen when two packages attempt to install files with the same name but different contents. If you continue, conflicting files will be replaced losing the previous content.
    Continue? [yes/no] (no):
    
    Or will it mess up my system?

    I've tried to uninstall
    libglvnd0-32bit but that would remove a ton of packages:
    Code:
    cris@PolariSuse [~]$ sudo zypper rm libglvnd0-32bit
    [sudo] password for root:
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...
    
    The following 3 applications are going to be REMOVED:
      Cuttlefish Desktop Steam
    
    The following 22 packages are going to be REMOVED:
      draftsight gtk2-engine-oxygen-32bit gtk2-tools-32bit libcairo2-32bit libcanberra-gtk0-32bit libcanberra-gtk2-module-32bit libGLU1-32bit libglvnd0-32bit libgtk-2_0-0-32bit
      libpango-1_0-0-32bit libqt4-qt3support-32bit libqt4-x11-32bit libQtWebKit4-32bit Mesa-32bit Mesa-libEGL1-32bit Mesa-libGL1-32bit skype steam wine wine-32bit wine-mp3 wine-mp3-32bit
    
    22 packages to remove.
    After the operation, 2,1 GiB will be freed.
    Continue? [y/n/...? shows all options] (y): n
    So I'd rather prefer another way, if there's a clean one.

    Thank you in advance
    Cris
    Desktop: OpenSUSE Tumbleweed (x86_64) - AMD FX-8350 Eight-Core Processor, 16Gb RAM, 120GB Samsung Evo 840 SSD
    Laptop: OpenSUSE Tumbleweed (x86_64) - Thinkpad T440 - Intel i5-4210U, 12Gb RAM, 250GB Samsung EVO 750 SSD

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •