Results 1 to 7 of 7

Thread: disabling automatic screen shutoff / make "xset s off" permanent

  1. #1
    Join Date
    Apr 2016
    Location
    North America
    Posts
    532

    Default disabling automatic screen shutoff / make "xset s off" permanent

    I'm trying to make "xset s off" permanent.

    Screen Saver:
    prefer blanking: yes allow exposures: yes
    timeout: 600 cycle: 600
    Where is the default value of "timeout: 600" set?

    Code:
    Section "Monitor"
      Identifier "LVDS0"
      Option "DPMS" "false"
    EndSection
    
    Section "ServerLayout"
      Identifier "ServerLayout0"
      Option "StandbyTime" "0"
      Option "SuspendTime" "0"
      Option "OffTime"     "0"
      Option "BlankTime"   "0"
    EndSection
    https://wiki.archlinux.org/index.php...ment_Signaling

    I tried adding that to /etc/X11/xorg.conf.d/50-monitor.conf (why 50 btw?)
    but it didn't seem to have any effect.
    Is the "Identifier" value arbitrary, or does it need to be something specific?
    I can't find any information regarding what the value is supposed to be, or how to determine it.
    I also tried "Default Monitor" as seen in the file's comments.

    Other people suggest simply adding "xset s off" to ~/.profile or ~/.xinitrc

  2. #2

    Default Re: disabling automatic screen shutoff / make "xset s off" permanent

    If your using kde did you try start button settings-system settings- power management ?

    What ever desktop you are using maybe totally in control of this sort of thing. Hence wayland arriving - good time to do it as x hardly does anything any more. That's a quote.

    I'm on kde leap and just disabled this there. Also need to do the same thing with lxde - if it has the facility.

    John
    -
    Leap 42.2 KDE 5.26
    3.6gig Xeon, 64bit SATA Raid home - Linux Raid 1
    All software on a flash drive, SATA swap & Temp files,

  3. #3
    Join Date
    Aug 2008
    Location
    Texas, US
    Posts
    227

    Default Re: disabling automatic screen shutoff / make "xset s off" permanent

    I'm not sure if it's still applicable, but I had always used a script file that I made to have KDE run at startup with the commands: xset dpms 0 0 0; xset -dpms

    In earlier versions of openSUSE, xset would often misbehave and ignore desktop settings. The commands are run as a regular user so it should only be valid as long as you are logged in.

    I just checked in 42.2 using xset -q and it seems that the KDE power manager settings are being followed correctly. My xset has DPMS turned off and all timeouts set to zero.

  4. #4
    Join Date
    Apr 2016
    Location
    North America
    Posts
    532

    Default Re: disabling automatic screen shutoff / make "xset s off" permanent

    I'm using OpenBox.

    Is it necessary to run mkinitrd after modifying 50-monitor.conf?

  5. #5
    Join Date
    Nov 2013
    Location
    Kamloops, BC, Canada
    Posts
    3,974

    Default Re: disabling automatic screen shutoff / make "xset s off" permanent

    Quote Originally Posted by ravas View Post
    I'm trying to make "xset s off" permanent.



    Where is the default value of "timeout: 600" set?

    Code:
    Section "Monitor"
      Identifier "LVDS0"
      Option "DPMS" "false"
    EndSection
    
    Section "ServerLayout"
      Identifier "ServerLayout0"
      Option "StandbyTime" "0"
      Option "SuspendTime" "0"
      Option "OffTime"     "0"
      Option "BlankTime"   "0"
    EndSection
    https://wiki.archlinux.org/index.php...ment_Signaling

    I tried adding that to /etc/X11/xorg.conf.d/50-monitor.conf (why 50 btw?)
    but it didn't seem to have any effect.
    Is the "Identifier" value arbitrary, or does it need to be something specific?
    I can't find any information regarding what the value is supposed to be, or how to determine it.
    I also tried "Default Monitor" as seen in the file's comments.

    Other people suggest simply adding "xset s off" to ~/.profile or ~/.xinitrc
    I handle it with the following script I created a few years back:

    First, create a file with the following contents, give it a meaningfull name such as "noblankscreen" or something:
    Code:
    #!/bin/sh
        xset dpms 0 0 0
        xset -dpms
        xset s noblank
    Save it in /bin, set the permissions to rwxr-xr-x

    Set it as a login script for each user you want to disable screen blanking for.

    Log out, log back in, or reboot & log in.

    Check to see that it all worked by opening a terminal and run:
    Code:
    xset q
    You should see something similar to the following lines:
    Code:
    Screen Saver:
      prefer blanking:  no    allow exposures:  yes
    
    DPMS (Energy Star):
      Standby: 0    Suspend: 0    Off: 0
      DPMS is Disabled
    BTW: It helps to go into the user settings (under Display and Monitor?), turn off any reference to Blank Screen and disable the automatic screensaver activation.

    Then, if necessary, use the above script.

    Note that, after each time you lock the screen, or hibernate, or sleep, you should drop to a terminal and invoke that script again.
    -Gerry Makaro
    Fraser-Bell Info Tech
    Solving Tech Mysteries since the Olden Days!
    ~~
    If I helped you, consider clicking the Star at the bottom left of my post.

  6. #6
    Join Date
    Apr 2016
    Location
    North America
    Posts
    532

    Default Re: disabling automatic screen shutoff / make "xset s off" permanent

    Code:
    xset s off
    in ~/.profile worked for Openbox.

    With xfce:

    Settings Manager -> Power Manager -> Display -> Blank after -> Never

  7. #7
    Join Date
    Apr 2016
    Location
    North America
    Posts
    532

    Default Re: disabling automatic screen shutoff / make "xset s off" permanent

    Code:
    xset s off
    can also be placed in

    ~/.config/openbox/autostart

    http://openbox.org/wiki/Help:Autostart

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •