Results 1 to 5 of 5

Thread: KDE - Download new plasma widgets does not work

  1. #1
    Join Date
    May 2015
    Location
    Italy
    Posts
    369

    Default KDE - Download new plasma widgets does not work

    Hi all,
    when I use my laptop at work, the "Download New Plasma Widgets" functionality is broken.
    The window that appears is empty, and the string "Loading of providers from file: http://download.kde.org/ocs/providers.xml failed" is shown at the bottom of the window.

    I think it may be due to the fact that, when at work, I have to pass through an http proxy server to get to the internet. At home I have no problems.
    This is apparently a regression, since it was working a few months ago.

    When navigating to that address from Firefox I can download the xml file without problems, even when at work. It's as if that functionality doesn't take into account proxy settings.

    Anybody else seeing this? I found this bug, but it is marked resolved since 2016-05-08. I am thinking about reopening it, but I would like to have some feedback from other forums users first.

    Thank you in advance.
    Cris
    Desktop: OpenSUSE Tumbleweed (x86_64) - AMD FX-8350 Eight-Core Processor, 16Gb RAM, 120GB Samsung Evo 840 SSD
    Laptop: OpenSUSE Tumbleweed (x86_64) - Thinkpad T440 - Intel i5-4210U, 12Gb RAM, 250GB Samsung EVO 750 SSD

  2. #2
    Join Date
    Jun 2010
    Location
    Michigan, USA
    Posts
    267

    Default Re: KDE - Download new plasma widgets does not work

    I just checked my Tumbleweed install (also at work) and i can access the repository of plasma widgets. I installed a simple monitor that looks kind of cool. My guess it has something to do with your corporate firewall.

    It is odd that Firefox can access it but the Add Widget system cannot.

    Has this always been an issue or is this a new-ish issue?

    Something I would try is to create a new user account and see if you have the same issue with that test user.

    Wish I could be more helpful.
    -Nathan
    If I am going to be spontaneous, I have to plan for it.

    www.CubicleNate.com

  3. #3
    Join Date
    May 2015
    Location
    Italy
    Posts
    369

    Default Re: KDE - Download new plasma widgets does not work

    Hi futureboy, thank you for your reply.
    Do you access the internet through a proxy when you're at work?

    I had this issue a couple years ago I think, then it was fixed.
    Now I have it again since a few months. I did not report it earlier because it is not a big problem (especially since I can access the widgets repository from home), but since it went unfixed for a few months now I thought it was better to report it.

    I'll try with a new user and will report back.

    Thank you!
    Cris
    Desktop: OpenSUSE Tumbleweed (x86_64) - AMD FX-8350 Eight-Core Processor, 16Gb RAM, 120GB Samsung Evo 840 SSD
    Laptop: OpenSUSE Tumbleweed (x86_64) - Thinkpad T440 - Intel i5-4210U, 12Gb RAM, 250GB Samsung EVO 750 SSD

  4. #4
    Join Date
    Jun 2010
    Location
    Michigan, USA
    Posts
    267

    Default Re: KDE - Download new plasma widgets does not work

    Quote Originally Posted by Cris70 View Post
    Hi futureboy, thank you for your reply.
    Do you access the internet through a proxy when you're at work?

    I had this issue a couple years ago I think, then it was fixed.
    Now I have it again since a few months. I did not report it earlier because it is not a big problem (especially since I can access the widgets repository from home), but since it went unfixed for a few months now I thought it was better to report it.

    Cris
    There is a firewall but the proxy was recently changed to a transparent proxy or something like that. I don't really know but I don't have to set a proxy anymore. There is a way to set a proxy in KDE that should fix any proxy issues you might have. It has previously worked well for me.

    If the proxy setting indeed does not work in KDE properly, then yes, report it.

    Cheers,
    -Nathan
    If I am going to be spontaneous, I have to plan for it.

    www.CubicleNate.com

  5. #5
    Join Date
    May 2015
    Location
    Italy
    Posts
    369

    Default Re: KDE - Download new plasma widgets does not work

    Thank you all for your replies.
    I have added my report to this bug.

    Cris
    Desktop: OpenSUSE Tumbleweed (x86_64) - AMD FX-8350 Eight-Core Processor, 16Gb RAM, 120GB Samsung Evo 840 SSD
    Laptop: OpenSUSE Tumbleweed (x86_64) - Thinkpad T440 - Intel i5-4210U, 12Gb RAM, 250GB Samsung EVO 750 SSD

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •