Results 1 to 10 of 10

Thread: can't install opera 12.16

  1. #1

    Default can't install opera 12.16

    On tumbleweed and leap 42.2 can't install opera 12.16 from here: https://ftp.opera.com/pub/opera/linux/1216/

    This opera installs fine only on 13.1, 13.2

    I did not guru user.

    i put command zypper in opera-12.16-1860.i386.rpm on tumbleweed and there is an error that one of the packages is missing and no repository provides it

  2. #2

    Default Re: can't install opera 12.16

    Quote Originally Posted by virex View Post
    On tumbleweed and leap 42.2 can't install opera 12.16 from here: https://ftp.opera.com/pub/opera/linux/1216/

    there is an error that one of the packages is missing and no repository provides it
    i need libgstbase-010.so.0

  3. #3
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,133

    Default Re: can't install opera 12.16

    Please whenever possible Show do not Tell (or at least show additionally to tell).

    Copy/paste from your terminal the complete thing: prompt, command, output, prompt. Pate it between CODE tags in your post. You get the CODE tags by clicking on the # button in the tool bar of the post editor.

    Only then we will see exactly what you saw. And only so others can come to their own conclusions.
    Henk van Velden

  4. #4

    Default Re: can't install opera 12.16

    Are you sure you want to install a web browser version that's 4 years old? That's a big security risk.
    Why don't you just install the latest opera that's included in the distribution?

    If you don't like the new/current opera browser, then maybe have a look at Vivaldi which is developed by the original Opera developers.
    https://vivaldi.com/
    A openSUSE package is available on Packman.

    gstreamer-0_10 has been dropped because it is old, outdated, and unmaintained (upstream).
    It should still be available on Packman though.

  5. #5
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,823
    Blog Entries
    15

    Default Re: can't install opera 12.16

    Hi
    Or look at installing otter-browser....
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  6. #6

    Default Re: can't install opera 12.16

    Quote Originally Posted by wolfi323 View Post
    Are you sure you want to install a web browser version that's 4 years old? That's a big security risk.
    Why don't you just install the latest opera that's included in the distribution?
    In that browser have a lot of saved links, and it have much convenient system for storing links.

    So i had installed them by ignoring dependencies, and it working fine.

  7. #7

    Default Re: can't install opera 12.16

    Quote Originally Posted by virex View Post
    In that browser have a lot of saved links, and it have much convenient system for storing links.
    It's still old and outdated, and therefore a security risk.

    You should be able to import your saved links to other browsers somehow. I know I did import them without problems into Konqueror years ago... KDE's keditbookmarks does offer an option to import Opera bookmarks.

    No idea what you mean with "convenient system for storing links", but other browsers may offer similar things. (as I said, Vivaldi is written by the same people that created Opera 12.16, unlike newer Opera versions)

    So i had installed them by ignoring dependencies, and it working fine.
    I don't know for what it uses gstreamer-0_10 exactly (maybe HTML5 videos?), but those functions won't work and may even cause it to crash.

    I had a look, and they removed gstreamer-0_10 from Packman too (for Tumbleweed, it is still available for Leap 42.2).
    It is still available in the multimedia:libs repo on OBS though (without support for restricted codecs of course):
    http://download.opensuse.org/reposit...SE_Tumbleweed/

    But if you add this repo, you probably should give it a lower priority than Packman, or multimedia packages from there will be replaced by crippled versions from multimedia:libs...

  8. #8
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: can't install opera 12.16

    most modern browsers can import opera bookmarks
    Vivaldi nativly supports Opera 12-14 or you can export your bookmarks as a html file and import them with your new browser
    you really should move to a new browser both Opera and Vivaldi use Chromium's blink engine so a choice between those 3 is what suits your needs Firefox is a good choice too

  9. #9

    Default Re: can't install opera 12.16

    Quote Originally Posted by I_A View Post
    most modern browsers can import opera bookmarks
    Vivaldi nativly supports Opera 12-14 or you can export your bookmarks as a html file and import them with your new browser
    Just to add:
    KDE's keditbookmarks does also offer exporting the bookmarks (e.g. as a simple html file), and it can import Opera's bookmarks as mentioned. So you could use that too to "convert" the bookmarks if necessary.
    It's a very small package and you probably have it installed already anyway if you use a KDE desktop...
    Last edited by wolfi323; 13-May-2017 at 03:35.

  10. #10
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: can't install opera 12.16

    I've never tried it
    I've been using Firefox since mozilla killed off the now resurrected SeaMonkey
    and with Firefox sync (I know it's a security hole) I can have all my bookmarks and addons thru out different devices (Linux Windows Android) I just logon to sync and all my bookmarks are there

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •