I use whatsapp web on firefox and after an upgrade from Opensuse 13.2 to 42.2 it asked for the QR code. I scanned it and whatsapp web worked, but when I close firefox and open it again and go to whatsapp web, It ask again the QR code.

Firefox ESR 52.1.0 (64-bit)

regards