Results 1 to 7 of 7

Thread: Hepl for update mozilla firefox!

  1. #1
    Join Date
    Apr 2015
    Location
    The Earth
    Posts
    498

    Default Hepl for update mozilla firefox!

    Hi
    I want update to firefox 53 in repo mozilla but show this error
    Code:
     ~> sudo zypper install MozillaFirefox-53.0-6.8.x86_64
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...
    
    Problem: MozillaFirefox-53.0-6.8.x86_64 requires mozilla-nspr >= 4.14, but this requirement cannot be provided
      uninstallable providers: mozilla-nspr-4.14-1.1.i586[mozilla]
                       mozilla-nspr-4.14-1.1.x86_64[mozilla]
     Solution 1: Following actions will be done:
      install mozilla-nspr-4.14-1.1.x86_64 (with vendor change)
        openSUSE  -->  obs://build.opensuse.org/mozilla
      deinstallation of java-1_8_0-openjdk-headless-1.8.0.121-3.3.x86_64
      deinstallation of java-1_8_0-openjdk-1.8.0.121-3.3.x86_64
     Solution 2: do not install MozillaFirefox-53.0-6.8.x86_64
     Solution 3: break MozillaFirefox-53.0-6.8.x86_64 by ignoring some of its dependencies
    
    Choose from above solutions by number or cancel [1/2/3/c] (c): 1
    Resolving dependencies...
    Resolving package dependencies...
    
    Problem: MozillaFirefox-53.0-6.8.x86_64 requires mozilla-nss >= 3.30.2, but this requirement cannot be provided
      uninstallable providers: mozilla-nss-3.30.2-1.4.i586[mozilla]
                       mozilla-nss-3.30.2-1.4.x86_64[mozilla]
     Solution 1: install mozilla-nss-3.30.2-1.4.x86_64 (with vendor change)
      openSUSE  -->  obs://build.opensuse.org/mozilla
     Solution 2: do not install MozillaFirefox-53.0-6.8.x86_64
     Solution 3: break MozillaFirefox-53.0-6.8.x86_64 by ignoring some of its dependencies
    
    Choose from above solutions by number or cancel [1/2/3/c] (c): 1
    Resolving dependencies...
    Resolving package dependencies...
    
    The following application is going to be installed:
      firefox
    
    The following 2 NEW packages are going to be installed:
      java-9-openjdk java-9-openjdk-headless
    
    The following 3 applications are going to be REMOVED:
      Desktop "Firefox Web Browser" "System Tray"
    
    The following 2 packages are going to be REMOVED:
      java-1_8_0-openjdk java-1_8_0-openjdk-headless
    
    The following 3 packages are going to be upgraded:
      MozillaFirefox mozilla-nspr mozilla-nss
    
    The following 3 packages are going to change vendor:
      MozillaFirefox  openSUSE -> obs://build.opensuse.org/mozilla
      mozilla-nspr    openSUSE -> obs://build.opensuse.org/mozilla
      mozilla-nss     openSUSE -> obs://build.opensuse.org/mozilla
    
    
    3 packages to upgrade, 2 new, 2 to remove, 3  to change vendor.
    Overall download size: 67.5 MiB. Already cached: 0 B. After the operation, additional
    23.1 MiB will be used.
    Continue? [y/n/...? shows all options] (y)
    why removing two apps "java-1_8_0-openjdk-headless-1.8.0.121-3.3.x86_64" and "java-1_8_0-openjdk-1.8.0.121-3.3.x86_64"?
    Thanks
    Dual-boot openSUSE and win10
    OpenSUSE Tumbleweed ; Plasma 5.15.x:" LVM encrypted"
    My Partition: GPT and UEFI system
    Hp ProBook 450 G1

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,136

    Default Re: Hepl for update mozilla firefox!

    This is not an update, but an installation of a specific version. And it even needs a vendor change.

    Where (which repo) should that version come from? Apparently from another repo then the one you used until now.
    Henk van Velden

  3. #3
    Join Date
    Apr 2015
    Location
    The Earth
    Posts
    498

    Default Re: Hepl for update mozilla firefox!

    Quote Originally Posted by hcvv View Post
    This is not an update, but an installation of a specific version. And it even needs a vendor change.

    Where (which repo) should that version come from? Apparently from another repo then the one you used until now.
    If choose 3 (Solution 3: break MozillaFirefox-53.0-6.8.x86_64 by ignoring some of its dependencies) Whether it will be successfully installed? or Or should I choose option 1 to install
    Dual-boot openSUSE and win10
    OpenSUSE Tumbleweed ; Plasma 5.15.x:" LVM encrypted"
    My Partition: GPT and UEFI system
    Hp ProBook 450 G1

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,136

    Default Re: Hepl for update mozilla firefox!

    Quote Originally Posted by 123thinksuse View Post
    If choose 3 (Solution 3: break MozillaFirefox-53.0-6.8.x86_64 by ignoring some of its dependencies) Whether it will be successfully installed? or Or should I choose option 1 to install
    That is NOT an answer to my questions.
    Henk van Velden

  5. #5
    Join Date
    Apr 2015
    Location
    The Earth
    Posts
    498

    Default Re: Hepl for update mozilla firefox!

    Quote Originally Posted by hcvv View Post
    That is NOT an answer to my questions.
    I want to installing Firefox 53 in the repo Mozilla
    but show error post 1
    Dual-boot openSUSE and win10
    OpenSUSE Tumbleweed ; Plasma 5.15.x:" LVM encrypted"
    My Partition: GPT and UEFI system
    Hp ProBook 450 G1

  6. #6
    Join Date
    Apr 2015
    Location
    The Earth
    Posts
    498

    Default Re: Hepl for update mozilla firefox!

    I mentioned in my first post
    repo mozilla
    Dual-boot openSUSE and win10
    OpenSUSE Tumbleweed ; Plasma 5.15.x:" LVM encrypted"
    My Partition: GPT and UEFI system
    Hp ProBook 450 G1

  7. #7
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,825
    Blog Entries
    15

    Default Re: Hepl for update mozilla firefox!

    Hi
    Latest is not the greatest..... See https://lists.opensuse.org/opensuse-.../msg00925.html on the current status and move to ESR version.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •