Results 1 to 3 of 3

Thread: Problem updating libqt4-devel

  1. #1
    Join Date
    May 2015
    Location
    Italy
    Posts
    368

    Default Problem updating libqt4-devel

    Hi all,
    today I had a problem updating:
    Code:
    cris@PolariSuse [~]$ sudo zypper dup
    [sudo] password for root:  
    Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' for more information abo
    ut this command.
    Loading repository data...
    Reading installed packages...
    Computing distribution upgrade...
    
    Problem: libqt4-devel-4.8.7-6.1.x86_64 requires openssl-devel, but this requirement cannot be provided
      uninstallable providers: libopenssl-devel-1.0.2k-3.1.i586[download.opensuse.org-oss]
                       libopenssl-devel-1.0.2k-3.1.x86_64[download.opensuse.org-oss]
     Solution 1: deinstallation of libressl-devel-2.5.3-1.1.x86_64
     Solution 2: keep obsolete python-qt4-4.12-2.2.x86_64
     Solution 3: break libqt4-devel-4.8.7-6.1.x86_64 by ignoring some of its dependencies
    
    Choose from above solutions by number or cancel [1/2/3/c] (c): 
    
    After a little bit of analysis, it seems that the problem is this one: python-qt4 is needed by this packages I have installed (and would like to retain): audacity git-cola suil-plugins.
    Updating python-qt4 apparently brings in libqt4-devel (I dont' have it installed presently) which, in turn, needs openssl-devel.
    But openssl-devel conflicts with libressl-devel (which is installed), so it is not installable. If I try to remove libressl-devel, I'm going to lose mysql-workbench, which I'd like to retain.

    Does anybody see a way out, besides keeping the obsolete python-qt4-4.12-2.2.x86_64?

    Thank you in advance.
    Cris
    Desktop: OpenSUSE Tumbleweed (x86_64) - AMD FX-8350 Eight-Core Processor, 16Gb RAM, 120GB Samsung Evo 840 SSD
    Laptop: OpenSUSE Tumbleweed (x86_64) - Thinkpad T440 - Intel i5-4210U, 12Gb RAM, 250GB Samsung EVO 750 SSD

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,311
    Blog Entries
    15

    Default Re: Problem updating libqt4-devel

    Hi
    What repos are active? If you have switched then should be using --no-allow-vendor-change but also there is no python-qt4, it's python2-qt4.

    Trying to install pulls in way too many packages, looks like it similar to my duplicate bug (and the linked bug...)
    https://bugzilla.opensuse.org/show_bug.cgi?id=1035833
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3
    Join Date
    May 2015
    Location
    Italy
    Posts
    368

    Default Re: Problem updating libqt4-devel

    Quote Originally Posted by malcolmlewis View Post
    Hi
    What repos are active? If you have switched then should be using --no-allow-vendor-change but also there is no python-qt4, it's python2-qt4.
    Using -no-allow-vendor-change does not make any difference here.

    And about the name of the python package, did it change name recently?
    Look here:
    Code:
    cris@PolariSuse [~/Downloads]$ zypper se -s python-qt4 python2-qt4  
    Loading repository data...
    Reading installed packages...
    
    S | Name                        | Type    | Version  | Arch   | Repository                
    --+-----------------------------+---------+----------+--------+--------------------------
    i | python-qt4                  | package | 4.12-2.2 | x86_64 | (System Packages)         
      | python-qt4-debuginfo        | package | 4.12-3.1 | x86_64 | openSUSE-Tumbleweed-Debug
      | python-qt4-debuginfo        | package | 4.12-3.1 | i586   | openSUSE-Tumbleweed-Debug
      | python-qt4-debugsource      | package | 4.12-3.1 | x86_64 | openSUSE-Tumbleweed-Debug
      | python-qt4-debugsource      | package | 4.12-3.1 | i586   | openSUSE-Tumbleweed-Debug
      | python-qt4-utils            | package | 4.12-3.1 | x86_64 | Main Repository (OSS)     
      | python-qt4-utils            | package | 4.12-3.1 | i586   | Main Repository (OSS)     
      | python2-qt4                 | package | 4.12-3.1 | x86_64 | Main Repository (OSS)     
      | python2-qt4                 | package | 4.12-3.1 | i586   | Main Repository (OSS)     
      | python2-qt4-debuginfo       | package | 4.12-3.1 | x86_64 | openSUSE-Tumbleweed-Debug
      | python2-qt4-debuginfo       | package | 4.12-3.1 | i586   | openSUSE-Tumbleweed-Debug
      | python2-qt4-devel           | package | 4.12-3.1 | x86_64 | Main Repository (OSS)     
      | python2-qt4-devel           | package | 4.12-3.1 | i586   | Main Repository (OSS)     
      | python2-qt4-devel-debuginfo | package | 4.12-3.1 | x86_64 | openSUSE-Tumbleweed-Debug
      | python2-qt4-devel-debuginfo | package | 4.12-3.1 | i586   | openSUSE-Tumbleweed-Debug
    
    Anyway, here is my repo list:
    Code:
    cris@PolariSuse [~/Downloads]$ zypper lr -d
    Repository priorities in effect:                                                                                                                             (See 'zypper lr -P' for details)
          98 (raised priority)  :  2 repositories
          99 (default priority) : 13 repositories
    
    
    #  | Alias                                 | Name                                   | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                                       | Service
    ---+---------------------------------------+----------------------------------------+---------+-----------+---------+----------+--------+-------------------------------------------------------------------------------------------+--------
     1 | GLDickens_Ubuntu_Style_Font_Rendering | GLDickens Ubuntu Style Font Rendering  | Yes     | (r ) Yes  | Yes     |   98     | rpm-md | http://download.opensuse.org/repositories/home:/gldickens3:/Advanced/openSUSE_Tumbleweed/ |        
     2 | Insync_Fedora_25                      | Insync Fedora 25                       | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://yum.insynchq.com/fedora/25/                                                        |        
     3 | Packman                               | Packman Repository                     | Yes     | (r ) Yes  | Yes     |   98     | rpm-md | http://ftp.gwdg.de/pub/linux/packman/suse/openSUSE_Tumbleweed/                            |        
     4 | Vivaldi_stable                        | Vivaldi stable                         | Yes     | ( p) Yes  | Yes     |   99     | rpm-md | http://repo.vivaldi.com/stable/rpm/x86_64/                                                |
     5 | download.opensuse.org-non-oss         | Main Repository (NON-OSS)              | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/tumbleweed/repo/non-oss/                                     |
     6 | download.opensuse.org-oss             | Main Repository (OSS)                  | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/tumbleweed/repo/oss/                                         |
     7 | download.opensuse.org-tumbleweed      | Main Update Repository                 | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/tumbleweed/                                           |
     8 | geogebra                              | geogebra                               | Yes     | ( p) Yes  | Yes     |   99     | rpm-md | http://www.geogebra.net/linux/rpm/x86_64                                                  |
     9 | google-earth                          | google-earth                           | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://dl.google.com/linux/earth/rpm/stable/x86_64                                        |
    10 | google-musicmanager                   | google-musicmanager                    | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://dl.google.com/linux/musicmanager/rpm/stable/x86_64                                 |
    11 | google-talkplugin                     | google-talkplugin                      | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://dl.google.com/linux/talkplugin/rpm/stable/x86_64                                   |
    12 | home_colomboem                        | Emanuele Colombo (openSUSE_Tumbleweed) | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/home:/colomboem/openSUSE_Tumbleweed/            |
    13 | libdvdcss                             | libdvdcss repository                   | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://opensuse-guide.org/repo/openSUSE_Tumbleweed/                                       |
    14 | openSUSE-20151118-0                   | openSUSE-20151118-0                    | No      | ----      | ----    |   99     | yast2  | cd:///?devices=/dev/disk/by-id/ata-PHILIPS_DVDR1660P1_DL100614069754                      |
    15 | repo-debug                            | openSUSE-Tumbleweed-Debug              | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/debug/tumbleweed/repo/oss/                                   |
    16 | repo-source                           | openSUSE-Tumbleweed-Source             | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/source/tumbleweed/repo/oss/                                  |
    17 | snappy                                | snappy                                 | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/system:/snappy/openSUSE_Tumbleweed/
    Quote Originally Posted by malcolmlewis View Post
    Trying to install pulls in way too many packages, looks like it similar to my duplicate bug (and the linked bug...)
    https://bugzilla.opensuse.org/show_bug.cgi?id=1035833
    Yes, I think it may be related... I don't see why it should pull in those -devel packages otherwise.

    Also, look at this thread.

    Cris
    Last edited by Cris70; 02-May-2017 at 10:58. Reason: add some more informations
    Desktop: OpenSUSE Tumbleweed (x86_64) - AMD FX-8350 Eight-Core Processor, 16Gb RAM, 120GB Samsung Evo 840 SSD
    Laptop: OpenSUSE Tumbleweed (x86_64) - Thinkpad T440 - Intel i5-4210U, 12Gb RAM, 250GB Samsung EVO 750 SSD

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •