Results 1 to 9 of 9

Thread: Steam not running after installtion(no GUI)

  1. #1
    Join Date
    Apr 2017
    Location
    Pakistan
    Posts
    18

    Smile Steam not running after installtion(no GUI)

    Hello

    Kindly help me!

    I have installed steam from suse repositories non-OSS. The steam does not show any gui when i execute it.

    when i check system monitor, it shows that steam is "Sleeping" or waiting.......

    kindly help me in this regard.

    Am I missing any lib file

    My system specs

    opensuse 42.2
    kernel-4.4.49-16.1x86_64
    I have a nvidia card geforce 560 ti installed (nvidia drivers installation the hard way ).

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,313
    Blog Entries
    15

    Default Re: Steam not running after installtion(no GUI)

    On Tue 25 Apr 2017 04:46:01 AM CDT, plansuse wrote:

    Hello

    Kindly help me!

    I have installed steam from suse repositories non-OSS. The steam does
    not show any gui when i execute it.

    when i check system monitor, it shows that steam is "Sleeping" or
    waiting.......

    kindly help me in this regard.

    Am I missing any lib file

    My system specs

    opensuse 42.2
    kernel-4.4.49-16.1x86_64
    I have a nvidia card geforce 560 ti installed (nvidia drivers
    installation the hard way ).


    Hi
    That's an old kernel, you should make sure your system is updated and
    boot to multi-user level and re-run the nvidia installer.... Then
    switch back to graphical...

    Code:
    su -
    zypper ref
    zypper up
    systemctl set-default multi-user.target
    systemctl reboot
    Then after reboot login as root user, then cd to Nvidia installer run
    file directory (I leave mine it /root so no need to go anywhere after
    login).

    Code:
    sh Nvidia......run -aq
    systemctl set-default graphical.target
    systemctl reboot
    --
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    openSUSE Leap 42.2|GNOME 3.22.2|4.4.57-18.3-default
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


  3. #3
    Join Date
    Apr 2017
    Location
    Pakistan
    Posts
    18

    Smile Re: Steam not running after installtion(no GUI)

    Quote Originally Posted by malcolmlewis View Post
    Hi
    That's an old kernel, you should make sure your system is updated and
    boot to multi-user level and re-run the nvidia installer.... Then
    switch back to graphical...

    Code:
    su -
    zypper ref
    zypper up
    systemctl set-default multi-user.target
    systemctl reboot
    Then after reboot login as root user, then cd to Nvidia installer run
    file directory (I leave mine it /root so no need to go anywhere after
    login).

    Code:
    sh Nvidia......run -aq
    systemctl set-default graphical.target
    systemctl reboot
    --
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    openSUSE Leap 42.2|GNOME 3.22.2|4.4.57-18.3-default
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!
    I have already installed the nvidia driver (as explained in opensuse SBD "installing nvidia driver the hardway").

    Previously there was no issue with steam it worked like a charm. But due some issues i have to reinstall my whole system, and now i am stuck with this issue kindly help, i shall update the system as you have instructed and shall reply as soon as possible.

    But kindly instruct me again if the above procedure fails.

    Thanks
    Muhammad Ali

  4. #4
    Join Date
    Apr 2017
    Location
    Pakistan
    Posts
    18

    Thumbs up Re: Steam not running after installtion(no GUI)

    Quote Originally Posted by malcolmlewis View Post
    Hi
    That's an old kernel, you should make sure your system is updated and
    boot to multi-user level and re-run the nvidia installer.... Then
    switch back to graphical...

    Code:
    su -
    zypper ref
    zypper up
    systemctl set-default multi-user.target
    systemctl reboot
    Then after reboot login as root user, then cd to Nvidia installer run
    file directory (I leave mine it /root so no need to go anywhere after
    login).

    Code:
    sh Nvidia......run -aq
    systemctl set-default graphical.target
    systemctl reboot
    --
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    openSUSE Leap 42.2|GNOME 3.22.2|4.4.57-18.3-default
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!
    Thanks malcolmlewis, you response is very helpful to me and it encourage me to do some thing to resolve the issue.

    I did following steps, if these steps are ok, then kindly reply otherwise please comment, i will be waiting for your reply.


    1. I added nvidia repo for opensuse 42.2, and install "nvidia-glG04" & "nvidia-gfxG04-kmp-default". since my nvidia card is Geforce 560 TI.
    2. Then i go Yast->Service-> and select "Multi User Login" apply and ok.
    3. rebooted and login to root and run the following cmd.


    Code:
    sh Nvidai-Linux-x86_64-*****.run
    4.Then as per you instruction followed the steps, i.e continue, continue,overwrite & continue...

    5.After the installer finished successfully, i go Yast->Service-> and select "Graphical.target" apply and ok.

    6.rebooted and to my surprise steam started working like a charm again.

    7. one issue remained was missing / scrambled fonts, so i downloaded steam fonts from
    HTML Code:
    https://www.google.com/url?sa=t&rct=j&q=&esrc=s&source=web&cd=1&cad=rja&uact=8&ved=0ahUKEwiBmr3fkMDTAhVQkRQKHZ9EDZQQFggjMAA&url=https%3A%2F%2Fsupport.steampowered.com%2Fkb_article.php%3Fp_faqid%3D1974-YFKL-4947&usg=AFQjCNH_SDodPdEvhOamb1QiXUVhY8_hIg
    web site extracted the font files to /home/user_name_dir/.font folder and rebooted steam which solved by scrambled font problem.

    5 stars to your response......, your my friend....., one post and complete solution to my problem & frustration.

    Hats-off man.

    Do reply if i did something wrong to my system, & also i did not update my system, is it OK , pls comment,

    Thanks
    Muhammad Ali

  5. #5
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,313
    Blog Entries
    15

    Default Re: Steam not running after installtion(no GUI)

    Hi
    Seems like your procedures covers both ways to install the nvidia driver... easy way is add repository, hard way is via the run file.

    I would suggest the hard way, since if there is a kernel update then it can take some time for the rpm version that matches the kernel to appear.

    So, if you update the kernel, you only need to follow the steps I indicated, not add the repository. My suggestion is to remove the repo and carry on.

    I would also guess there have been other updates that helped get steam up and running again.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  6. #6

    Default Re: Steam not running after installtion(no GUI)

    Quote Originally Posted by malcolmlewis View Post
    I would suggest the hard way, since if there is a kernel update then it can take some time for the rpm version that matches the kernel to appear.
    That's not true at all.

    There is absolutely no need for an rpm version that matches the kernel to appear, if you use the rpms, the installed kernel module will just continue to work...
    (unless you use some non-standard kernel)

    OTOH, don't forget that if using the hard way, you also have to reinstall the driver whenever Xorg or Mesa is updated.

    Therefore I'd rather recommend the easy way.

    But yes, doing both is bound to cause problems. If not now, then definitely at some point in the future (e.g. when there is a driver update).
    Please uninstall the .run driver via:
    Code:
    sh Nvidia......run --uninstall
    The driver installed via the rpm packages should still work afterwards I suppose, if not uninstall and reinstall the packages.

    Or, if you do prefer the hard way, uninstall the packages, remove the repo, and then reinstall the .run driver again.

    I would also guess there have been other updates that helped get steam up and running again.
    I would rather guess that some update broke the nvidia installation, and reinstalling the driver fixed it...
    Last edited by wolfi323; 25-Apr-2017 at 14:03.

  7. #7
    Join Date
    Apr 2017
    Location
    Pakistan
    Posts
    18

    Smile Re: Steam not running after installtion(no GUI)

    Well a big thanks to both "malcolmlewis" & "wolfi323" for detailed response.

    As malcolmlewis has pointed out, I shall uninstall the installed nvidia rmps and reboot to see the changes, and yes I will have no issue unless i update the kernal.

    As wolfi323 has pointed out, that rpm method is easy, but to my knowledge, hard way method of installing nvidia drivers is very basic, exciting and good way to install, only one issue is to install the driver again when a kernel is updated.

    But as I have edited zyper.conf file and changed multikernalversion to only "oldest" & "running", i shall have no kernal update issue as my kernel will remain the same.

    HISTORY
    "I also remember installing nvidia the hardway back date to suse version 10.0 when nvidia installation ends & we should have to run sax cmd with some parameter to setup xorg.".... there was no issue even it was the hard way.
    i really want sax to be incorporated in opensuse

    Thanks for pointing out the changes regarding updated kernel,

    Thanks
    Muhammad Ali
    Yours Sincerely
    Muhammad Ali
    Civil Engineer
    Add me as friend if you like my post

  8. #8

    Default Re: Steam not running after installtion(no GUI)

    Quote Originally Posted by plansuse View Post
    only one issue is to install the driver again when a kernel is updated.
    I'd like to note again that you will also need to reinstall the driver after an Xorg or Mesa update.

    The reason is that nvidia "overwrites" some system libraries, if the corresponding packages are updated the original (non-nvidia) versions are installed again.
    This will break nvidia's OpenGL support, and is IMHO the likely reason for your problem that started this thread.

    The RPM packages avoid this problem by installing the nvidia libraries to a different place.

    But as I have edited zyper.conf file and changed multikernalversion to only "oldest" & "running", i shall have no kernal update issue as my kernel will remain the same.
    TBH, I don't think this is a good idea.
    And I'm not sure it will even prevent the installation of Kernel updates in the first place. I think it is only evaluated by purge-kernels.service that removes "unwanted" kernels on boot, and in that case the newer kernel will be the "running" one and not be removed either. Unless you also configured grub2 to boot a specific kernel of course.

    You can avoid reinstallation on kernel modules by using dkms though, that will recompile the kernel module automatically after a kernel update.
    Or use the RPM packages...

    But that's your decision of course.

    "I also remember installing nvidia the hardway back date to suse version 10.0 when nvidia installation ends & we should have to run sax cmd with some parameter to setup xorg.".... there was no issue even it was the hard way.
    There normally is no need for an xorg.conf at all nowadays (since years).
    Xorg will determine automatically which driver to load.
    It uses a predefined list depending on the graphics card, and uses the "best" driver that is installed/can be loaded successfully.
    For NVidia cards the order is nvidia->nouveau->modesetting->nv->fbdev->vesa.

    i really want sax to be incorporated in opensuse
    Sax2 has been completely dropped years ago, that's nothing to do with SUSE vs. openSUSE.

    There was a replacement that created new-style xorg.conf.d snippets instead of a monolithic xorg.conf, sax3, but that never really took off.
    It is still included in Leap 42.2 though.
    Last edited by wolfi323; 27-Apr-2017 at 11:45.

  9. #9
    Join Date
    May 2012
    Location
    Finland
    Posts
    2,002

    Default Re: Steam not running after installtion(no GUI)

    Quote Originally Posted by plansuse View Post
    "I also remember installing nvidia the hardway back date to suse version 10.0 when nvidia installation ends & we should have to run sax cmd with some parameter to setup xorg.".... there was no issue even it was the hard way.
    i really want sax to be incorporated in opensuse
    I think you're looking at things through rose tinted glasses because "back in the day" (with SaX2) laptops and anything more exotic configurations were an incredible pain in the butt as there was literally no way to get external displays hooked up to your machine without fighting and when you did, you had to manually configure it through sax - if you pulled it out without restarting X, well kaboom.

    nVidia drivers had constant issues with VGA displays and you had to manually tinker around with DPI settings and numerous other problems.

    It was a horrible, horrible period before auto-configuration started working properly.
    .: miuku #suse @ irc.freenode.net
    :: miuku@opensuse.org

    .: h​ttps://download.opensuse.org/repositories/home:/Miuku/

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •