Results 1 to 5 of 5

Thread: Getting compatible version of Calibre

Hybrid View

  1. #1
    Join Date
    Dec 2008
    Location
    Norway
    Posts
    543

    Default Getting compatible version of Calibre

    I cannot install Calibre because it requires an older version of KDE Frameworks.

    Code:
    Problem: calibre-2.83.0-388.1.x86_64 requires libQt5Core.so.5(Qt_5.6.1_PRIVATE_API)(64bit), but this requirement cannot be provided
      uninstallable providers: libQt5Core5-5.6.1-2.1.x86_64[repo-oss]
     Solution 1: Following actions will be done:
      downgrade of libQt5Core5-5.8.0-287.1.x86_64 to libQt5Core5-5.6.1-2.1.x86_64
      install libQt5Core5-5.6.1-2.1.x86_64 (with vendor change)
        obs://build.opensuse.org/KDE  -->  openSUSE
    
    None of the versions available here are installable:
    https://software.opensuse.org/package/calibre

    I am using the latest KDE Framworks, Plasma and Applications:
    http://download.opensuse.org/repositories/KDE:/Frameworks5/openSUSE_Leap_42.2
    http://download.opensuse.org/repositories/KDE:/Applications/KDE_Frameworks5_openSUSE_Leap_42.2/

  2. #2

    Default Re: Getting compatible version of Calibre

    Quote Originally Posted by DJViking View Post
    I cannot install Calibre because it requires an older version of KDE Frameworks.
    Actually it requires an older version of Qt5.

    Calibre uses internal/private Qt headers, and needs the exact same Qt5 version it is built against.

    So somebody would need to build it against Qt 5.8.0 from KDE:Qt5...

    Calibre is not a KDE application, and not maintained by openSUSE's KDE team.
    But, because there are also some packages with similar packages in KDE:Extra, we decided to provide KDE:Extra built against KF5 and KDE:Qt5 too. And as we are aware of this problem with calibre, the plan was to add it to KDE:Extra too (as a link).

    No idea why this hasn't been done yet, it probably was "forgotten" because of other work (especially KDE Applications 17.04 was quite a lot of work recently).

    AFAIK you should be able to install the rpm package provided by upstream though, this doesn't use the system libraries AIUI.
    https://calibre-ebook.com/download

    Or switch back to Qt 5.6 as shipped in Leap 42.2... (which would mean you cannot have the latest Plasma5 and KDE applications though)
    Last edited by wolfi323; 24-Apr-2017 at 11:23.

  3. #3
    Join Date
    Dec 2008
    Location
    Norway
    Posts
    543

    Default Re: Getting compatible version of Calibre

    I tried building Calibre my self from source, but I could not find all the required packages for it.

    Code:
    djviking@mintaka:~/workspace> rpmbuild --rebuild calibre-2.83.0-389.1.src.rpm
    Installerer calibre-2.83.0-389.1.src.rpm
    feil: Failed build dependencies:
            help2man is needed by calibre-2.83.0-389.1.x86_64
            chmlib-devel >= 0.40 is needed by calibre-2.83.0-389.1.x86_64
            libQt5Core-private-headers-devel >= 5.3.2 is needed by calibre-2.83.0-389.1.x86_64
            libQt5Gui-private-headers-devel >= 5.3.2 is needed by calibre-2.83.0-389.1.x86_64
            libQt5PlatformSupport-private-headers-devel >= 5.3.2 is needed by calibre-2.83.0-389.1.x86_64
            libmtp-devel >= 1.1.5 is needed by calibre-2.83.0-389.1.x86_64
            libpodofo-devel >= 0.8.2 is needed by calibre-2.83.0-389.1.x86_64
            libpoppler-devel >= 0.20.2 is needed by calibre-2.83.0-389.1.x86_64
            libwmf-devel >= 0.2.8 is needed by calibre-2.83.0-389.1.x86_64
            optipng >= 0.7.5 is needed by calibre-2.83.0-389.1.x86_64
            podofo >= 0.8.2 is needed by calibre-2.83.0-389.1.x86_64
            python-apsw >= 3.7.17 is needed by calibre-2.83.0-389.1.x86_64
            python-beautifulsoup >= 3.0.5 is needed by calibre-2.83.0-389.1.x86_64
            python-cherrypy is needed by calibre-2.83.0-389.1.x86_64
            python-cssselect >= 0.7.1 is needed by calibre-2.83.0-389.1.x86_64
            python-cssutils >= 0.9.9 is needed by calibre-2.83.0-389.1.x86_64
            python-dateutil >= 1.4.1 is needed by calibre-2.83.0-389.1.x86_64
            python-devel >= 2.7.9 is needed by calibre-2.83.0-389.1.x86_64
            python-dnspython >= 1.6.0 is needed by calibre-2.83.0-389.1.x86_64
            python-genshi is needed by calibre-2.83.0-389.1.x86_64
            python-lxml >= 3.2.1 is needed by calibre-2.83.0-389.1.x86_64
            python-mechanize >= 0.1.11 is needed by calibre-2.83.0-389.1.x86_64
            python-odfpy is needed by calibre-2.83.0-389.1.x86_64
            python-psutil >= 0.6.1 is needed by calibre-2.83.0-389.1.x86_64
            python-pypdf is needed by calibre-2.83.0-389.1.x86_64
            python-qt5-devel >= 5.3.1 is needed by calibre-2.83.0-389.1.x86_64
            python-sip-devel >= 4.12 is needed by calibre-2.83.0-389.1.x86_64
            sqlite3-devel is needed by calibre-2.83.0-389.1.x86_64
            pkgconfig(ImageMagick) >= 6.5.9 is needed by calibre-2.83.0-389.1.x86_64
            python-Pillow is needed by calibre-2.83.0-389.1.x86_64
    
    


    Tried installing these packages:
    Code:
    mintaka:/home/djviking/workspace # zypper in help2man chmlib-devel libQt5Core-private-headers-devel libQt5Gui-private-headers-devel libQt5PlatformSupport-private-h
    eaders-devel libmtp-devel libpodofo-devel libpoppler-devel libwmf-devel optipng podofo python-apsw python-beautifulsoup python-cherrypy python-cssselec
    t python-cssutils python-dateutil python-devel python-dnspython python-genshi python-lxml python-mechanize python-odfpy python-psutil python-pypdf pyth
    on-qt5-devel python-sip-devel sqlite3-devel ImageMagick python-Pillow 
    Loading repository data... 
    Reading installed packages... 
    'ImageMagick' is already installed. 
    No update candidate for 'ImageMagick-6.8.8.1-28.1.x86_64'. The highest available version is already installed. 
    'python-cherrypy' not found in package names. Trying capabilities. 
    'python-genshi' not found in package names. Trying capabilities. 
    Resolving package dependencies... 
    
    Problem: nothing provides python-sip-devel >= 4.19.1 needed by python-qt5-devel-5.8-74.1.x86_64 
    Solution 1: do not install python-qt5-devel-5.8-74.1.x86_64 
    Solution 2: break python-qt5-devel-5.8-74.1.x86_64 by ignoring some of its dependencies
    


  4. #4

    Default AW: Re: Getting compatible version of Calibre

    Quote Originally Posted by DJViking View Post
    I tried building Calibre my self from source, but I could not find all the required packages for it.

    "zypper si -d calibre" would install all build dependencies.


    Problem: nothing provides python-sip-devel >= 4.19.1 needed by python-qt5-devel-5.8-74.1.x86_64

    Solution 1: do not install python-qt5-devel-5.8-74.1.x86_64
    Solution 2: break python-qt5-devel-5.8-74.1.x86_64 by ignoring some of its dependencies
    python-qt5 in KDE:Qt5 is "broken" currently because of recent changes in the distribution's python setup (in Tumbleweed).
    Therefore it requires a python-sip that doesn't exist any more.

    Install python-qt5-devel and python-sip-devel from the main repo.

  5. #5
    Join Date
    Dec 2008
    Location
    Norway
    Posts
    543

    Default Re: Getting compatible version of Calibre

    I ended up with installing it directy from Calibre. It worked. I will change to KDE:Extra if it gets built there in the near future.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •