Results 1 to 9 of 9

Thread: System Tray and Desktop upgrade problem

  1. #1
    Join Date
    Apr 2016
    Location
    Flix, Spain
    Posts
    7

    Default System Tray and Desktop upgrade problem

    Hi, when I check for updates using Zypper dup, I get the following message:

    Warning: You are about to do a distribution upgrade with all enabled repositories. Make
    sure these repositories are compatible before you continue. See 'man zypper' for more in
    formation about this command.
    Loading repository data...
    Reading installed packages...
    Computing distribution upgrade...

    The following 2 applications are going to be REMOVED:
    Desktop "System Tray"

    No additional space will be used or freed after the operation.
    Nothing to do.

    I have been getting this message for over a week now. My PC used to run KDE Neon, I installed Tumbleweed onto the formatted system partition an retained the /home partition from when I used Neon. Can someone shed any light on whats going on?


  2. #2
    Join Date
    Nov 2013
    Location
    Kamloops, BC, Canada
    Posts
    3,974

    Default Re: System Tray and Desktop upgrade problem

    Quote Originally Posted by alanholt View Post
    Hi, when I check for updates using Zypper dup, I get the following message:

    Warning: You are about to do a distribution upgrade with all enabled repositories. Make
    sure these repositories are compatible before you continue. See 'man zypper' for more in
    formation about this command.
    Loading repository data...
    Reading installed packages...
    Computing distribution upgrade...

    The following 2 applications are going to be REMOVED:
    Desktop "System Tray"

    No additional space will be used or freed after the operation.
    Nothing to do.

    I have been getting this message for over a week now. My PC used to run KDE Neon, I installed Tumbleweed onto the formatted system partition an retained the /home partition from when I used Neon. Can someone shed any light on whats going on?

    Start by showing us your repo list:
    Code:
    zypper lr -d
    -Gerry Makaro
    Fraser-Bell Info Tech
    Solving Tech Mysteries since the Olden Days!
    ~~
    If I helped you, consider clicking the Star at the bottom left of my post.

  3. #3
    Join Date
    Apr 2016
    Location
    Flix, Spain
    Posts
    7

    Default Re: System Tray and Desktop upgrade problem

    Repository priorities are without effect. All enabled repositories share the same priority.

    # | Alias | Name | Enabled | GPG Check | Refresh | Priority | Type | URI
    | Service
    ---+----------------------------------+-----------------------------+---------+-----------+---------+----------+--------+-----------------------------------------------------------------------
    -----+--------
    1 | http-ftp.gwdg.de-a962bacb | Packman Repository | Yes | (r ) Yes | Yes | 99 | rpm-md | http://ftp.gwdg.de/pub/linux/packman...SE_Tumbleweed/
    |
    2 | http-opensuse-guide.org-7f7dc2ef | libdvdcss repository | Yes | (r ) Yes | Yes | 99 | rpm-md | http://opensuse-guide.org/repo/openSUSE_Tumbleweed/
    |
    3 | openSUSE-20170407-0 | openSUSE-20170407-0 | No | ---- | ---- | 99 | yast2 | hd:///?device=/dev/disk/by-id/scsi-36001b440644477df0000000000000000-p
    art2 |
    4 | packman2 | packman2 | Yes | (r ) Yes | No | 99 | rpm-md | http://mirror.yandex.ru/opensuse/pac...SE_Tumbleweed/
    |
    5 | repo-debug | openSUSE-Tumbleweed-Debug | No | ---- | ---- | 99 | NONE | http://download.opensuse.org/debug/tumbleweed/repo/oss/
    |
    6 | repo-non-oss | openSUSE-Tumbleweed-Non-Oss | Yes | (r ) Yes | Yes | 99 | yast2 | http://download.opensuse.org/tumbleweed/repo/non-oss/
    |
    7 | repo-oss | openSUSE-Tumbleweed-Oss | Yes | (r ) Yes | Yes | 99 | yast2 | http://download.opensuse.org/tumbleweed/repo/oss/
    |
    8 | repo-source | openSUSE-Tumbleweed-Source | No | ---- | ---- | 99 | NONE | http://download.opensuse.org/source/...weed/repo/oss/
    |
    9 | repo-update | openSUSE-Tumbleweed-Update | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/update/tumbleweed/
    |
    10 | skype-stable | skype (stable) | Yes | (r ) Yes | Yes | 99 | rpm-md | https://repo.skype.com/rpm/stable/
    |


  4. #4
    Join Date
    Nov 2013
    Location
    Kamloops, BC, Canada
    Posts
    3,974

    Default Re: System Tray and Desktop upgrade problem

    Start by making certain your Packman switch is still in force.
    Code:
    zypper dup --from packman
    Then, make sure your repos and database are in order:
    Code:
    zypper clean --all
    zypper ref
    rpm  --rebuilddb
    Then, (maybe not needed, but can't hurt) refresh again:
    Code:
    zypper ref
    Since you have Packman, you want to do your Tumbleweed Updates and Upgrades with:
    Code:
    zypper dup --no-allow-vendor-change
    -Gerry Makaro
    Fraser-Bell Info Tech
    Solving Tech Mysteries since the Olden Days!
    ~~
    If I helped you, consider clicking the Star at the bottom left of my post.

  5. #5
    Join Date
    Apr 2016
    Location
    Flix, Spain
    Posts
    7

    Default Re: System Tray and Desktop upgrade problem

    Thanks for your help so far, but i've followed each step and I still get the same message:

    linux-quqw:~ # zypper dup --from packman
    Loading repository data...
    Reading installed packages...
    Computing distribution upgrade...

    The following 2 applications are going to be REMOVED:
    Desktop "System Tray"

    No additional space will be used or freed after the operation.
    Nothing to do.
    linux-quqw:~ # zypper clean --all
    All repositories have been cleaned up.
    linux-quqw:~ # zypper ref
    Retrieving repository 'libdvdcss repository' metadata ....................................................................................................................................[done]
    Building repository 'libdvdcss repository' cache .........................................................................................................................................[done]
    Retrieving repository 'packman' metadata .................................................................................................................................................[done]
    Building repository 'packman' cache ......................................................................................................................................................[done]
    Retrieving repository 'openSUSE-Tumbleweed-Non-Oss' metadata .............................................................................................................................[done]
    Building repository 'openSUSE-Tumbleweed-Non-Oss' cache ..................................................................................................................................[done]
    Retrieving repository 'openSUSE-Tumbleweed-Oss' metadata .................................................................................................................................[done]
    Building repository 'openSUSE-Tumbleweed-Oss' cache ......................................................................................................................................[done]
    Retrieving repository 'openSUSE-Tumbleweed-Update' metadata ..............................................................................................................................[done]
    Building repository 'openSUSE-Tumbleweed-Update' cache ...................................................................................................................................[done]
    Retrieving repository 'skype (stable)' metadata ..........................................................................................................................................[done]
    Building repository 'skype (stable)' cache ...............................................................................................................................................[done]
    All repositories have been refreshed.
    linux-quqw:~ # rpm --rebuilddb
    linux-quqw:~ # zypper ref
    Repository 'libdvdcss repository' is up to date.
    Repository 'packman' is up to date.
    Repository 'openSUSE-Tumbleweed-Non-Oss' is up to date.
    Repository 'openSUSE-Tumbleweed-Oss' is up to date.
    Repository 'openSUSE-Tumbleweed-Update' is up to date.
    Repository 'skype (stable)' is up to date.
    All repositories have been refreshed.
    linux-quqw:~ # zypper dup --no-allow-vendor-change
    Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' for more information about
    this command.
    Loading repository data...
    Reading installed packages...
    Computing distribution upgrade...

    The following 2 applications are going to be REMOVED:
    Desktop "System Tray"

    No additional space will be used or freed after the operation.
    Nothing to do.


  6. #6
    Join Date
    Nov 2013
    Location
    Kamloops, BC, Canada
    Posts
    3,974

    Default Re: System Tray and Desktop upgrade problem

    Then I would just ignore those messages. It appears you are up to date, AFAICS.

    ... unless one of our more technical members has anything to add, say Deano, Wolfi, or Arvidjaar, or others...
    -Gerry Makaro
    Fraser-Bell Info Tech
    Solving Tech Mysteries since the Olden Days!
    ~~
    If I helped you, consider clicking the Star at the bottom left of my post.

  7. #7
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,641
    Blog Entries
    3

    Default Re: System Tray and Desktop upgrade problem

    Quote Originally Posted by alanholt View Post
    The following 2 applications are going to be REMOVED:
    Desktop "System Tray"
    I ignore that.

    Zypper deals with packages, not with applications. If it says a package will be removed, then investigate. But if it is only reporting that an application will be removed, just treat it as background noise.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  8. #8
    Join Date
    Nov 2013
    Location
    Kamloops, BC, Canada
    Posts
    3,974

    Default Re: System Tray and Desktop upgrade problem

    Quote Originally Posted by nrickert View Post
    I ignore that.

    Zypper deals with packages, not with applications. If it says a package will be removed, then investigate. But if it is only reporting that an application will be removed, just treat it as background noise.
    Thanks for verifying, Neil.
    -Gerry Makaro
    Fraser-Bell Info Tech
    Solving Tech Mysteries since the Olden Days!
    ~~
    If I helped you, consider clicking the Star at the bottom left of my post.

  9. #9

    Default Re: System Tray and Desktop upgrade problem

    FWIW - I get the same message on tumbleweed using zypper as well, and it's the same on 2 new tumbleweed installs...I've been meaning to look into why it is saying that, and what to do, but for now I've been ignoring it. It will say it whether you use
    Code:
    zypper up
    or
    Code:
    zypper dup

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •