After investigating an unrelated issue, I was surprised to discover that my system was still using KDM instead of SDDM as the display manager. I just updated my configuration to fix this. However the switch introduces one problem:

My system was configured to enable automatic logins for my username. With KDM, the screen would instantly lock after logging in. With SDDM however, the screen does not automatically lock after an auto-login. Is there a way to fix this, and instruct KDE to immediately lock the session after the system logs in after booting while using SDDM?

I already looked in Configure Desktop - Workspace - Startup and Shutdown - Login Screen (SDDM). However the "Automatically lock screen on auto-login" option is gone. I assume there might be no easy solution, or this is a missing feature.