Results 1 to 3 of 3

Thread: GraphicsMagick requires libgomp, which is not provided

  1. #1

    Question GraphicsMagick requires libgomp, which is not provided

    I am attempting to install the GraphicsMagick package on SLES 12, using the instructions found at https://software.opensuse.org/downlo...GraphicsMagick

    Following those instructions, I get this error:

    # zypper addrepo http://download.opensuse.org/reposit.../graphics.repo
    Adding repository 'Graphics Project (SLE_12)' [......done]
    Repository 'Graphics Project (SLE_12)' successfully added
    Enabled: Yes
    Autorefresh: No
    GPG check: Yes
    URI: http://download.opensuse.org/reposit...aphics/SLE_12/
    # zypper refresh graphics
    Retrieving repository 'Graphics Project (SLE_12)' metadata [..

    Automatically importing the following key:

    Repository: Graphics Project (SLE_12)
    Key Name: graphics OBS Project <graphics@build.opensuse.org>
    Key Fingerprint: 4B9E37E2 BED9C972 5FAD399D 55E7BAF9 4F311B1D
    Key Created: Mon Aug 10 05:45:38 2015
    Key Expires: Wed Oct 18 05:45:38 2017
    Rpm Name: gpg-pubkey-4f311b1d-55c89cf2


    ...done]
    Building repository 'Graphics Project (SLE_12)' cache [....done]
    Specified repositories have been refreshed.
    # zypper install GraphicsMagick
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...

    Problem: nothing provides libgomp.so.1()(64bit) needed by libGraphicsMagick-Q16-3-1.3.25-89.5.x86_64
    Solution 1: do not install GraphicsMagick-1.3.25-89.5.x86_64
    Solution 2: break libGraphicsMagick-Q16-3-1.3.25-89.5.x86_64 by ignoring some of its dependencies

    Choose from above solutions by number or cancel [1/2/c] (c):

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,872

    Default Re: GraphicsMagick requires libgomp, which is not provided

    Quote Originally Posted by starnet_comm View Post
    I am attempting to install the GraphicsMagick package on SLES 12, ....
    Sorry, but these here are the openSUSE forums. The SLES/SLED forums are at: https://forums.suse.com/forum.php (thye same username/password as here).
    Henk van Velden

  3. #3
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,889

    Default AW: GraphicsMagick requires libgomp, which is not provided

    I think therefore it is disabled for SLES build.

    https://build.opensuse.org/package/s...GraphicsMagick

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •