Results 1 to 3 of 3

Thread: Cannot use osc

  1. #1

    Post Cannot use osc

    Hello, I tried to install osc by the command
    Code:
    sudo zypper in osc
    the packages are installed successfully, however it returned an error when I tried to use osc in the command line
    the error is
    Code:
    Traceback (most recent call last):
      File "/usr/bin/osc", line 10, in <module>
        from osc import commandline, babysitter
    ModuleNotFoundError: No module named 'osc'
    
    what should I do?

  2. #2
    Join Date
    May 2012
    Location
    Finland
    Posts
    2,002

    Default Re: Cannot use osc

    OSC is a python 2.x app so you may need to install python, my guess is you only have python3 installed and /usr/bin/python points to python3.6

    Edit:
    python --version

    Should be revealing. python-base should install a 2.7 symlink in /usr/bin/
    .: miuku #suse @ irc.freenode.net
    :: miuku@opensuse.org

    .: h​ttps://download.opensuse.org/repositories/home:/Miuku/

  3. #3

    Default Re: Cannot use osc

    Thanks, it works perfectly after linking python to /usr/bin/python2
    Quote Originally Posted by Miuku View Post
    OSC is a python 2.x app so you may need to install python, my guess is you only have python3 installed and /usr/bin/python points to python3.6

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •