Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: No volume feedback and can't change notifications volume.

  1. #1

    Default No volume feedback and can't change notifications volume.

    Hello everybody

    I have this problem, I just installed openSuSe 42.2 (KDE) in a MacBook Pro mid 2012 and everything seems to work except for the volume feedback for the volume controls I tried to increase the volume notifications in Configure Desktop -> Multimedia -> Audio Volume -> Notifications but I can't change the value from 0, if I try then the indicator returns to 0.

    And also the left and right test do not work but I do have sound.

    Any suggestions for this?

  2. #2
    Join Date
    Mar 2008
    Location
    Europe
    Posts
    27,173
    Blog Entries
    34

    Default Re: No volume feedback and can't change notifications volume.

    The desktop you installed (KDE ? Gnome ? XFCE ? other ? ) may play a roll here as the mixers that can be used for volume control can be different dependent on the desktop.

    The application 'pavucontrol' (pulse audio volume control) may give you more control over your computer volume under openSUSE if you install pavucontrol.

    If you run in an xterm/konsole (as a regular user with computer connected to the internet) the following diagnostic script, it might give some clues to misconfiguration :
    Code:
    /usr/sbin/alsa-info.sh
    select the SHARE/UPLOAD option when running the script, let the script run to completion, and when complete look in the xterm/konsole and it will give you a web address where the information was uploaded. Post here that web address / URL and we will look at it and see if we can spot anything misconfigured.
    .

  3. #3

    Default Re: No volume feedback and can't change notifications volume.

    Quote Originally Posted by oldcpu View Post
    The desktop you installed (KDE ? Gnome ? XFCE ? other ? ) may play a roll here as the mixers that can be used for volume control can be different dependent on the desktop.

    The application 'pavucontrol' (pulse audio volume control) may give you more control over your computer volume under openSUSE if you install pavucontrol.

    If you run in an xterm/konsole (as a regular user with computer connected to the internet) the following diagnostic script, it might give some clues to misconfiguration :
    Code:
    /usr/sbin/alsa-info.sh
    select the SHARE/UPLOAD option when running the script, let the script run to completion, and when complete look in the xterm/konsole and it will give you a web address where the information was uploaded. Post here that web address / URL and we will look at it and see if we can spot anything misconfigured.
    .
    Thanks for the reply, In my post I said that I have the KDE version and as you told me, here is the diagnostic file

    http://www.alsa-project.org/db/?f=294fcc2a2c33c2e50b21355853ab7d8d1b905028

    I'm not sure about pavucontrol, I might remember that it causes conflicts with alsamixer isn't it?

  4. #4
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    2,552

    Default AW: No volume feedback and can't change notifications volume.

    Code:
    I'm not sure about pavucontrol, I might remember that it causes conflicts with alsamixer isn't it?
    What conflicts?

    And no.

  5. #5

    Default Re: AW: No volume feedback and can't change notifications volume.

    Quote Originally Posted by Sauerland View Post
    Code:
    I'm not sure about pavucontrol, I might remember that it causes conflicts with alsamixer isn't it?
    What conflicts?

    And no.
    Ok...So anyway, with pavucontrol will I be able to change the notifications volume from the KDE configure desktop app?

  6. #6
    Join Date
    Sep 2010
    Location
    Poland
    Posts
    2,022

    Default Re: AW: No volume feedback and can't change notifications volume.

    Quote Originally Posted by mauricio288 View Post
    Ok...So anyway, with pavucontrol will I be able to change the notifications volume from the KDE configure desktop app?
    Yes with pavucontrol you can change the volume of any input/output application you want regardless of the desktop. The only thing you need is to be running pulseaudio but that should be on by default.
    Best regards,
    Greg
    Box: Windows 7 / Windows XP | Intel Dual-Core E5200 | ATI Radeon HD4850 | 4GB RAM
    Lap: openSUSE 13.2 / Windows 7 | Intel U7300 | KDE | Intel GMA 4500 | Asus UL80A | 3GB RAM

  7. #7
    Join Date
    Mar 2008
    Location
    Europe
    Posts
    27,173
    Blog Entries
    34

    Default Re: No volume feedback and can't change notifications volume.

    Quote Originally Posted by mauricio288 View Post
    Thanks for the reply, In my post I said that I have the KDE version and as you told me, here is the diagnostic file

    http://www.alsa-project.org/db/?f=294fcc2a2c33c2e50b21355853ab7d8d1b905028

    I'm not sure about pavucontrol, I might remember that it causes conflicts with alsamixer isn't it?
    From the script I note your MacBook Pro has pulse audio installed and running. There is only one alsa sound module loaded which is a snd_hda_intel. The MacBook Pro hardware audio codec is a Cirrus Logic CS4206. Your MacBook Pro supports analog (hw:0,0) and digital audio (hw:0,1), and also HDMI on one of the following (hw:0,3 or hw:0,7 or hw:0,8).

    The mixer indicates hour MacBook Pro's internal (?) speakers have been muted for some reason ? Is that your intent?
    Code:
    Simple mixer control 'Speaker',0
      Capabilities: pvolume pswitch
      Playback channels: Front Left - Front Right
      Limits: Playback 0 - 127
      Mono:
      Front Left: Playback 0 [0%] [-57.50dB] [off]
      Front Right: Playback 0 [0%] [-57.50dB] [off]
    Simple mixer control 'Bass Speaker',0
      Capabilities: pvolume pswitch
      Playback channels: Front Left - Front Right
      Limits: Playback 0 - 127
      Mono:
      Front Left: Playback 0 [0%] [-57.50dB] [off]
      Front Right: Playback 0 [0%] [-57.50dB] [off]
    Further digital audio (IEC958) playback is OFF.
    Code:
    Simple mixer control 'IEC958',0   Capabilities: pswitch pswitch-joined
      Playback channels: Mono
      Mono: Playback [off]
    The dmesg appears ok to me.

    I think you should
    • unmute your MacBook Pro speaker
    • install pavucontrol and use it to help configure pulse audio - where pulse audio IS running now on your MacBook Pro openSUSE


    If you need help in doing the above please advise.

    Good luck.
    .

  8. #8
    Join Date
    Mar 2008
    Location
    Europe
    Posts
    27,173
    Blog Entries
    34

    Default Re: No volume feedback and can't change notifications volume.

    Further you also have automute enabled:
    Code:
    Simple mixer control 'Auto-Mute Mode',0
      Capabilities: enum
      Items: 'Disabled' 'Enabled'
      Item0: 'Enabled'
    If that does not remove noise, then you could consider disabling it.
    .

  9. #9

    Default Re: No volume feedback and can't change notifications volume.

    Quote Originally Posted by oldcpu View Post
    Further you also have automute enabled:
    Code:
    Simple mixer control 'Auto-Mute Mode',0
      Capabilities: enum
      Items: 'Disabled' 'Enabled'
      Item0: 'Enabled'
    If that does not remove noise, then you could consider disabling it.
    .
    How do I disable Automute? Also, I don't have mute on my speakers, they have sound but in the test they don't

  10. #10
    Join Date
    Mar 2008
    Location
    Europe
    Posts
    27,173
    Blog Entries
    34

    Default Re: No volume feedback and can't change notifications volume.

    Quote Originally Posted by mauricio288 View Post
    How do I disable Automute? Also, I don't have mute on my speakers, they have sound but in the test they don't
    Did you enable the sound on your speakers (per my previous post) ?

    wrt automute, you should be able to do that using the application 'alsamixer'.

    Alternatively you could also use the command line app 'amixer' albeit the syntax is always (for me) a bit tricky to figure out.

    Possibly try something like (in an xterm/konsole as a regular user):
    Code:
    amixer -c 0 -- set 'Auto-Mute Mode' Disabled
    I am guessing at the syntax. Please report any syntax errors you may get from that.

    Also, wrt the other two speaker settings being muted, likely you could also unmute them with the 'amixer' command:
    Code:
    amixer -c 0 -- set 'Speaker' on 60%
    and
    Code:
    amixer -c 0 -- set 'Bass Speaker' on 60%
    60% was an arbitrary selection by me. Possibly you want it higher or lower. Also, I am not certain if the syntax is "set" or "sset" - so report any syntax errors as I am guessing a bit here.
    .

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •