Page 1 of 3 123 LastLast
Results 1 to 10 of 22

Thread: HDMI Audio not working

  1. #1

    Question HDMI Audio not working

    I bough a ASUS VivoMini VC66 this week and install Opensuse on it. However, when I plug a HDMI cable to the machine, the audio output is not working.
    I had searched and read some related issues, and I still have no idea how to get it work.

    I had installed pavucontrol. The configuration page show a list of Profile but all Build-in Audio (HDMI) are unplugged.

    Below is the report from /usr/sbin/alsa-info.sh
    http://www.alsa-project.org/db/?f=aa...3e15f97e4474d6

    I don't really understand the report. (I am quite new to Linux)
    I wish someone could help/teach me to fix the issue.

    Many thanks.

  2. #2
    Join Date
    Mar 2008
    Location
    Europe
    Posts
    27,173
    Blog Entries
    34

    Default Re: HDMI Audio not working

    Quote Originally Posted by syip View Post
    I bough a ASUS VivoMini VC66 this week and install Opensuse on it. However, when I plug a HDMI cable to the machine, the audio output is not working.
    ...
    Below is the report from /usr/sbin/alsa-info.sh
    http://www.alsa-project.org/db/?f=aa...3e15f97e4474d6
    The report tells us your ASUTek VC66 has only the analog device recognized as sound card-0 (an ALC255) also with an HDMI (Codec: Intel Kabylake HDMI).

    I do noted an error in the dmesg whic may (?) be relevant ?
    Code:
    [    5.066308] snd_hda_intel 0000:00:1f.3: failed to add i915 component master (-19)
    and a series of other HDMI messages:
    Code:
    [    5.085228]  [<ffffffffa045b469>] snd_hdac_i915_register_notifier 0x29/0x30 [snd_hda_core]
    [    5.085238]  [<ffffffffa089ccb4>] patch_generic_hdmi 0x2b4/0x6b0 [snd_hda_codec_hdmi]
    [    5.085246]  [<ffffffffa0542435>] hda_codec_driver_probe 0x65/0xf0 [snd_hda_codec]
    [    5.085250]  [<ffffffff8146cca7>] driver_probe_device 0x1f7/0x420
    --
    [    5.086206] ---[ end trace 42025597258258d2 ]---
    [    5.089339] input: HDA Intel PCH Mic as /devices/pci0000:00/0000:00:1f.3/sound/card0/input11
    [    5.089379] input: HDA Intel PCH Headphone as /devices/pci0000:00/0000:00:1f.3/sound/card0/input12
    [    5.089412] input: HDA Intel PCH HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:1f.3/sound/card0/input13
    [    5.089445] input: HDA Intel PCH HDMI/DP,pcm=7 as /devices/pci0000:00/0000:00:1f.3/sound/card0/input14
    [    5.089478] input: HDA Intel PCH HDMI/DP,pcm=8 as /devices/pci0000:00/0000:00:1f.3/sound/card0/input15
    also in aplay I note the HDMI detected:
    Code:
    !!Aplay/Arecord output
    !!--------------------
    
    APLAY
    
    **** List of PLAYBACK Hardware Devices ****
    card 0: PCH [HDA Intel PCH], device 0: ALC255 Analog [ALC255 Analog]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
      Subdevices: 0/1
      Subdevice #0: subdevice #0
    card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    So it reads your HDMI could be hw:0,3 or hw:0,7 or hw:0,8 .

    The HDMI does not show up in the mixer thou - and that is unexpected. Am I correct that this HDMI is on the motherboard ? I'm wondering if maybe you have an inappropriate setting in your BIOS ? Are there any relevant BIOS settings for HDMI ?

    Out of curiousity, do any of these commands (copied into an xterm or konsole as a regular user) give sound via your HDMI ?
    Code:
    aplay -D plughw:0,3 /usr/share/sounds/alsa/test.wav
    or
    Code:
    aplay -D plughw:0,7 /usr/share/sounds/alsa/test.wav
    or
    Code:
    aplay -D plughw:0,8 /usr/share/sounds/alsa/test.wav
    Searching the Internet on "Intel Kabylake HDMI alsa" and I see a lot of people having problems with GNU/Linux and this hardware. One bug report, for example, noted until after the power management puts the display to sleep at least once there is no sound. Upon waking the monitor sound is restored. That is VERY speculative ...

    I have read of users with this hardware clearing pulse audio settings which helped. ie emptied the directory under /home/username/.pulse and also emptying the directory under /home/username/.config/pulse (if there is such a directory - there may not be such) and then rebooting and testing. Again that is VERY speculative.

    This does not read to be an easy nut to crack.

    Let us know if any of the above aplay commands work.
    .

  3. #3

    Thumbs up Re: HDMI Audio not working

    Quote Originally Posted by oldcpu View Post
    The report tells us your ASUTek VC66 has only the analog device recognized as sound card-0 (an ALC255) also with an HDMI (Codec: Intel Kabylake HDMI).

    I do noted an error in the dmesg whic may (?) be relevant ?
    Code:
    [    5.066308] snd_hda_intel 0000:00:1f.3: failed to add i915 component master (-19)
    and a series of other HDMI messages:
    Code:
    [    5.085228]  [<ffffffffa045b469>] snd_hdac_i915_register_notifier 0x29/0x30 [snd_hda_core]
    [    5.085238]  [<ffffffffa089ccb4>] patch_generic_hdmi 0x2b4/0x6b0 [snd_hda_codec_hdmi]
    [    5.085246]  [<ffffffffa0542435>] hda_codec_driver_probe 0x65/0xf0 [snd_hda_codec]
    [    5.085250]  [<ffffffff8146cca7>] driver_probe_device 0x1f7/0x420
    --
    [    5.086206] ---[ end trace 42025597258258d2 ]---
    [    5.089339] input: HDA Intel PCH Mic as /devices/pci0000:00/0000:00:1f.3/sound/card0/input11
    [    5.089379] input: HDA Intel PCH Headphone as /devices/pci0000:00/0000:00:1f.3/sound/card0/input12
    [    5.089412] input: HDA Intel PCH HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:1f.3/sound/card0/input13
    [    5.089445] input: HDA Intel PCH HDMI/DP,pcm=7 as /devices/pci0000:00/0000:00:1f.3/sound/card0/input14
    [    5.089478] input: HDA Intel PCH HDMI/DP,pcm=8 as /devices/pci0000:00/0000:00:1f.3/sound/card0/input15
    also in aplay I note the HDMI detected:
    Code:
    !!Aplay/Arecord output
    !!--------------------
    
    APLAY
    
    **** List of PLAYBACK Hardware Devices ****
    card 0: PCH [HDA Intel PCH], device 0: ALC255 Analog [ALC255 Analog]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
      Subdevices: 0/1
      Subdevice #0: subdevice #0
    card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    So it reads your HDMI could be hw:0,3 or hw:0,7 or hw:0,8 .

    The HDMI does not show up in the mixer thou - and that is unexpected. Am I correct that this HDMI is on the motherboard ? I'm wondering if maybe you have an inappropriate setting in your BIOS ? Are there any relevant BIOS settings for HDMI ?

    Out of curiousity, do any of these commands (copied into an xterm or konsole as a regular user) give sound via your HDMI ?
    Code:
    aplay -D plughw:0,3 /usr/share/sounds/alsa/test.wav
    or
    Code:
    aplay -D plughw:0,7 /usr/share/sounds/alsa/test.wav
    or
    Code:
    aplay -D plughw:0,8 /usr/share/sounds/alsa/test.wav
    Searching the Internet on "Intel Kabylake HDMI alsa" and I see a lot of people having problems with GNU/Linux and this hardware. One bug report, for example, noted until after the power management puts the display to sleep at least once there is no sound. Upon waking the monitor sound is restored. That is VERY speculative ...

    I have read of users with this hardware clearing pulse audio settings which helped. ie emptied the directory under /home/username/.pulse and also emptying the directory under /home/username/.config/pulse (if there is such a directory - there may not be such) and then rebooting and testing. Again that is VERY speculative.

    This does not read to be an easy nut to crack.

    Let us know if any of the above aplay commands work.
    .
    Thanks for your reply. You had provided me some valuable information.

    >> Am I correct that this HDMI is on the motherboard ?

    Yes, I am currently using the on-board display card.
    I tried that in Windows 10 (before I replace Windows 10 with Opensuse), the same HDMI outputs audio successfully.
    Therefore, I believed that the BIIOS setting (UEFI in fact) should work.

    >>Out of curiousity, do any of these commands (copied into an xterm or konsole as a regular user) give sound via your HDMI ?

    I tried all of them without success.
    The 0,3 shows: aplay: main:786: audio open error: Device or resource busy
    The other two : Playing WAVE '/usr/share/sounds/alsa/test.wav' : Signed 16 bit Little Endian, Rate 44100 Hz, Stereo


    >>I have read of users with this hardware clearing pulse audio settings which helped. ie emptied the directory under /home/username/.pulse and also emptying the directory under /home/username/.config/pulse (if there is such a directory - there may not be such) and then rebooting and testing. Again that is VERY speculative.

    I removed the ~/.config/pulse and restarted, but still no luck.

    Thanks a lot for your time and help!

  4. #4
    Join Date
    Mar 2008
    Location
    Europe
    Posts
    27,173
    Blog Entries
    34

    Default Re: HDMI Audio not working

    Quote Originally Posted by syip View Post
    I tried all of them without success.
    The 0,3 shows: aplay: main:786: audio open error: Device or resource busy
    The other two : Playing WAVE '/usr/share/sounds/alsa/test.wav' : Signed 16 bit Little Endian, Rate 44100 Hz, Stereo
    Hmmm.

    that makes me think your HDMI device is hw:0,3.

    Try a 'lower case' d instead of an upper case. ie
    Code:
    aplay -d plughw:0,3 /usr/share/sounds/alsa/test.wav
    Do you get the same syntax error ?

  5. #5
    Join Date
    Mar 2008
    Location
    Europe
    Posts
    27,173
    Blog Entries
    34

    Default Re: HDMI Audio not working

    Quote Originally Posted by oldcpu View Post
    Hmmm.

    that makes me think your HDMI device is hw:0,3.

    Try a 'lower case' d instead of an upper case. ie
    Code:
    aplay -d plughw:0,3 /usr/share/sounds/alsa/test.wav
    Do you get the same syntax error ?
    ...
    although after posting that, I note the 'lower-case' is supposed to specify duration and not device. Possibly capital 'N' is better ? ie.
    Code:
    aplay -N plughw:0,3 /usr/share/sounds/alsa/test.wav
    My reference in this case for aplay options is: https://linux.die.net/man/1/aplay

    Do you have any idea as to what application seized the hw:0,3 device while you tested ? I hope you were not trying to play an audio with another application at the same time as this test.

  6. #6
    Join Date
    Mar 2008
    Location
    Europe
    Posts
    27,173
    Blog Entries
    34

    Default Re: HDMI Audio not working

    Quote Originally Posted by syip View Post
    I tried all of them without success.
    The 0,3 shows: aplay: main:786: audio open error: Device or resource busy
    Further to this - I want to know which device is blocking aplay from working here. What is the output of the following in a xterm as a regular user ? My guess is it is pulse audio.
    Code:
    lsof /dev/snd/*

  7. #7

    Default Re: HDMI Audio not working

    Quote Originally Posted by oldcpu View Post
    Further to this - I want to know which device is blocking aplay from working here. What is the output of the following in a xterm as a regular user ? My guess is it is pulse audio.
    Code:
    lsof /dev/snd/*
    This is the output:

    lsof: WARNING: can't stat() tracefs file system /sys/kernel/debug/tracing
    Output information may be incomplete.
    COMMAND PID USER FD TYPE DEVICE SIZE/OFF NODE NAME
    pulseaudi 2061 user 15u CHR 116,2 0t0 17032 /dev/snd/controlC0
    pulseaudi 2061 user 22u CHR 116,2 0t0 17032 /dev/snd/controlC0
    pulseaudi 2061 user 27u CHR 116,2 0t0 17032 /dev/snd/controlC0


    Yes, you are right. I had the plusaudiocontrol open that is blocking the aplay.



    aplay -N plughw:0,3 /usr/share/sounds/alsa/test.wav:
    plughw:0,3: No such file or directory

  8. #8
    Join Date
    Mar 2008
    Location
    Europe
    Posts
    27,173
    Blog Entries
    34

    Default Re: HDMI Audio not working

    Quote Originally Posted by syip View Post
    This is the output:

    lsof: WARNING: can't stat() tracefs file system /sys/kernel/debug/tracing
    Output information may be incomplete.
    COMMAND PID USER FD TYPE DEVICE SIZE/OFF NODE NAME
    pulseaudi 2061 user 15u CHR 116,2 0t0 17032 /dev/snd/controlC0
    pulseaudi 2061 user 22u CHR 116,2 0t0 17032 /dev/snd/controlC0
    pulseaudi 2061 user 27u CHR 116,2 0t0 17032 /dev/snd/controlC0

    Yes, you are right. I had the plusaudiocontrol open that is blocking the aplay.
    Ok, then try this:
    Code:
    pasuspender -- aplay -D plughw:0,3 /usr/share/sounds/alsa/test.wav
    The idea (and I do not know if this will work) is to use pasuspender to suspend pulse audio for that one aplay command. And the aplay command is being sent to confirm hw:0,3 is your HDMI device. The problem (for me) is I do not know the syntax well and I am guessing.
    .

  9. #9
    Join Date
    Mar 2008
    Location
    Europe
    Posts
    27,173
    Blog Entries
    34

    Default Re: HDMI Audio not working

    Quote Originally Posted by oldcpu View Post
    Ok, then try this:
    Code:
    pasuspender -- aplay -D plughw:0,3 /usr/share/sounds/alsa/test.wav
    The idea (and I do not know if this will work) is to use pasuspender to suspend pulse audio for that one aplay command. And the aplay command is being sent to confirm hw:0,3 is your HDMI device. The problem (for me) is I do not know the syntax well and I am guessing.
    .
    Another possible syntax (as I am guessing at the syntax) is:
    Code:
    pasuspender /usr/bin/aplay -- -D plughw:0,3 /usr/share/sounds/alsa/test.wav

  10. #10

    Default Re: HDMI Audio not working

    Quote Originally Posted by oldcpu View Post
    Another possible syntax (as I am guessing at the syntax) is:
    Code:
    pasuspender /usr/bin/aplay -- -D plughw:0,3 /usr/share/sounds/alsa/test.wav
    This is correct
    Code:
    pasuspender -- aplay -D plughw:0,3 /usr/share/sounds/alsa/test.wav
    It outputs
    Code:
    Playing WAVE '/usr/share/sounds/alsa/test.wav' : Signed 16 bit Little Endian, Rate 44100 Hz, Stereo
    without sound

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •