Results 1 to 4 of 4

Thread: mount tmp on tmpfs not working

  1. #1

    Default mount tmp on tmpfs not working

    Hi, I would like to mount /tmp to tmpfs.
    the way to do this today is via systemd,

    Code:
    [a4z@t460p ~] > systemctl is-enabled tmp.mount
    enabled
    
    [a4z@t460p ~] > df -k /tmp
    Filesystem     1K-blocks    Used Available Use% Mounted on
    /dev/sda6       41946112 9778212  31893644  24% /tmp
    I used the howto from here
    https://en.opensuse.org/SDB:SSD_perf...FS_filesystems

    why does it not work?

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,241

    Default Re: mount tmp on tmpfs not working

    I have this entry in my /etc/fstab
    Code:
    tmpfs		/tmp	   tmpfs	size=25%,uid=root,gid=root,mode=1777 0 0
    The 25% is of course something you should choose.
    Henk van Velden

  3. #3

    Default Re: mount tmp on tmpfs not working

    Quote Originally Posted by hcvv View Post
    I have this entry in my /etc/fstab
    Code:
    tmpfs        /tmp       tmpfs    size=25%,uid=root,gid=root,mode=1777 0 0
    The 25% is of course something you should choose.
    yes, thanks, this is of course the 'old style' approach,
    but systemd should manage this today, but it does not work on opensuse,
    what I remember, in former days I used openSuse, the tmpfs option could be set in yast via system settings or so,
    however, today the systemd way 'should' work ..... I know it works on rhe7 with systemctl enable tmp.mount since I did in at work today

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,241

    Default Re: mount tmp on tmpfs not working

    I do not know about the systemd way (it looks as if systems claims to do everything), but imho a reboot is required between switch such a thing on and it being active.
    Henk van Velden

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •