Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: When will Leap 42.2 get KDE 5.9?

  1. #1

    Default When will Leap 42.2 get KDE 5.9?

    I've filed several critical bugs against KDE 5.8 and they were closed saying it's fixed in 5.9, but after I fully update OpenSUSE Leap 42.2 I find that I'm still on KDE 5.8.6

  2. #2
    Join Date
    May 2012
    Location
    Finland
    Posts
    2,002

    Default Re: When will Leap 42.2 get KDE 5.9?

    5.8 is an LTS release, 42.2 won't upgrade to 5.9.
    .: miuku #suse @ irc.freenode.net
    :: miuku@opensuse.org

    .: h​ttps://download.opensuse.org/repositories/home:/Miuku/

  3. #3

    Default Re: When will Leap 42.2 get KDE 5.9?

    So LTS releases are supposed to be LESS stable than others? I got an update that BROKE Plasma Panel TaskManager, but I won't get the one that fixes it!?!

  4. #4
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,037

    Default Re: When will Leap 42.2 get KDE 5.9?

    On Fri, 31 Mar 2017 18:46:01 +0000, CountBakula wrote:

    > So LTS releases are supposed to be LESS stable than others? I got an
    > update that BROKE Plasma Panel TaskManager, but I won't get the one that
    > fixes it!?!


    The fix may be backported, but in general, openSUSE doesn't update
    versions of major components like KDE because doing so can break
    dependencies in unexpected ways.



    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

  5. #5
    Join Date
    May 2012
    Location
    Finland
    Posts
    2,002

    Default Re: When will Leap 42.2 get KDE 5.9?

    Quote Originally Posted by CountBakula View Post
    So LTS releases are supposed to be LESS stable than others? I got an update that BROKE Plasma Panel TaskManager, but I won't get the one that fixes it!?!
    They'll backport the fixes if they're critical - reporting them vs KDE on their bugtracker isn't going to do much.

    You should report them to openSUSE Bugzilla vs 42.2, I doubt they'll say "It's fixed in 5.9".
    .: miuku #suse @ irc.freenode.net
    :: miuku@opensuse.org

    .: h​ttps://download.opensuse.org/repositories/home:/Miuku/

  6. #6
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: When will Leap 42.2 get KDE 5.9?

    afik 42.2 won't get an "official" 5.9 but it is currently available from the kde:frameworks5 repo which has the latest kde versions
    http://download.opensuse.org/reposit...USE_Leap_42.2/
    the 5.8 LTS can be found here
    http://download.opensuse.org/reposit...USE_Leap_42.2/
    you'd also need the kde:qt5 repo as the updated plasma needs updated qt libraries
    http://download.opensuse.org/reposit...USE_Leap_42.2/
    if you want 5.9 on LEAP add those two repo's KDE:/Frameworks5 and KDE:/Qt5 and do a full vendor change to them
    note there are no delta rpm's for those repo's and they are updated often so you will endup downloading a lot of data

  7. #7

    Default Re: When will Leap 42.2 get KDE 5.9?

    Quote Originally Posted by I_A View Post
    afik 42.2 won't get an "official" 5.9 but it is currently available from the kde:frameworks5 repo which has the latest kde versions
    http://download.opensuse.org/reposit...USE_Leap_42.2/
    the 5.8 LTS can be found here
    http://download.opensuse.org/reposit...USE_Leap_42.2/
    you'd also need the kde:qt5 repo as the updated plasma needs updated qt libraries
    http://download.opensuse.org/reposit...USE_Leap_42.2/
    if you want 5.9 on LEAP add those two repo's KDE:/Frameworks5 and KDE:/Qt5 and do a full vendor change to them
    note there are no delta rpm's for those repo's and they are updated often so you will endup downloading a lot of data
    My multi-monitor configuration issues are somewhat comparable to the OP's so this was a very interesting proposition! Unfortunately, adding the KDE:/Frameworks5 and KDE:/Qt5 repositories, selecting 'allow vendor change' then selecting to 'upgrade all in this list if a newer package is available' yielded several hundred dependency conflicts on my freshly installed, fully updated Leap 42.2. Did I misinterpret something? Thanks!

  8. #8
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,721

    Default Re: When will Leap 42.2 get KDE 5.9?

    Quote Originally Posted by carlh04426 View Post
    adding the KDE:/Frameworks5 and KDE:/Qt5 repositories, selecting 'allow vendor change' then selecting to 'upgrade all in this list if a newer package is available' yielded several hundred dependency conflicts on my freshly installed, fully updated Leap 42.2. Did I misinterpret something? Thanks!
    I do not think this is waht was hinted at.
    From the View button choose Repositories. Then select the new repo. Above ths package list of the repos there is a line Switch all system packages ........ Click that line. That is the same as when doing the Vendor switch to Packman.

    I think your way of handling can create a mess, because it is based on version "numbers" throughout all repos. And version numbers of packages of the same name in the different repos are not said to be coordinated.
    Henk van Velden

  9. #9

    Default Re: When will Leap 42.2 get KDE 5.9?

    Quote Originally Posted by hcvv View Post
    I do not think this is waht was hinted at.
    From the View button choose Repositories. Then select the new repo. Above ths package list of the repos there is a line Switch all system packages ........ Click that line. That is the same as when doing the Vendor switch to Packman.

    I think your way of handling can create a mess, because it is based on version "numbers" throughout all repos. And version numbers of packages of the same name in the different repos are not said to be coordinated.
    Thank you very much for the clarification! I tried this method and, again, ran into an extremely large number of conflicts that could only be solved by uninstalling many packages. There were also a significant number of conflicts that could be resolved by 'switching vendor' to openSUSE Build Service. I'm going to put more time into devising workarounds for the specific problems I've encountered and put KDE 5.9 on the 'back burner' for awhile. Thanks again!

  10. #10
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,719
    Blog Entries
    20

    Default Re: When will Leap 42.2 get KDE 5.9?

    Switching can be tricky and yes, there will be some choices to make regarding dependencies but it's usually not as difficult to overcome as it looks.

    You can use the switch and just cancel away the dependency error
    Why?
    Because you can apply each switch required in turn (no changes take place at this point and you can just abort and start again as you get the feel of what the system is saying)

    You can always save the error list to a file, by using the expert button in the deps error box
    The let us see it
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •