Results 1 to 2 of 2

Thread: compiling Audacity 2.1.0

  1. #1

    Default compiling Audacity 2.1.0

    Machine #1

    Because of a BUG in Audacity 2.1.1 to Audacity 2.1.3, I am trying to compile Audacity 2.1.0 on my machine.
    The BUG is that you cannot change the default SAVE from .aiff to anything else and must type whatever file extension you require. Although that is not a big deal for one or two files, I have a great number of files to edit and would like to do it in as efficient manner as possible. Audacity is aware of the problem but have not found a solution to it yet. Apparently, it has to do with changing from wxWidgets 2.8.12 to wxWidgets 3.0.
    In the Audacity forums, I was told that I would need to compile wxWidgets 2.8.12 as Audacity 2.1.0 would need wxWidgets 2.8.12 to run.

    So far I have managed to compile wxWidgets 2.8.12.
    I am trying to compile Audacity 2.1.0, but am coming up with an error at the end.
    Following the advice on this page:
    http://wiki.audacityteam.org/wiki/Developing_On_Linux
    I checked to make sure all dependencies on their list were met.
    Are there any other dependencies that opensuse would require that may not have been on the list?
    I also installed all devel pkgs for these dependencies.
    It has been suggested[via google] that EXPAT, glibc and glibc-devel might not be installed, but I have checked and they are.
    It is shown in the code below [see next post] that the compile finds wxWidgets 2.8.12 and that EXPAT is there.

    This statement in the Audacity compile:
    Code:
    configure: WARNING: system installation of libmad found, but it is too old.  Upgrade to at least 0.14.2b to use with Audacity
    I have searched in Yast for 'libmad' and come up with 'libmad0' and its version is 1.15.1b-15.
    I see no 'libmad'.
    I have gone through the Audacity compile and checked for anything missing and there are things that may be missing but they are not in repos when I search in Yast.
    Where would I get them?
    I see a couple of other warnings. Is it possible to identify the 1st thing that went wrong and thereby correcting it, it may correct other problems down the line?

    I have run out of characters and the compile is too big also, so I will post the Audacity compile in pastebin.
    https://pastebin.com/eqtWFbX6
    Last edited by LaQuirrELL; 27-Mar-2017 at 17:49. Reason: adding link
    Machine # 1 - Asus Prime Z390A, i7-9700k 3.6GHz, 32.0 GB ram, openSUSE Leap 15.0 64-bit, KDE Plasma 5.12.8
    Machine # 2 - Asus P8Z77-V Deluxe, i7-3770k 3.5GHz, 16.0 GB ram, Debian 10 Buster 64-bit, LXDE

  2. #2

    Default Re: compiling Audacity 2.1.0 & [Audacity 2.12 .aiff BUG]

    NOTE: Out of desperation I tried the rpm for Audacity 2.1.0 version from here:
    http://packman.links2linux.org/package/286

    I installed it and It seems to work OK, although it was only used up to opensuse 13.2.
    I have edited a few songs thru it and it seems to be working. [as in it puts the .mp3 extension on the edited song. I don't know what 'bugs' were in 2.1.0 but they don't seem to be effecting my work yet. I have locked Audacity from auto updating.
    Machine # 1 - Asus Prime Z390A, i7-9700k 3.6GHz, 32.0 GB ram, openSUSE Leap 15.0 64-bit, KDE Plasma 5.12.8
    Machine # 2 - Asus P8Z77-V Deluxe, i7-3770k 3.5GHz, 16.0 GB ram, Debian 10 Buster 64-bit, LXDE

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •