Results 1 to 6 of 6

Thread: Cam't start kmail

  1. #1

    Default Cam't start kmail

    After update on Sunday kontact and kmail are not starting anymore. Akonadi is working because I am recieving notifications of new mails. I think the update was from wolfi323 repository.
    From the command line I get symbol lookup error:

    ric@linux-bl4k:~> kontactorg.kde.akonadi.ETM: GEN true false false
    org.kde.akonadi.ETM: collection: QVector()
    org.kde.akonadi.ETM:
    org.kde.akonadi.ETM: Subtree: 56 QSet(57, 56, 65, 64, 59, 58, 61, 60, 63, 62)
    org.kde.akonadi.ETM: collection: "Gmail"
    org.kde.akonadi.ETM: Fetch job took 242 msec
    org.kde.akonadi.ETM: was collection fetch job: collections: 10
    org.kde.akonadi.ETM: first fetched collection: "Carpetas locales"
    org.kde.akonadi.ETM: collection: QVector()
    org.kde.akonadi.ETM: Fetch job took 255 msec
    org.kde.akonadi.ETM: was collection fetch job: collections: 6
    org.kde.akonadi.ETM: first fetched collection: "Search"
    org.kde.akonadi.ETM: Fetch job took 85 msec
    org.kde.akonadi.ETM: was item fetch job: items: 12
    org.kde.akonadi.ETM: Fetch job took 114 msec
    org.kde.akonadi.ETM: was collection fetch job: collections: 0
    kontact: symbol lookup error: /opt/kf5/lib64/libKF5MessageCore.so.5: undefined symbol: _ZNK5KMime5Types7Mailbox13prettyAddressEv
    ric@linux-bl4k:~>

    Opensuse 42.2
    Repos
    wolfi323
    Kdeframework5
    Kdeframework5 applications
    kde Extra
    Qt5

    thanks

  2. #2
    Join Date
    Mar 2015
    Location
    Viçosa, Brasil
    Posts
    263

    Default Re: Cam't start kmail

    Why are you using the wolfi323 repo? The Akonadi from the openSUSE official repo is the same version of this unofficial repo. Remove this repo and the installation, update the system and reinstall it again.
    --
    Biostatistics and Data Science
    https://bio-data.github.io/

  3. #3

    Default Re: Cam't start kmail

    The op should be using Kmail5 that comes with the leap42.2 distro or some none related email package as some people fell out with kmail when version 4 arrived.

    If the op is trying to run an older version this one is still about but I have no idea how reliable it is now or how much has been changed from the original. It isn't supported by opensuse any more.

    https://software.opensuse.org/package/kdepim3

    I did install this initially but having looked at it decided to do a complete reinstall mainly because up to 12.3 I have continued to use it but that relies on some one sorting it out so that in can run on more recent releases without interfering with the fundamental reliability it had.

    Frankly I would not use the kmail 4 that I had but would assume that by the time 13. was released it was sorted out but 5 is probably better in several respects.

    John
    -
    Leap 42.2 KDE 5.26
    3.6gig Xeon, 64bit SATA Raid home - Linux Raid 1
    All software on a flash drive, SATA swap & Temp files,

  4. #4

    Default Re: Cam't start kmail

    After two updates the problem is solved. I use this repo mostly for kdenlive, wolfi323 has melt compiled for movit and graphics card so I can use the gpu. I tried kdenlive site with git master version for download, and they require Qt 5.8 and kframework5 repositories. Then I saw wolfi repository and is updated frequently. In the other hand I have to do it manually.
    So sometimes getting errors from kmail or other packages but is getting updated periodically.
    Thanks for your time and thanks for wolfi323 repository.

  5. #5
    Join Date
    Mar 2015
    Location
    Viçosa, Brasil
    Posts
    263

    Default Re: Cam't start kmail

    Quote Originally Posted by ricsan View Post
    After two updates the problem is solved. I use this repo mostly for kdenlive, wolfi323 has melt compiled for movit and graphics card so I can use the gpu. I tried kdenlive site with git master version for download, and they require Qt 5.8 and kframework5 repositories. Then I saw wolfi repository and is updated frequently. In the other hand I have to do it manually.
    So sometimes getting errors from kmail or other packages but is getting updated periodically.
    Thanks for your time and thanks for wolfi323 repository.
    I see. But remember that you can install apps from others repos without keep it (the repo) in the system. This is what I strongly recommend if you need of some packages from non-officials repositories.
    --
    Biostatistics and Data Science
    https://bio-data.github.io/

  6. #6

    Default Re: Cam't start kmail

    Quote Originally Posted by ricsan View Post
    After two updates the problem is solved. I use this repo mostly for kdenlive, wolfi323 has melt compiled for movit and graphics card so I can use the gpu. I tried kdenlive site with git master version for download, and they require Qt 5.8 and kframework5 repositories. Then I saw wolfi repository and is updated frequently. In the other hand I have to do it manually.
    So sometimes getting errors from kmail or other packages but is getting updated periodically.
    Thanks for your time and thanks for wolfi323 repository.
    Kdenlive is available in the leap 42.2 repo as is melt. Movit isn't however if you use opensuse software search it's available under none supported development via the multimedia repo. No disrespect to the wolfi repo but I tried a small app from it and it didn't work. If its a popular package you shouldn't have problems with one from the multimedia repo but I wouldn't leave it active in your repo list as it probably contains all sorts that might mess your machine up.

    The supported kdenlive can be installed from yast or from software search as can melt.

    If for some reason you must run kmail4 and official kdepim4 is also available. That has probably been maintained in case there were problems with kmail5 as there were with kmail4 - the early versions of that had all sorts of problems. I get the impression that kmail is now more or less a stand alone collection of software so any version may be ok but it may also use baloo.

    I linked to the software search earlier. It can be used to update to more recent versions of many applications etc but it needs some care as the repo may contain all sorts of bits and pieces that allow it to run. It's more likely to be ok on apps that have plenty of users. Generally that can mean that success depends on what you already have on your machine and if the repo's are left active the usual updates can get into a complete mess. That can mean that the machine will only boot to the console. A bit more serious than kmail not starting.

    One thing for sure once people stray from supported packages there isn't any guarantee however some repo's for upgrades are reliable probably because some one has been sorting out newer releases as soon as they come out for a rather long time mostly for special interest use in situations where a significant number of users want the updates including the person that did it.

    John
    -
    Leap 42.2 KDE 5.26
    3.6gig Xeon, 64bit SATA Raid home - Linux Raid 1
    All software on a flash drive, SATA swap & Temp files,

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •