Results 1 to 4 of 4

Thread: Linphone not installing correctly

  1. #1

    Default Linphone not installing correctly

    Trying to install linphone 3.10.2 on openSUSE Leap 42.2 XFCE.
    Tried both 'network:telephony' and 'home:ithod:updated' ... neither of which install to allow linphone to run.
    This is the error message that I get starting from the terminal ..... linphone: symbol lookup error: /usr/lib64/libmediastreamer_voip.so.7: undefined symbol: bctbx_rng_get
    Any suggestions would be helpful.

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,006
    Blog Entries
    1

    Default Re: Linphone not installing correctly

    I can't help directly, but if you might consider requesting support from the developers themselves

    http://www.linphone.org/contact.html

  3. #3
    Join Date
    Oct 2008
    Location
    Glasgow, Scotland
    Posts
    1,130

    Default Re: Linphone not installing correctly

    Linphone-3.10.2 from the Packman repository is working here on both Tumbleweed and Leap-42.2 KDE Plasma 5).
    ~Thank you for sharing an interesting problem.
    --
    slàinte mhath,
    rayH

  4. #4
    Join Date
    Sep 2010
    Location
    Poland
    Posts
    181

    Default Re: Linphone not installing correctly

    Hi
    I have my Linphone 3.10.2 running on my Leap 44.2

    But I DO remember problems with installing.
    I had to install some non-so-obvious packages.

    It seems you are missing this library - libmediastreamer_voip.so.7
    Check it out.

    Here is a very nice command to search for missing parts and libraries.. Type it as a su in Terminal.
    Code:
    zypper search --provides libmediastreamer_voip.so.7
    You can replace libmediastreamer_voip.so.7 with whatever you need.
    Then install suggested package with
    Code:
    zypper in suggested-package
    That way I was able step by step to install and finally run Linphone. Maybe you will need to install 32bit packages too.
    Linux 4.12.14
    openSUSE Leap 15.0 - 64 bit
    KDE Plasma 5.12.15
    KDE Framework 5.44.0
    Qt - 5.9.4

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •