Results 1 to 9 of 9

Thread: search finds nothing

  1. #1
    Join Date
    Jun 2008
    Location
    USA
    Posts
    1,125

    Default search finds nothing

    I have tried searching for a document that I can find by manually looking through Dolphin. But, if I name the document in the search bar of Dolphin, Libreoffice Writer or from the Start menu search bar, I get no results at all. Clearly, there is no index. I searched for an answer and saw something about the baloo index. I followed the steps to see if I could get a re-index going but nothing happened. Also tried using wild cards but still got no results on any file I searched for, all of which I can find manually. How do I get search to work?
    Any sufficiently advanced technology is indistinguishable from magic. - Arthur C. Clarke

  2. #2

    Default Re: search finds nothing

    Check that baloo5-file is installed, and that file indexing is activated in "Configure Desktop"->"Search"->"File Search". Also check that the folders you want to search are configured to be indexed in the settings.

    If that doesn't help, try to delete the index completely (/.local/share/baloo/) to force reindexing.

  3. #3

    Default Re: search finds nothing

    For me, "search" in Dolphin only works reliably if I disable indexing in "Configure Desktop"->"Search"->"File Search".
    I guess baloo is not involved then.

  4. #4

    Default Re: search finds nothing

    Quote Originally Posted by theo222 View Post
    For me, "search" in Dolphin only works reliably if I disable indexing in "Configure Desktop"->"Search"->"File Search".
    I guess baloo is not involved then.
    Correct.
    Dolphin falls back to using find and grep if indexing is disabled. As this is not using an index then, it may take longer though.
    If you don't bother (and don't want to search for more complex things like metadata or file modification dates), then disabling baloo may be a "solution" too.

  5. #5

    Default Re: search finds nothing

    Thank you.

    Quote Originally Posted by wolfi323 View Post
    disabling baloo may be a "solution" too.
    It seems like the only solution to me. Or how can I make baloo work?

    I have deleted: ~/.local/share/baloo/
    Changed "first run" in ~/.config/baloofilerc
    Restarted the system.

    But it only shows some files containing the search term, never all.
    Totally unreliable and useless for my purpose.

    Thank you.

  6. #6
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,744

    Default Re: search finds nothing

    Allow time it can take a while to index all the files. By default the whole system is indexed and there appears to be no opt in it is all opt out.

  7. #7
    Join Date
    Feb 2016
    Location
    Berlin
    Posts
    357

    Default Re: search finds nothing

    https://community.kde.org/Baloo/Configuration
    for configuration, if you delete the index be sure to set the first-run parameter

    https://forum.kde.org/viewtopic.php?f=154&t=128603
    use balooctl to check status (see if its stuck) also can check particular files have been indexed. balooctl has many other options but i have so far found no manual.

    by default baloo ignores some file types, hidden directories and indexing can get stuck on corrupted files

  8. #8

    Default Re: search finds nothing

    It does not work. This is a waste of time imo. I have disabled indexing.
    I'm only searching in certain folders on an SSD and I need accuracy, so the find&grep fallback will be fast enough for me.
    Thank you.

  9. #9

    Default Re: search finds nothing


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •