Results 1 to 2 of 2

Thread: Problems after system update

  1. #1
    Join Date
    Apr 2015
    Location
    Indiana
    Posts
    79

    Default Problems after system update

    I recently executed
    Code:
    sudo zypper update
    and the following errors appeared. How do I fix these uninstalled modules?

    Code:
    Output of dracut-037-80.1.x86_64.rpm %posttrans script:
        Creating initrd: /boot/initrd-4.1.36-44-default
        Executing: /usr/bin/dracut --logfile /var/log/YaST2/mkinitrd.log --force /boot/initrd-4.1.36-44-default 4.1.36-44-default
        dracut module 'multipath' will not be installed, because command 'multipath' could not be found!
        dracut module 'fcoe-uefi' will not be installed, because command 'dcbtool' could not be found!
        dracut module 'fcoe-uefi' will not be installed, because command 'fipvlan' could not be found!
        dracut module 'fcoe-uefi' will not be installed, because command 'lldpad' could not be found!
        dracut module 'multipath' will not be installed, because command 'multipath' could not be found!
        dracut module 'fcoe-uefi' will not be installed, because command 'dcbtool' could not be found!
        dracut module 'fcoe-uefi' will not be installed, because command 'fipvlan' could not be found!
        dracut module 'fcoe-uefi' will not be installed, because command 'lldpad' could not be found!
        *** Including module: bash ***
        *** Including module: warpclock ***
        *** Including module: i18n ***
        *** Including module: ifcfg ***
        *** Including module: drm ***
        *** Including module: plymouth ***
        *** Including module: btrfs ***
        *** Including module: kernel-modules ***
        Omitting driver i2o_scsi
        *** Including module: resume ***
        *** Including module: rootfs-block ***
        *** Including module: suse-btrfs ***
        /usr/lib/dracut/modules.d/95suse-btrfs/module-setup.sh: line 15: inst_fsck_help: command not found
        *** Including module: suse-xfs ***
        /usr/lib/dracut/modules.d/95suse-xfs/module-setup.sh: line 15: inst_fsck_help: command not found
        *** Including module: terminfo ***
        *** Including module: udev-rules ***
        Skipping udev rule: 91-permissions.rules
        Skipping udev rule: 80-drivers-modprobe.rules
        *** Including module: haveged ***
        *** Including module: systemd ***
        *** Including module: usrmount ***
        *** Including module: base ***
        *** Including module: fs-lib ***
        *** Including module: shutdown ***
        *** Including module: suse ***
        *** Including modules done ***
        *** Installing kernel module dependencies and firmware ***
        *** Installing kernel module dependencies and firmware done ***
        *** Resolving executable dependencies ***
        *** Resolving executable dependencies done***
        *** Hardlinking files ***
        *** Hardlinking files done ***
        *** Stripping files ***
        *** Stripping files done ***
        *** Generating early-microcode cpio image ***
        *** Constructing AuthenticAMD.bin ****
        *** Store current command line parameters ***
        Stored kernel commandline:
         resume=UUID=5f027dee-b560-4e47-a19e-6ed1a23924b3
        root=UUID=29ac95cd-4ff3-4e8c-8626-423621012d1e rootflags=rw,relatime,space_cache,subvolid=259,subvol=/@/.snapshots/1/snapshot rootfstype=btrfs
        *** Creating image file ***
        *** Creating image file done ***
        Some kernel modules could not be included
        This is not necessarily an error:
        swap
        Creating initrd: /boot/initrd-4.4.27-2-default
        Executing: /usr/bin/dracut --logfile /var/log/YaST2/mkinitrd.log --force /boot/initrd-4.4.27-2-default 4.4.27-2-default
        dracut module 'multipath' will not be installed, because command 'multipath' could not be found!
        dracut module 'fcoe-uefi' will not be installed, because command 'dcbtool' could not be found!
        dracut module 'fcoe-uefi' will not be installed, because command 'fipvlan' could not be found!
        dracut module 'fcoe-uefi' will not be installed, because command 'lldpad' could not be found!
        dracut module 'multipath' will not be installed, because command 'multipath' could not be found!
        dracut module 'fcoe-uefi' will not be installed, because command 'dcbtool' could not be found!
        dracut module 'fcoe-uefi' will not be installed, because command 'fipvlan' could not be found!
        dracut module 'fcoe-uefi' will not be installed, because command 'lldpad' could not be found!
        *** Including module: bash ***
        *** Including module: warpclock ***
        *** Including module: i18n ***
        *** Including module: ifcfg ***
        *** Including module: drm ***
        *** Including module: plymouth ***
        *** Including module: btrfs ***
        *** Including module: kernel-modules ***
        *** Including module: resume ***
        *** Including module: rootfs-block ***
        *** Including module: suse-btrfs ***
        /usr/lib/dracut/modules.d/95suse-btrfs/module-setup.sh: line 15: inst_fsck_help: command not found
        *** Including module: suse-xfs ***
        /usr/lib/dracut/modules.d/95suse-xfs/module-setup.sh: line 15: inst_fsck_help: command not found
        *** Including module: terminfo ***
        *** Including module: udev-rules ***
        Skipping udev rule: 91-permissions.rules
        Skipping udev rule: 80-drivers-modprobe.rules
        *** Including module: haveged ***
        *** Including module: systemd ***
        *** Including module: usrmount ***
        *** Including module: base ***
        *** Including module: fs-lib ***
        *** Including module: shutdown ***
        *** Including module: suse ***
        *** Including modules done ***
        *** Installing kernel module dependencies and firmware ***
        *** Installing kernel module dependencies and firmware done ***
        *** Resolving executable dependencies ***
        *** Resolving executable dependencies done***
        *** Hardlinking files ***
        *** Hardlinking files done ***
        *** Stripping files ***
        *** Stripping files done ***
        *** Generating early-microcode cpio image ***
        *** Constructing AuthenticAMD.bin ****
        *** Store current command line parameters ***
        Stored kernel commandline:
         resume=UUID=5f027dee-b560-4e47-a19e-6ed1a23924b3
        root=UUID=29ac95cd-4ff3-4e8c-8626-423621012d1e rootflags=rw,relatime,space_cache,subvolid=259,subvol=/@/.snapshots/1/snapshot rootfstype=btrfs
        *** Creating image file ***
        *** Creating image file done ***
        Some kernel modules could not be included
        This is not necessarily an error:
        scsi_dh
        swap
        Update bootloader...
    Bryan Sailer
    SpaceMonkey
    openSUSE LEAP 15.1
    KDE
    "Don't sweat the small stuff, it's all small stuff"

  2. #2

    Default Re: Problems after system update

    Quote Originally Posted by bryansailer View Post
    How do I fix these uninstalled modules?
    By installing the packages that contain them.

    But you likely don't need them anyway, especially if your system worked fine without them so far...
    These are just informational messages that those modules couldn't be copied to the initrd because they are not installed.

    In other words: ignore that.
    There is nothing to fix.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •