Results 1 to 6 of 6

Thread: KDE 5.8.3 Desktop - Can no longer drag windows

  1. #1

    Default KDE 5.8.3 Desktop - Can no longer drag windows

    Running 42.2 with KDE desktop and find I can no longer drag windows. For example if I open a terminal I cannot move it. Any suggestions as to what is going on and how to restore normal service please?

  2. #2

    Default Re: KDE 5.8.3 Desktop - Can no longer drag windows

    Quote Originally Posted by Budgie2 View Post
    Running 42.2 with KDE desktop and find I can no longer drag windows. For example if I open a terminal I cannot move it. Any suggestions as to what is going on and how to restore normal service please?
    Are the window title bars missing too?
    Then kwin crashed obviously, or wasn't started in the first place.

    Try to run it again with "kwin_x11 --replace" (as user, not root!).

    Btw, the latest Plasma in 42.2 is 5.8.6. Did you install all updates?

  3. #3

    Default Re: KDE 5.8.3 Desktop - Can no longer drag windows

    Quote Originally Posted by wolfi323 View Post
    Are the window title bars missing too?
    Then kwin crashed obviously, or wasn't started in the first place.

    Try to run it again with "kwin_x11 --replace" (as user, not root!).

    Btw, the latest Plasma in 42.2 is 5.8.6. Did you install all updates?
    Hi Wolfi and thanks for the reply. I solved my problem temporarily by logging out and then back in but there is clearly an issue with the update. I usually leave this to auto notification but when I run online update from Yast I get an error message:-

    There was an error in the repository initialization. SKIP request: User-requested skipping of a file History: - File '/repodata/repomd.xml' not found on medium 'http://download.opensuse.org/repositories/KDE:/Applications/openSUSE_Leap_42.2/'
    AFAIK I should not need this repo site for normal installation but what is going on. Is it an authority issue or have there been changes in url?

  4. #4

    Default Re: KDE 5.8.3 Desktop - Can no longer drag windows

    Quote Originally Posted by Budgie2 View Post
    AFAIK I should not need this repo site for normal installation but what is going on. Is it an authority issue or have there been changes in url?
    This repo doesn't exist any more (since weeks).
    Remove it in YaST->Repository Configuration or with zypper.

    http://lists.opensuse.org/opensuse-k.../msg00031.html

    If you still want to have the latest KDE applications, use this URL instead:
    http://download.opensuse.org/reposit...SUSE_Leap_42.2
    But note that this will *require* you to also add KDE:Frameworks5 and KDE:Qt5 and fully upgrade all KDE and Qt packages to the latest upstream versions.

    So it's probably better for you to stick to the standard versions, you won't miss much (as many KDE applications couldn't be built in newer versions anyway for 42.2, that was actually the reason for this change).
    Last edited by wolfi323; 16-Mar-2017 at 05:28.

  5. #5

    Default Re: KDE 5.8.3 Desktop - Can no longer drag windows

    Hi Wolfi,

    Quote Originally Posted by wolfi323 View Post
    This repo doesn't exist any more (since weeks).
    Remove it in YaST->Repository Configuration or with zypper.

    http://lists.opensuse.org/opensuse-k.../msg00031.html

    If you still want to have the latest KDE applications, use this URL instead:
    http://download.opensuse.org/reposit...SUSE_Leap_42.2
    But note that this will *require* you to also add KDE:Frameworks5 and KDE:Qt5 and fully upgrade all KDE and Qt packages to the latest upstream versions.

    So it's probably better for you to stick to the standard versions, you won't miss much (as many KDE applications couldn't be built in newer versions anyway for 42.2, that was actually the reason for this change).
    Now I understand. In truth I cannot remember what I used the KDE repo for so will delete as you suggest. Does this apply also to KDE Extra?
    I shall stick with standard versions.
    Regards,
    Budgie2

  6. #6

    Default Re: KDE 5.8.3 Desktop - Can no longer drag windows

    Quote Originally Posted by Budgie2 View Post
    Does this apply also to KDE Extra?
    KDE:Extra is still built for standard 42.2.

    It contains applications/packages not included in the distribution at all, and newer versions of some that are in the distribution (e.g. calligra, digikam).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •