Results 1 to 2 of 2

Thread: XFCE panel apps - padding problem

  1. #1

    Default XFCE panel apps - padding problem


    I've recently migrated from openSUSE 13.2 to Leap 42.2 (fresh install); I'm using XFCE (v4.12) with an application menu and a clock in the xfce panel. Unfortunately, icons and text in both get cut off:

    I'd like to have a two-row display of time and date in the clock but the date isn't readable.

    I've tried editing both ~/.config/gtk-3.0/gtk.css and ~/.gtkrc-2.0 to set the padding on those items - but to no avail.

    Do you have any tips on how to find out which of those two (or what else?) the xfce clock and application menu are using and how to change whatever is causing the cut off there? Any debug tools that are available in Leap 42.2 to investigate this?

  2. #2

    Default Re: XFCE panel apps - padding problem

    OK, figured out a fix that's good enough

    By playing around with the values in /usr/share/themes/Adwaita/gtk-2.0/main.rc and apps.rc I figured out how to fix the issue. Then I moved the necessary changes to /etc/gtk-2.0/gtkrc:
    style "less-padding" {
        GtkButton::inner-border           = {1, 1, 1, 1}
    class "GtkWidget"            style "less-padding"
    style "clock-padding" {
      GtkButton::inner-border           = {0, 0, 0, 0}
      xthickness = 0
      ythickness = 0
    widget "*clock*" style "clock-padding"
    To apply the changes quickly, I went to XFCE Settings Manager -> Appearance and in the "Style" tab switched from Adwaita to another style and back.

    Still don't know why ~/.gtkrc-2.0 isn't used but since it works now for me I stopped looking.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts