Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Fedora: [osc-rawhide]Unknown dependencies are broken

  1. #1

    Question Fedora: [osc-rawhide]Unknown dependencies are broken

    Code:
    # dnf config-manager -qy --add-repo https://download.opensuse.org/repositories/openSUSE:Tools/Fedora_Rawhide/openSUSE:Tools.repo
    # dnf install -y osc
    # dnf config-manager -qy --add-repo https://download.opensuse.org/repositories/home:X0F:HSF/openSUSE_Tumbleweed/home:X0F:HSF.repo
    # dnf config-manager -qy --add-repo https://download.opensuse.org/repositories/home:nuklly/openSUSE_Tumbleweed/home:nuklly.repo
    # dnf config-manager -qy --add-repo http://download.videolan.org/SuSE/Tumbleweed/
    # dnf update -y && dnf install -y telegram-desktop vlc
    How to fix dependencies under Rawhide with OpenSuSE OSC installed and Tumbleweed repo present?
    Code:
    [root@rawhide hd.scania]# dnf update -y && dnf install -y telegram telegram-desktop vlc
    Last metadata expiration check: 5:12:47 ago on Mon Mar 13 06:35:57 2017 MYT.
    Failed to synchronize cache for repo 'rommon-telegram', disabling.
    Dependencies resolved.
    ==========================================================================================================================================================================
     Package                                              Arch                            Version                                 Repository                             Size
    ==========================================================================================================================================================================
    Upgrading:
     dosfstools                                           x86_64                          4.1-101.3                               home_X0F_HSF                           77 k
     libunwind                                            x86_64                          1.2~rc1-121.10                          home_X0F_HSF                           56 k
     lxappearance-obconf                                  x86_64                          0.2.3-28.3                              home_X0F_HSF                           36 k
     menu-cache                                           x86_64                          1.0.2-68.3                              home_X0F_HSF                           56 k
     openal-soft                                          x86_64                          1.17.2-54.7                             home_X0F_HSF                          144 k
     pulseaudio-gdm-hooks                                 x86_64                          10.0-16.9                               home_X0F_HSF                           31 k
     pulseaudio-module-bluetooth                          x86_64                          10.0-16.9                               home_X0F_HSF                           87 k
     pulseaudio-module-x11                                x86_64                          10.0-16.9                               home_X0F_HSF                           48 k
     pulseaudio-utils                                     x86_64                          10.0-16.9                               home_X0F_HSF                          102 k
     xdg-utils                                            noarch                          20160610-96.2                           home_X0F_HSF                           86 k
     zenity                                               x86_64                          3.22.0-74.11                            home_X0F_HSF                          447 k
    Installing dependencies:
     libmenu-cache3                                       x86_64                          1.0.2-68.3                              home_X0F_HSF                           28 k
     libopenal1                                           x86_64                          1.17.2-54.7                             home_X0F_HSF                          256 k
     libpulse-mainloop-glib0                              x86_64                          10.0-16.9                               home_X0F_HSF                           38 k
     libpulse0                                            x86_64                          10.0-16.9                               home_X0F_HSF                          315 k
     perl-HTML-Tree                                       noarch                          1:5.03-15.fc26                          rawhide                               222 k
     perl-IO-stringy                                      noarch                          2.111-6.fc26                            rawhide                                70 k
     perl-Net-DBus                                        x86_64                          1.1.0-6.fc26                            rawhide                               213 k
     perl-X11-Protocol                                    noarch                          0.56-24.fc26                            rawhide                               144 k
     perl-XML-Parser                                      x86_64                          2.44-6.fc26                             rawhide                               223 k
     perl-XML-Twig                                        noarch                          3.52-2.fc26                             rawhide                               220 k
    Installing weak dependencies:
     lxappearance-obconf-lang                             noarch                          0.2.3-28.3                              home_X0F_HSF                           42 k
     zenity-lang                                          noarch                          3.22.0-74.11                            home_X0F_HSF                          380 k
    Skipping packages with broken dependencies
    (add '--best' to command line to see why package dependency cannot be satisfied):
     nano                                                 x86_64                          2.7.5-74.3                              home_X0F_HSF                          398 k
     pulseaudio                                           x86_64                          10.0-16.9                               home_X0F_HSF                          963 k
     xterm                                                x86_64                          327-153.5                               home_X0F_HSF                          122 k
    Transaction Summary
    ==========================================================================================================================================================================
    Install  12 Packages
    Upgrade  11 Packages
    Skip      3 Packages
    Total size: 3.2 M
    Downloading Packages:
    Running transaction check
    Transaction check succeeded.
    Running transaction test
    The downloaded packages were saved in cache until the next successful transaction.
    You can remove cached packages by executing 'dnf clean packages'.
    Error: Transaction check error:
      file /etc/pulse/client.conf from install of libpulse0-10.0-16.9.x86_64 conflicts with file from package pulseaudio-libs-10.0-4.fc26.x86_64
      file /usr/lib64/libpulse-simple.so.0.1.0 from install of libpulse0-10.0-16.9.x86_64 conflicts with file from package pulseaudio-libs-10.0-4.fc26.x86_64
      file /usr/lib64/libpulse.so.0.20.1 from install of libpulse0-10.0-16.9.x86_64 conflicts with file from package pulseaudio-libs-10.0-4.fc26.x86_64
      file /usr/lib64/pulseaudio/libpulsecommon-10.0.so from install of libpulse0-10.0-16.9.x86_64 conflicts with file from package pulseaudio-libs-10.0-4.fc26.x86_64
      file /usr/lib64/libpulse-mainloop-glib.so.0.0.5 from install of libpulse-mainloop-glib0-10.0-16.9.x86_64 conflicts with file from package pulseaudio-libs-glib2-10.0-4.f
    c26.x86_64
      file /usr/lib64/pulseaudio/libpulsedsp.so from install of pulseaudio-utils-10.0-16.9.x86_64 conflicts with file from package pulseaudio-libs-10.0-4.fc26.x86_64
      file /var/lib/gdm from install of pulseaudio-gdm-hooks-10.0-16.9.x86_64 conflicts with file from package gdm-1:3.23.91.1-1.fc27.x86_64
      file /usr/sbin/dosfsck conflicts between attempted installs of dosfstools-4.1-101.3.x86_64 and dosfstools-4.1-101.3.x86_64
      file /usr/sbin/dosfslabel conflicts between attempted installs of dosfstools-4.1-101.3.x86_64 and dosfstools-4.1-101.3.x86_64
      file /usr/sbin/fsck.fat conflicts between attempted installs of dosfstools-4.1-101.3.x86_64 and dosfstools-4.1-101.3.x86_64
      file /usr/sbin/fsck.msdos conflicts between attempted installs of dosfstools-4.1-101.3.x86_64 and dosfstools-4.1-101.3.x86_64
      file /usr/sbin/fsck.vfat conflicts between attempted installs of dosfstools-4.1-101.3.x86_64 and dosfstools-4.1-101.3.x86_64
      file /usr/sbin/mkdosfs conflicts between attempted installs of dosfstools-4.1-101.3.x86_64 and dosfstools-4.1-101.3.x86_64
      file /usr/sbin/mkfs.fat conflicts between attempted installs of dosfstools-4.1-101.3.x86_64 and dosfstools-4.1-101.3.x86_64
      file /usr/sbin/mkfs.msdos conflicts between attempted installs of dosfstools-4.1-101.3.x86_64 and dosfstools-4.1-101.3.x86_64
      file /usr/sbin/mkfs.vfat conflicts between attempted installs of dosfstools-4.1-101.3.x86_64 and dosfstools-4.1-101.3.x86_64
    
    Error Summary
    ------------- 
    [root@rawhide hd.scania]# dnf install -y telegram-desktop vlc          
    Last metadata expiration check: 5:13:16 ago on Mon Mar 13 06:35:57 2017 MYT.
    Failed to synchronize cache for repo 'rommon-telegram', disabling.
    Error:  
     Problem 1: conflicting requests
      - nothing provides xorg-x11-devel needed by telegram-desktop-1.0.14-1.4.src
      - nothing provides libcrypto.so.1.0.0()(64bit) needed by telegram-desktop-1.0.14-1.4.x86_64
     Problem 2: conflicting requests
      - nothing provides libass.so.9 needed by vlc-2.2.4-238.15.i586
      - nothing provides gdk-pixbuf-devel needed by vlc-2.2.4-238.15.src
      - nothing provides libass.so.9()(64bit) needed by vlc-2.2.4-238.15.x86_64
    (try to add '--allowerasing' to command line to replace conflicting packages)
    [root@rawhide hd.scania]# dnf install -y --allowerasing telegram-desktop vlc    
    Last metadata expiration check: 5:13:39 ago on Mon Mar 13 06:35:57 2017 MYT.
    Failed to synchronize cache for repo 'rommon-telegram', disabling.
    Error:  
     Problem 1: conflicting requests
      - nothing provides xorg-x11-devel needed by telegram-desktop-1.0.14-1.4.src
      - nothing provides libcrypto.so.1.0.0()(64bit) needed by telegram-desktop-1.0.14-1.4.x86_64
     Problem 2: conflicting requests
      - nothing provides libass.so.9 needed by vlc-2.2.4-238.15.i586
      - nothing provides gdk-pixbuf-devel needed by vlc-2.2.4-238.15.src
      - nothing provides libass.so.9()(64bit) needed by vlc-2.2.4-238.15.x86_64
    [root@rawhide hd.scania]#

  2. #2
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,300
    Blog Entries
    2

    Default Re: [osc-rawhide]Unknown dependencies are broken

    You may need to explain and describe your running environment, including why you're using a Fedora tool and installing Fedora RAwhide User tools...

    I still took a short look at what you tried to do...

    - It's fairly well known in the openSUSE community that the vlc repository has been deprecated, you should install install vlc from the main repository.

    - There is something wrong with the metadata to the XOF private repository, it may not work, or at least it can't be set up properly using our openSUSE command line package management tool, zypper. The other repos can be added fine.

    Results installing using zypper instead of dnf...
    - Telegram-desktop installs fine with no problem locating dependencies
    - osc failed to install, lacking a different dependency, complaining it didn't have a sufficiently recent version of m2crypto. I don't know if installingpython- m2crypto from the following link solves that issue
    https://software.opensuse.org/package/python-M2Crypto

    HTH,
    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  3. #3

    Default Re: [osc-rawhide]Unknown dependencies are broken

    I think i have got what you are saying ... do you mean installing Zypper under Fedora???

    Code:
    # dnf copr enable ngompa/zypper -qy && dnf install -y zypper && zypper
    Quote Originally Posted by tsu2 View Post
    You may need to explain and describe your running environment, including why you're using a Fedora tool and installing Fedora RAwhide User tools...

    I still took a short look at what you tried to do...

    - It's fairly well known in the openSUSE community that the vlc repository has been deprecated, you should install install vlc from the main repository.

    - There is something wrong with the metadata to the XOF private repository, it may not work, or at least it can't be set up properly using our openSUSE command line package management tool, zypper. The other repos can be added fine.

    Results installing using zypper instead of dnf...
    - Telegram-desktop installs fine with no problem locating dependencies
    - osc failed to install, lacking a different dependency, complaining it didn't have a sufficiently recent version of m2crypto. I don't know if installingpython- m2crypto from the following link solves that issue
    https://software.opensuse.org/package/python-M2Crypto

    HTH,
    TSU

  4. #4
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,300
    Blog Entries
    2

    Default Re: [osc-rawhide]Unknown dependencies are broken

    You need to describe what you have set up...
    Are you running something that supports running a different distro on openSUSE, something like Docker?
    Maybe even running openSUSE in docker on a Fedora?
    Or,
    Maybe you just want to install and run Fedora tools on an openSUSE?
    Or,
    Maybe you're doing something else?

    And, although you can use any RPM package manager like yum (and possibly dnf) on openSUSE, it's not generally recommended because then you'd have multiple package manager repositories which are unaware of what the other is doing.

    It's just highly unusual to be using tools specific to another distro on openSUSE (as it would also be reversed).
    So, if this is more than just a whim, the details of what you have set up may be important.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  5. #5

    Default Re: [osc-rawhide]Unknown dependencies are broken

    I should mean your points A and C, and opposed to B, in other means, Zypper and OSC have been installed under an another RPM distro like Rawhide (Mageia and OpenMandriva are equivalent here), and OpenSuSE have been not yet installed.
    Quote Originally Posted by tsu2 View Post
    You need to describe what you have set up...
    Are you running something that supports running a different distro on openSUSE, something like Docker?
    Maybe even running openSUSE in docker on a Fedora?
    Or,
    Maybe you just want to install and run Fedora tools on an openSUSE?
    Or,
    Maybe you're doing something else?

    And, although you can use any RPM package manager like yum (and possibly dnf) on openSUSE, it's not generally recommended because then you'd have multiple package manager repositories which are unaware of what the other is doing.

    It's just highly unusual to be using tools specific to another distro on openSUSE (as it would also be reversed).
    So, if this is more than just a whim, the details of what you have set up may be important.

    TSU

  6. #6
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,300
    Blog Entries
    2

    Default Re: [osc-rawhide]Unknown dependencies are broken

    Quote Originally Posted by hd_scania View Post
    I should mean your points A and C, and opposed to B, in other means, Zypper and OSC have been installed under an another RPM distro like Rawhide (Mageia and OpenMandriva are equivalent here), and OpenSuSE have been not yet installed.
    What are you trying to do?
    Why are you configuring openSUSE repos for non-openSUSE tools in some other distro?

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  7. #7
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: [osc-rawhide]Unknown dependencies are broken

    what tsu2 said use zypper and paste the error output here
    this might help you
    https://en.opensuse.org/images/1/17/...at-sheet-1.pdf
    you don't seam to have the packman repo, all multimedia should come from packman
    you can try this (after reading teh above 2 page pdf)
    Code:
    zypper ar -f http://ftp.gwdg.de/pub/linux/packman/suse/openSUSE_Tumbleweed/ packman
    zypper dup --from packman
    zypper in vlc vlc-codecs

  8. #8
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: [osc-rawhide]Unknown dependencies are broken

    my mistake if I understood correctly you are not running TW but Fedora and want to install some TW packages
    the title of this thread is wrong it should be other OS
    and as I have no idea on how to solve Fedora repo issues I'll quit here

  9. #9

    Default R: OpenSuSE tools in Rawhide

    Code:
    # dnf config-manager -qy --add-repo https://download.opensuse.org/reposi...USE:Tools.repo
    # dnf copr enable ngompa/zypper && dnf update -y && dnf install -y zypper osc
    # zypper -f ar https://download.opensuse.org/reposi...e:X0F:HSF.repo
    # zypper -f ar https://download.opensuse.org/reposi...me:nuklly.repo
    # zypper -f ar http://download.videolan.org/SuSE/Tumbleweed/
    # zypper ref -f && zypper up -f && zypper in -f telegram-desktop vlc
    In other words I am trying to install TW binaries thru Zypper for Rawhide, aka OpenSuSE tools in OTHER RPM distro.
    Quote Originally Posted by tsu2 View Post
    What are you trying to do?
    Why are you configuring openSUSE repos for non-openSUSE tools in some other distro?

    TSU

  10. #10
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: R: OpenSuSE tools in Rawhide

    Quote Originally Posted by hd_scania View Post
    Code:
    # dnf config-manager -qy --add-repo https://download.opensuse.org/reposi...USE:Tools.repo
    # dnf copr enable ngompa/zypper && dnf update -y && dnf install -y zypper osc
    # zypper -f ar https://download.opensuse.org/reposi...e:X0F:HSF.repo
    # zypper -f ar https://download.opensuse.org/reposi...me:nuklly.repo
    # zypper -f ar http://download.videolan.org/SuSE/Tumbleweed/
    # zypper ref -f && zypper up -f && zypper in -f telegram-desktop vlc
    In other words I am trying to install TW binaries thru Zypper for Rawhide, aka OpenSuSE tools in OTHER RPM distro.
    Rawhide is not TW and the title of this thread
    TUMBLEWEED [osc-rawhide]Unknown dependencies are broken
    is somewhat confusing
    if this is what you mean by Rawhide
    https://fedoraproject.org/wiki/Releases/Rawhide
    I have serious doubts that a native TW package will run under Fedora unstable, some might but Fedora has different library convention
    you might be better off asking some of the maintainers to build said package for fedora (using opensuse's OBS which supports Fedora)

    if a mod is reading this maybe change the TUMBLEWEED prefix to Other as Fedora is not TW

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •