Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Mozilla TBird problem

  1. #1

    Default Mozilla TBird problem

    Running Leap 42.1, KDE 5.5.5, Kernel 4.1.38-50-default

    Previously using TBird 45.6.0-31.1 without any problems.
    Using YaST2, updated to TBird 45.7.0-34.1. With that version, many but not all HTML links embedded in email fail to open in FFox. Tbird gui usually goes blank and frequently needs to be killed. If I wait 2-3 minutes the link will eventually open.

    Today I used YaST2 to revert to TBird 45.6.0-31.1 and all is well again.

    Since the pkg is provided by openSuse I don't know where to report this problem or check if it has been reported before.

    Jon

  2. #2
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,441

    Default Re: Mozilla TBird problem

    I suspect you may need to do a bit more research. I have just stepped through my recent Thunderbird links from a wide variety of sources and every one of them opened without a problem with 45.7.0-34.1.

    Is there a common factor in those links that will not open correctly in Firefox?

  3. #3
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: Mozilla TBird problem

    sounds like a desktop issue
    you could try and reset firefox as the default browser from both inside firefox and in plasma settings

  4. #4

    Default Re: Mozilla TBird problem

    I guess I need to look further, after startup this morning I have the same problem even tho I have back leveled TB.
    I'll check the default browser again too. But it's been firebird for years and I haven't changed anything except for updating Leap as fixes roll in.
    Thanks

  5. #5

    Default Re: Mozilla TBird problem

    I really don't know what to do about this issue. I back leveled both FF & TB. FF is now at 50.1.0-45.1 and TB is 45.6.0-31.1
    In looking at my problem further, any link in TB will finally open in FF after what is probably about a minute during which there is plenty of drive light activity.

    This was not a problem in the recent past. I don't recall the last time I opened a link so I don't know the exact date this started.
    I know I updated FF & TB over the last few weeks.
    I also updated the kernel twice in the last month.

    I don't know what else would cause this issue, I'm thinking maybe to backlevel the kernel.
    I have Snapper and it last updated the kernel on 23rd. This seems like a fairly drastic measure to take. Since I don't see anyone else with this problem I guess it has to point to my system.

    If I restore from Snapper, do I have to restore individually from the most recent, one at a time? Or if I pick, say, the 5th image back from current date, will it restore just that single image or all of the later ones too?

    I have been thinking about updating Leap but I'm in the middle of some stuff that I'd rather finish before making a major change to what was, until recently, a nicely working system.

  6. #6
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,188
    Blog Entries
    1

    Default Re: Mozilla TBird problem

    Just a thought - Do you still have problems if you start TB in safe mode?

  7. #7

    Default Re: Mozilla TBird problem

    Quote Originally Posted by deano_ferrari View Post
    Just a thought - Do you still have problems if you start TB in safe mode?
    Thanks, that's a good idea.
    I also found a page at Mozilla where it tells me how to restore FF to factory default state. I am also considering a test user and seeing how that works. And I can also try a new profile, something I'll leave to a last resort.

    Another thought....A few weeks ago I upped my ram from 8gb to 24gb. My swap partition is still 8gb. But a search of the web indicated that I probably don't need to resize the swap partition. I wonder......

    Finally, last night I used YaST to install the TB & FF updates that I earlier back-leveled. Today the problem has not presented itself, so I hope that the reinstall of the updates fixed a glitch.

  8. #8

    Default Re: Mozilla TBird problem

    Quote Originally Posted by I_A View Post
    sounds like a desktop issue
    you could try and reset firefox as the default browser from both inside firefox and in plasma settings

    By plasma settings do you mean "configure desktop" aka "system settings"? If so, my "default component" button :"in the following browser" is firefox %u.

    If you don't mean the above, where do I find the settings you are referring to?

    I also tried Deano's suggestion of TB in safe mode, no luck there.

    I did set up TB in a new KDE user login and did not have a problem, I need more time to know if this repeats as a new user. When I revert to my normal login, the problem is gone.....until the next day or maybe two days, when it shows up again.

    jon

  9. #9
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: Mozilla TBird problem

    Quote Originally Posted by 6520302 View Post
    By plasma settings do you mean "configure desktop" aka "system settings"? If so, my "default component" button :"in the following browser" is firefox %u.

    If you don't mean the above, where do I find the settings you are referring to?

    I also tried Deano's suggestion of TB in safe mode, no luck there.

    I did set up TB in a new KDE user login and did not have a problem, I need more time to know if this repeats as a new user. When I revert to my normal login, the problem is gone.....until the next day or maybe two days, when it shows up again.

    jon
    yes I did
    the plasma 5 setting where you setup your preferred web browser
    I haven't used T-bird on Lnux in some time (I use it on my win box) I think T-bird is gtk2 (or gtk3) app it might not know plasma 5 well but if a previous version worked it might be a build issue
    currently the mozilla repo has T-bird 45.7.1-1.3 you could try using that updated version (you might need to do a vendor change to that repo)
    http://download.opensuse.org/reposit...USE_Leap_42.1/
    an addon that's causing your issues you could try T-bird in safe mode
    I was going to recommend thunderbrowse to set your preferred browser within Thunderbird
    https://addons.mozilla.org/en-US/thu...thunderbrowse/
    but I don't think that is going to fix things

  10. #10

    Default Re: Mozilla TBird problem

    I_A:

    Thanks for info. Oddly, it is currently working correctly at this moment.
    I don't wish to go the route of a vendor change and adding stuff outside of the standard repo's. Seems like everytime I fiddle with this stuff I wind up in some kind of trouble sooner or later. I've found it safer just to wait for updates to show up in YaST.

    I've already tried the safe mode in TB & in FF with no luck.

    What has worked, sometimes - not always, is rebooting.

    I will look at thunderbrowse and see what it's all about. Thanks for that info.
    jon

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •