Page 1 of 6 123 ... LastLast
Results 1 to 10 of 59

Thread: System randomly freezes or crashes to the login screen, glitches until rebooted

  1. #1
    Join Date
    Jan 2009
    Location
    Romania, Bucharest
    Posts
    705

    Exclamation System randomly freezes or crashes to the login screen, glitches until rebooted

    Approximately once every 1 to 3 days of uptime, the system experiences a sudden and inexplicable crash: The image completely freezes in place, although unlike similar crashes in the past I can keep moving the mouse pointer around. A few seconds afterward, I find myself in a black console... and a few seconds after that, I'm back at the login screen. If I attempt to log back in however, the image either freezes again or desktop effects are no longer working without any error message as to why. Not even forcefully restarting X11 (control + alt + backspace twice) fixes the remaining glitches, and the only way to truly recover the system is to also reboot.

    Although the crashes are completely random, I vaguely get the impression they might be happening when an event triggers certain desktop effects. Several times the crash occurred as a system tray notification popped up, whereas just now the system crashed while I was switching desktops in the middle of the desktop cube animation. Certain games might also have a probability of causing this.

    I use the free video drivers and default system packages, all latest versions of openSUSE Tumbleweed. My card is a Radeon R7 370, GCN 1.0 on RadeonSI.
    openSUSE Tumbleweed x64, KDE Framework 5

  2. #2
    Join Date
    Jan 2009
    Location
    Romania, Bucharest
    Posts
    705

    Default Re: System randomly freezes or crashes to the login screen, glitches until rebooted

    This continues to be a huge issue with the latest Tumbleweed packages! The system now freezes and crashes on a hourly basis. It's likely something triggering a GPU crash, as it only seems to happen the moment certain desktop effects occur or given panels pop up; Even bringing up the taskbar (from auto-hide) or clicking the arrow which expands the system tray can cause it.

    The only way to recover the system without restarting is to immediately hit "control + alt + backspace" to kill x11 once noticing the freeze, before it has time to become permanent or the glitches I mentioned take place. Can anyone else confirm this please, and let us know whether a solution is being worked on?
    openSUSE Tumbleweed x64, KDE Framework 5

  3. #3

    Default Re: System randomly freezes or crashes to the login screen, glitches until rebooted

    Kernel 4.10 is... ehm... *cough* slightly experimental for the last few weeks.

    I expect someone of the usual suspects to show up here within the next few hours to tell you that TW is a rolling release and you should only use it for your microwave or so...
    Kind regards

    raspu

  4. #4
    Join Date
    Jan 2009
    Location
    Romania, Bucharest
    Posts
    705

    Default Re: System randomly freezes or crashes to the login screen, glitches until rebooted

    Quote Originally Posted by suse_rasputin View Post
    Kernel 4.10 is... ehm... *cough* slightly experimental for the last few weeks.

    I expect someone of the usual suspects to show up here within the next few hours to tell you that TW is a rolling release and you should only use it for your microwave or so...
    openSUSE Tumbleweed is generally very stable... there are only a few exceptions that occur a few times each year, which could (and likely will) be solved with better automated testing. TW only uses stable releases of each package, always tested to work at a basic level. The real madness would be running Factory directly, and expecting that to work perfectly all the time But yes, it does seem like Kernel 4.10 would be responsible for this... though it's just as likely the "radeon" driver itself.
    openSUSE Tumbleweed x64, KDE Framework 5

  5. #5
    Join Date
    Jul 2008
    Location
    Toronto, Canada
    Posts
    1,253

    Default Re: System randomly freezes or crashes to the login screen, glitches until rebooted

    As a test, try adding "intel_idle.max_cstate=1" without the quotes to the kernel boot parameters.
    Or to GRUB_CMDLINE_LINUX_DEFAULT= in /etc/default/grub then run grub2-mkconfig -o /boot/grub2/grub.cfg
    My Linux Box
    OS:
    openSUSE 42.3 - Plasma 5.8.7
    OS:
    Tumbleweed Plasma 5.15.4
    ASUS P5Q | Intel Quad 6600 @3.02 GHz | 8GB G.SKILL RAM | Nvidia GeForce 750 Ti

  6. #6
    Join Date
    Jan 2009
    Location
    Romania, Bucharest
    Posts
    705

    Default Re: System randomly freezes or crashes to the login screen, glitches until rebooted

    Quote Originally Posted by Romanator View Post
    As a test, try adding "intel_idle.max_cstate=1" without the quotes to the kernel boot parameters.
    Or to GRUB_CMDLINE_LINUX_DEFAULT= in /etc/default/grub then run grub2-mkconfig -o /boot/grub2/grub.cfg
    I assume this might not matter, but my video card is an AMD and not Intel. I figure that might be referring to the processor though, which is indeed a core i7 in my case.

    But I might try that if the freeze happens again. Surprisingly, a crash hasn't occurred during the last 24 hours, after some massive package updates... the problem might have been solved though I won't be surprised if it hasn't. Kernel 4.10.2 also hit Tumbleweed today, and from the looks of it 4.10.3 (with lots of driver fixes) might be in tomorrow... I should also see if those change anything.
    openSUSE Tumbleweed x64, KDE Framework 5

  7. #7
    Join Date
    Jan 2009
    Location
    Romania, Bucharest
    Posts
    705

    Default Re: System randomly freezes or crashes to the login screen, glitches until rebooted

    The issue seems to have been maintained from kernel 4.10.1 to 4.10.3. The new kernel has updated drivers, including for radeon which is what my card uses. This implies it might not be a driver issue, although I'm not sure where else such a trigger may be hidden.
    openSUSE Tumbleweed x64, KDE Framework 5

  8. #8
    Join Date
    Jan 2009
    Location
    Romania, Bucharest
    Posts
    705

    Default Re: System randomly freezes or crashes to the login screen, glitches until rebooted

    I discovered an important detail today: The crash is not limited to KDE desktop effects, unlike most crashes of this sort and what I initially suspected! I've had compositing disabled for several hours (alt + shift + F12) yet the exact same crash occurred just now: All windows and buttons froze in place while only the mouse cursor could be moved, the monitor then turned itself on and off a few times, and I found myself back to the login manager. Upon killing X11 and logging back in, I was presented with a window asking to check my compositor settings... indicating that KDE might have detected compositing as a source, although it's been entirely turned off so that couldn't be true.

    Could a maintainer or developer familiar with this part of the system please be dispatched to the issue? I have reported it two weeks ago, and so far there has been no official response here. While I understand the developers are busy with other concerns, this is a major problem due to which I can't keep my system from being shot down at random daily intervals. Considering that such a crash may occur anytime, including during a package update or while other processes are handling data, it leaves my system at risk of data corruption!

    Additionally, could I please request that updates for x11 and the AMD video driver are prioritized? http://tumbleweed.boombatower.com indicates that Devel has the following versions pending: xorg-x11-server 1.19.3 (currently 1.19.2), xf86-video-ati 7.9.0 (currently 7.8.0), Mesa 17.0.2 (currently 17.0.1). Yesterday's Factory snapshot appears to have ignored these packages. As Kernel updates don't seem to affect the issue, I'm hoping a new version of one of these components might include a solution. Thank you.
    openSUSE Tumbleweed x64, KDE Framework 5

  9. #9
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,589

    Default Re: System randomly freezes or crashes to the login screen, glitches until rebooted

    No developer here just us users. Report on bugzilla with as much detail as you can

    The joys of a rolling release

  10. #10
    Join Date
    Jan 2009
    Location
    Romania, Bucharest
    Posts
    705

    Default Re: System randomly freezes or crashes to the login screen, glitches until rebooted

    Quote Originally Posted by gogalthorp View Post
    No developer here just us users. Report on bugzilla with as much detail as you can

    The joys of a rolling release
    Already reported in two more places:

    https://bugzilla.opensuse.org/show_bug.cgi?id=1028575
    https://bugs.freedesktop.org/show_bug.cgi?id=100306

    openSUSE Tumbleweed is almost always stable; This sort of thing is the exception, and in the past worse issues happened with stable openSUSE releases too (though this was in the 11.x and pre 42.x era).
    openSUSE Tumbleweed x64, KDE Framework 5

Page 1 of 6 123 ... LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •