Results 1 to 3 of 3

Thread: Dependency errors reinstalling libreoffice suite after running zypper dup

  1. #1

    Default Dependency errors reinstalling libreoffice suite after running zypper dup

    Hi!I am running openSUSE Tumbleweed 32 bit.I routinely upgrade my system by running zypper dup command.

    When I ran zypper dup today it chose to uninstall the whole libreoffice suite.I have tried reinstalling the suite again using yast but I am getting dependency errors below.

    Please assist.Which repository can I get these missing packages or how else can I resolve this?

    Thanks.

    #### YaST2 conflicts list - generated 2018-01-13 09:00:50 ####

    nothing provides libicuuc.so.59.1 needed by libreoffice-5.4.3.2-1.3.i586

    [ ] do not install libreoffice-5.4.3.2-1.3.i586

    [ ] break libreoffice-5.4.3.2-1.3.i586 by ignoring some of its dependencies



    nothing provides libicuuc.so.59.1 needed by libreoffice-calc-5.4.3.2-1.3.i586

    [ ] do not install libreoffice-calc-5.4.3.2-1.3.i586

    [ ] break libreoffice-calc-5.4.3.2-1.3.i586 by ignoring some of its dependencies



    nothing provides libpoppler.so.72 needed by libreoffice-draw-5.4.3.2-1.3.i586

    [ ] do not install libreoffice-draw-5.4.3.2-1.3.i586

    [ ] break libreoffice-draw-5.4.3.2-1.3.i586 by ignoring some of its dependencies



    nothing provides libicuuc.so.59.1 needed by libreoffice-writer-5.4.3.2-1.3.i586

    [ ] do not install libreoffice-writer-5.4.3.2-1.3.i586

    [ ] break libreoffice-writer-5.4.3.2-1.3.i586 by ignoring some of its dependencies



    nothing provides libreoffice = 6.0.0.1 needed by libreoffice-gdb-pretty-printers-6.0.0.1-1.1.noarch

    [ ] do not install libreoffice-gdb-pretty-printers-6.0.0.1-1.1.noarch

    [ ] break libreoffice-gdb-pretty-printers-6.0.0.1-1.1.noarch by ignoring some of its dependencies



    nothing provides libreoffice = 6.0.0.1 needed by libreoffice-glade-6.0.0.1-1.1.noarch

    [ ] do not install libreoffice-glade-6.0.0.1-1.1.noarch

    [ ] break libreoffice-glade-6.0.0.1-1.1.noarch by ignoring some of its dependencies



    nothing provides libreoffice = 6.0.0.1 needed by libreoffice-l10n-af-6.0.0.1-1.1.noarch

    [ ] do not install libreoffice-l10n-af-6.0.0.1-1.1.noarch

    [ ] break libreoffice-l10n-af-6.0.0.1-1.1.noarch by ignoring some of its dependencies



    nothing provides libreoffice = 6.0.0.1 needed by libreoffice-l10n-ar-6.0.0.1-1.1.noarch

    [ ] do not install libreoffice-l10n-ar-6.0.0.1-1.1.noarch

    [ ] break libreoffice-l10n-ar-6.0.0.1-1.1.noarch by ignoring some of its dependencies



    nothing provides libreoffice = 6.0.0.1 needed by libreoffice-l10n-as-6.0.0.1-1.1.noarch

    [ ] do not install libreoffice-l10n-as-6.0.0.1-1.1.noarch

    [ ] break libreoffice-l10n-as-6.0.0.1-1.1.noarch by ignoring some of its dependencies



    nothing provides libreoffice = 6.0.0.1 needed by libreoffice-l10n-bg-6.0.0.1-1.1.noarch

    [ ] do not install libreoffice-l10n-bg-6.0.0.1-1.1.noarch

    [ ] break libreoffice-l10n-bg-6.0.0.1-1.1.noarch by ignoring some of its dependencies



    nothing provides libreoffice = 6.0.0.1 needed by libreoffice-l10n-bn-6.0.0.1-1.1.noarch

    [ ] do not install libreoffice-l10n-bn-6.0.0.1-1.1.noarch

    [ ] break libreoffice-l10n-bn-6.0.0.1-1.1.noarch by ignoring some of its dependencies



    nothing provides libreoffice = 6.0.0.1 needed by libreoffice-l10n-br-6.0.0.1-1.1.noarch

    [ ] do not install libreoffice-l10n-br-6.0.0.1-1.1.noarch

    [ ] break libreoffice-l10n-br-6.0.0.1-1.1.noarch by ignoring some of its dependencies



    nothing provides libreoffice = 6.0.0.1 needed by libreoffice-l10n-ca-6.0.0.1-1.1.noarch

    [ ] do not install libreoffice-l10n-ca-6.0.0.1-1.1.noarch

    [ ] break libreoffice-l10n-ca-6.0.0.1-1.1.noarch by ignoring some of its dependencies



    nothing provides libreoffice = 6.0.0.1 needed by libreoffice-l10n-cs-6.0.0.1-1.1.noarch

    [ ] do not install libreoffice-l10n-cs-6.0.0.1-1.1.noarch

    [ ] break libreoffice-l10n-cs-6.0.0.1-1.1.noarch by ignoring some of its dependencies



    nothing provides libreoffice = 6.0.0.1 needed by libreoffice-l10n-cy-6.0.0.1-1.1.noarch

    [ ] break libreoffice-l10n-cy-6.0.0.1-1.1.noarch by ignoring some of its dependencies

    [ ] do not install libreoffice-l10n-cy-6.0.0.1-1.1.noarch



    nothing provides libreoffice = 6.0.0.1 needed by libreoffice-l10n-da-6.0.0.1-1.1.noarch

    [ ] do not install libreoffice-l10n-da-6.0.0.1-1.1.noarch

    [ ] break libreoffice-l10n-da-6.0.0.1-1.1.noarch by ignoring some of its dependencies



    nothing provides libreoffice = 6.0.0.1 needed by libreoffice-l10n-de-6.0.0.1-1.1.noarch

    [ ] do not install libreoffice-l10n-de-6.0.0.1-1.1.noarch

    [ ] break libreoffice-l10n-de-6.0.0.1-1.1.noarch by ignoring some of its dependencies



    nothing provides libreoffice = 6.0.0.1 needed by libreoffice-l10n-dz-6.0.0.1-1.1.noarch

    [ ] do not install libreoffice-l10n-dz-6.0.0.1-1.1.noarch

    [ ] break libreoffice-l10n-dz-6.0.0.1-1.1.noarch by ignoring some of its dependencies



    nothing provides libreoffice = 6.0.0.1 needed by libreoffice-l10n-el-6.0.0.1-1.1.noarch

    [ ] do not install libreoffice-l10n-el-6.0.0.1-1.1.noarch

    [ ] break libreoffice-l10n-el-6.0.0.1-1.1.noarch by ignoring some of its dependencies



    nothing provides libreoffice = 6.0.0.1 needed by libreoffice-l10n-en-6.0.0.1-1.1.noarch

    [ ] do not install libreoffice-l10n-en-6.0.0.1-1.1.noarch

    [ ] break libreoffice-l10n-en-6.0.0.1-1.1.noarch by ignoring some of its dependencies



    nothing provides libreoffice = 6.0.0.1 needed by libreoffice-l10n-eo-6.0.0.1-1.1.noarch

    [ ] do not install libreoffice-l10n-eo-6.0.0.1-1.1.noarch

    [ ] break libreoffice-l10n-eo-6.0.0.1-1.1.noarch by ignoring some of its dependencies



    nothing provides libreoffice = 6.0.0.1 needed by libreoffice-l10n-es-6.0.0.1-1.1.noarch

    [ ] do not install libreoffice-l10n-es-6.0.0.1-1.1.noarch

    [ ] break libreoffice-l10n-es-6.0.0.1-1.1.noarch by ignoring some of its dependencies



    nothing provides libreoffice = 6.0.0.1 needed by libreoffice-l10n-et-6.0.0.1-1.1.noarch

    [ ] do not install libreoffice-l10n-et-6.0.0.1-1.1.noarch

    [ ] break libreoffice-l10n-et-6.0.0.1-1.1.noarch by ignoring some of its dependencies



    nothing provides libreoffice = 6.0.0.1 needed by libreoffice-l10n-eu-6.0.0.1-1.1.noarch

    [ ] do not install libreoffice-l10n-eu-6.0.0.1-1.1.noarch

    [ ] break libreoffice-l10n-eu-6.0.0.1-1.1.noarch by ignoring some of its dependencies



    nothing provides libreoffice = 6.0.0.1 needed by libreoffice-l10n-fa-6.0.0.1-1.1.noarch

    [ ] do not install libreoffice-l10n-fa-6.0.0.1-1.1.noarch

    [ ] break libreoffice-l10n-fa-6.0.0.1-1.1.noarch by ignoring some of its dependencies



    nothing provides libreoffice = 6.0.0.1 needed by libreoffice-l10n-fi-6.0.0.1-1.1.noarch

    [ ] do not install libreoffice-l10n-fi-6.0.0.1-1.1.noarch

    [ ] break libreoffice-l10n-fi-6.0.0.1-1.1.noarch by ignoring some of its dependencies


    nothing provides libreoffice = 6.0.0.1 needed by libreoffice-l10n-hu-6.0.0.1-1.1.noarch

    [ ] do not install libreoffice-l10n-hu-6.0.0.1-1.1.noarch

    [ ] break libreoffice-l10n-hu-6.0.0.1-1.1.noarch by ignoring some of its dependencies



    nothing provides libreoffice = 6.0.0.1 needed by libreoffice-l10n-it-6.0.0.1-1.1.noarch

    [ ] break libreoffice-l10n-it-6.0.0.1-1.1.noarch by ignoring some of its dependencies

    [ ] do not install libreoffice-l10n-it-6.0.0.1-1.1.noarch



    nothing provides libreoffice = 6.0.0.1 needed by libreoffice-l10n-ja-6.0.0.1-1.1.noarch

    [ ] do not install libreoffice-l10n-ja-6.0.0.1-1.1.noarch

    [ ] break libreoffice-l10n-ja-6.0.0.1-1.1.noarch by ignoring some of its dependencies



    nothing provides libreoffice = 6.0.0.1 needed by libreoffice-l10n-kk-6.0.0.1-1.1.noarch

    [ ] do not install libreoffice-l10n-kk-6.0.0.1-1.1.noarch

    [ ] break libreoffice-l10n-kk-6.0.0.1-1.1.noarch by ignoring some of its dependencies


    nothing provides libreoffice = 6.0.0.1 needed by libreoffice-l10n-pl-6.0.0.1-1.1.noarch

    [ ] do not install libreoffice-l10n-pl-6.0.0.1-1.1.noarch

    [ ] break libreoffice-l10n-pl-6.0.0.1-1.1.noarch by ignoring some of its dependencies



    nothing provides libreoffice = 6.0.0.1 needed by libreoffice-l10n-pt_BR-6.0.0.1-1.1.noarch

    [ ] do not install libreoffice-l10n-pt_BR-6.0.0.1-1.1.noarch

    [ ] break libreoffice-l10n-pt_BR-6.0.0.1-1.1.noarch by ignoring some of its dependencies



    nothing provides libreoffice = 6.0.0.1 needed by libreoffice-l10n-pt_PT-6.0.0.1-1.1.noarch

    [ ] do not install libreoffice-l10n-pt_PT-6.0.0.1-1.1.noarch

    [ ] break libreoffice-l10n-pt_PT-6.0.0.1-1.1.noarch by ignoring some of its dependencies



    nothing provides libreoffice = 6.0.0.1 needed by libreoffice-l10n-ro-6.0.0.1-1.1.noarch

    [ ] do not install libreoffice-l10n-ro-6.0.0.1-1.1.noarch

    [ ] break libreoffice-l10n-ro-6.0.0.1-1.1.noarch by ignoring some of its dependencies



    nothing provides libreoffice = 6.0.0.1 needed by libreoffice-l10n-ru-6.0.0.1-1.1.noarch

    [ ] do not install libreoffice-l10n-ru-6.0.0.1-1.1.noarch

    [ ] break libreoffice-l10n-ru-6.0.0.1-1.1.noarch by ignoring some of its dependencies



    nothing provides libreoffice = 6.0.0.1 needed by libreoffice-l10n-si-6.0.0.1-1.1.noarch

    [ ] do not install libreoffice-l10n-si-6.0.0.1-1.1.noarch

    [ ] break libreoffice-l10n-si-6.0.0.1-1.1.noarch by ignoring some of its dependencies



    nothing provides libreoffice = 6.0.0.1 needed by libreoffice-l10n-sk-6.0.0.1-1.1.noarch

    [ ] do not install libreoffice-l10n-sk-6.0.0.1-1.1.noarch

    [ ] break libreoffice-l10n-sk-6.0.0.1-1.1.noarch by ignoring some of its dependencies



    nothing provides libreoffice = 6.0.0.1 needed by libreoffice-l10n-sl-6.0.0.1-1.1.noarch

    [ ] do not install libreoffice-l10n-sl-6.0.0.1-1.1.noarch

    [ ] break libreoffice-l10n-sl-6.0.0.1-1.1.noarch by ignoring some of its dependencies



    nothing provides libreoffice = 6.0.0.1 needed by libreoffice-l10n-sr-6.0.0.1-1.1.noarch

    [ ] do not install libreoffice-l10n-sr-6.0.0.1-1.1.noarch

    [ ] break libreoffice-l10n-sr-6.0.0.1-1.1.noarch by ignoring some of its dependencies



    nothing provides libreoffice = 6.0.0.1 needed by libreoffice-l10n-ss-6.0.0.1-1.1.noarch

    [ ] do not install libreoffice-l10n-ss-6.0.0.1-1.1.noarch

    [ ] break libreoffice-l10n-ss-6.0.0.1-1.1.noarch by ignoring some of its dependencies



    nothing provides libreoffice = 6.0.0.1 needed by libreoffice-l10n-st-6.0.0.1-1.1.noarch

    [ ] do not install libreoffice-l10n-st-6.0.0.1-1.1.noarch

    [ ] break libreoffice-l10n-st-6.0.0.1-1.1.noarch by ignoring some of its dependencies



    nothing provides libreoffice = 6.0.0.1 needed by libreoffice-l10n-sv-6.0.0.1-1.1.noarch

    [ ] do not install libreoffice-l10n-sv-6.0.0.1-1.1.noarch

    [ ] break libreoffice-l10n-sv-6.0.0.1-1.1.noarch by ignoring some of its dependencies



    nothing provides libreoffice = 6.0.0.1 needed by libreoffice-l10n-ta-6.0.0.1-1.1.noarch

    [ ] do not install libreoffice-l10n-ta-6.0.0.1-1.1.noarch

    [ ] break libreoffice-l10n-ta-6.0.0.1-1.1.noarch by ignoring some of its dependencies



    nothing provides libreoffice = 6.0.0.1 needed by libreoffice-l10n-te-6.0.0.1-1.1.noarch

    [ ] do not install libreoffice-l10n-te-6.0.0.1-1.1.noarch

    [ ] break libreoffice-l10n-te-6.0.0.1-1.1.noarch by ignoring some of its dependencies



    nothing provides libreoffice = 6.0.0.1 needed by libreoffice-l10n-th-6.0.0.1-1.1.noarch

    [ ] do not install libreoffice-l10n-th-6.0.0.1-1.1.noarch

    [ ] break libreoffice-l10n-th-6.0.0.1-1.1.noarch by ignoring some of its dependencies



    nothing provides libreoffice = 6.0.0.1 needed by libreoffice-l10n-tn-6.0.0.1-1.1.noarch

    [ ] do not install libreoffice-l10n-tn-6.0.0.1-1.1.noarch

    [ ] break libreoffice-l10n-tn-6.0.0.1-1.1.noarch by ignoring some of its dependencies



    nothing provides libreoffice = 6.0.0.1 needed by libreoffice-l10n-tr-6.0.0.1-1.1.noarch

    [ ] do not install libreoffice-l10n-tr-6.0.0.1-1.1.noarch

    [ ] break libreoffice-l10n-tr-6.0.0.1-1.1.noarch by ignoring some of its dependencies



    nothing provides libreoffice = 6.0.0.1 needed by libreoffice-l10n-ts-6.0.0.1-1.1.noarch

    [ ] do not install libreoffice-l10n-ts-6.0.0.1-1.1.noarch

    [ ] break libreoffice-l10n-ts-6.0.0.1-1.1.noarch by ignoring some of its dependencies



    nothing provides libreoffice = 6.0.0.1 needed by libreoffice-l10n-uk-6.0.0.1-1.1.noarch

    [ ] do not install libreoffice-l10n-uk-6.0.0.1-1.1.noarch

    [ ] break libreoffice-l10n-uk-6.0.0.1-1.1.noarch by ignoring some of its dependencies



    nothing provides libreoffice = 6.0.0.1 needed by libreoffice-l10n-ve-6.0.0.1-1.1.noarch

    [ ] do not install libreoffice-l10n-ve-6.0.0.1-1.1.noarch

    [ ] break libreoffice-l10n-ve-6.0.0.1-1.1.noarch by ignoring some of its dependencies



    nothing provides libreoffice = 6.0.0.1 needed by libreoffice-l10n-xh-6.0.0.1-1.1.noarch

    [ ] break libreoffice-l10n-xh-6.0.0.1-1.1.noarch by ignoring some of its dependencies

    [ ] do not install libreoffice-l10n-xh-6.0.0.1-1.1.noarch



    nothing provides libreoffice = 6.0.0.1 needed by libreoffice-l10n-zh_CN-6.0.0.1-1.1.noarch

    [ ] do not install libreoffice-l10n-zh_CN-6.0.0.1-1.1.noarch

    [ ] break libreoffice-l10n-zh_CN-6.0.0.1-1.1.noarch by ignoring some of its dependencies



    nothing provides libreoffice = 6.0.0.1 needed by libreoffice-l10n-zh_TW-6.0.0.1-1.1.noarch

    [ ] do not install libreoffice-l10n-zh_TW-6.0.0.1-1.1.noarch

    [ ] break libreoffice-l10n-zh_TW-6.0.0.1-1.1.noarch by ignoring some of its dependencies



    nothing provides libreoffice = 6.0.0.1 needed by libreoffice-l10n-zu-6.0.0.1-1.1.noarch

    [ ] do not install libreoffice-l10n-zu-6.0.0.1-1.1.noarch

    [ ] break libreoffice-l10n-zu-6.0.0.1-1.1.noarch by ignoring some of its dependencies



    nothing provides libicuuc.so.59.1 needed by libreoffice-writer-5.4.3.2-1.3.i586

    [ ] do not install libreoffice-writer-extensions-5.4.3.2-1.3.i586

    [ ] break libreoffice-writer-5.4.3.2-1.3.i586 by ignoring some of its dependencies


    installed libreoffice-icon-themes-6.0.0.1-1.1.noarch obsoletes libreoffice-icon-theme-breeze < 6.0.0.1 provided by libreoffice-icon-theme-breeze-5.4.3.2-1.3.noarch

    [ ] Following actions will be done:
    do not install libreoffice-icon-theme-breeze-5.4.3.2-1.3.noarch
    do not install libreoffice-icon-theme-galaxy-5.4.3.2-1.3.noarch
    do not install libreoffice-icon-theme-hicontrast-5.4.3.2-1.3.noarch
    do not install libreoffice-icon-theme-sifr-5.4.3.2-1.3.noarch
    do not install libreoffice-icon-theme-tango-5.4.3.2-1.3.noarch
    [ ] deinstallation of libreoffice-icon-themes-6.0.0.1-1.1.noarch




    #### YaST2 conflicts list END ###

  2. #2

    Default Re: Dependency errors reinstalling libreoffice suite after running zypper dup

    Well, for some reason LibreOffice 6 (even though it built successfully) is not in the repos for 32bit yet, the current packages are outdated and require other libraries ( libicuuc.so.59.1) that no longer exist.

    I suppose that will be fixed with the next snapshot.
    If you can't wait, you could try to temporary add the LibreOffice:Factory repo and install libreoffice 6.0.0.1 from there.
    https://download.opensuse.org/reposi...SE_Tumbleweed/

    You should probably consider switching to 64bit though, especially if your CPU supports it (most, if not all, that were manufactured in the last 10 years should).
    Tumbleweed 32bit is basically untested, and some things cannot even be built anymore.

  3. #3

    Cool Re: Dependency errors reinstalling libreoffice suite after running zypper dup

    Quote Originally Posted by wolfi323 View Post
    Well, for some reason LibreOffice 6 (even though it built successfully) is not in the repos for 32bit yet, the current packages are outdated and require other libraries ( libicuuc.so.59.1) that no longer exist.

    I suppose that will be fixed with the next snapshot.
    If you can't wait, you could try to temporary add the LibreOffice:Factory repo and install libreoffice 6.0.0.1 from there.
    https://download.opensuse.org/reposi...SE_Tumbleweed/

    You should probably consider switching to 64bit though, especially if your CPU supports it (most, if not all, that were manufactured in the last 10 years should).
    Tumbleweed 32bit is basically untested, and some things cannot even be built anymore.
    Thanks.I added the LibreOffice:Factory repo and installed libreoffice.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •