Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: Special characters not displaying correctly - Serbian Cyrillic and Firefox

  1. #1
    Join Date
    Nov 2013
    Location
    Ljubljana, Slovenia
    Posts
    465

    Default Special characters not displaying correctly - Serbian Cyrillic and Firefox

    Hi,

    I have a problem:

    There are a couple of special characters in Serbian Cyrillic, that do not display correctly in Firefox on openSUSE. Anytime characters such as: ђ, љ, њ etc. appear, theres a т instead of them.

    However, as far as I can see, this problem only occurs on Facebook and Twitter. Other Serbian sites display these characters correctly. I have translations-other installed, even tried playing around with character encoding in Firefox, but that did not work. Any idea where I could look next?

    Thanks!
    Running openSUSE Leap 42.3 + KDE

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,394

    Default Re: Special characters not displaying correctly - Serbian Cyrillic and Firefox

    I see all the character in your post above correct. That is they are all different from the T shaped one you post there as last.

    Thus I assume they are correct encoded in UTF-8 and all the pages of the forums here are charset=UTF-8.

    Did you check on those pages where they are wrong what those pages advertize as their character encoding? In Firefox: Extra > Page Info (or Ctrl-I)?
    Henk van Velden

  3. #3

    Default Re: Special characters not displaying correctly - Serbian Cyrillic and Firefox

    Quote Originally Posted by holden87 View Post
    Hi,

    I have a problem:

    There are a couple of special characters in Serbian Cyrillic, that do not display correctly in Firefox on openSUSE. Anytime characters such as: ђ, љ, њ etc. appear, theres a т instead of them.

    However, as far as I can see, this problem only occurs on Facebook and Twitter. Other Serbian sites display these characters correctly. I have translations-other installed, even tried playing around with character encoding in Firefox, but that did not work. Any idea where I could look next?

    Thanks!
    Have you solved this problem in the end? I have been having the same issue and it's going on my nerves a bit. I could switch and use Firefox for work and Chrome for personal stuff instead of the other way around, but that just seems wrong after years of having this setup.

    Quote Originally Posted by hcvv View Post
    I see all the character in your post above correct. That is they are all different from the T shaped one you post there as last.

    Thus I assume they are correct encoded in UTF-8 and all the pages of the forums here are charset=UTF-8.

    Did you check on those pages where they are wrong what those pages advertize as their character encoding? In Firefox: Extra > Page Info (or Ctrl-I)?
    Couple of offending pages that I checked list UTF-8.

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,394

    Default Re: Special characters not displaying correctly - Serbian Cyrillic and Firefox

    Quote Originally Posted by wavelike View Post
    Have you solved this problem in the end?
    He seems to be one of those that ask for help and then, after people take the trouble to spend time on their problem, never answer back
    Quote Originally Posted by wavelike View Post
    I have been having the same issue and it's going on my nerves a bit. I could switch and use Firefox for work and Chrome for personal stuff instead of the other way around, but that just seems wrong after years of having this setup.
    As we here do not know what the consequences are of you being "for work" or "for personal stuff", you better explain in technical terms what works on which browser.
    So, is it OK on Firefox (as it is here on my system) and wrong on Chrome (which I do not use, thus I can not follow you there), or the other way around?

    Quote Originally Posted by wavelike View Post
    Couple of offending pages that I checked list UTF-8.
    That would point then to the browser, like the fact that one browser can do it and the other not.
    Henk van Velden

  5. #5

    Default Re: Special characters not displaying correctly - Serbian Cyrillic and Firefox

    - I use Chrome for work. Chrome does not have any problems displaying Serbian Cyrillic, it works perfectly. On top of that, my work does not involve Serbian language and I never have the need to visit the offending sites and pages. Everything's perfect here.
    - However, Firefox is always open on the side, and is used exclusively for personal, non-work, activities. These activities sometimes take me to Serbian websites, where certain letters (see OP post) are not displayed correctly. Firefox DOES have this problem.

    So, I could solve this problem easily, by using Chrome for fun and Firefox for work, as in that case I would never see this issue. It is a simple solution that would require about five minutes of work. But, I would have to change a habit, you know, and I would rather solve the problem, if possible. Which is not really a problem, more of an annoyance.

    So, yes, it's a browser-related problem.

  6. #6

    Default Re: Special characters not displaying correctly - Serbian Cyrillic and Firefox

    Hi wavelike,

    Quote Originally Posted by wavelike View Post
    So, yes, it's a browser-related problem.
    In Firefox, did you try to uncheck "Allow pages to choose their own fonts, instead of your selections above"?

    (Preferences > General > Fonts & Colors > Advanced)

    Does that have any effect?

    Also, could you please add a Twitter-url that uses those characters and shows them wrongly?

    Kind regards,

    Leen

  7. #7
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: Special characters not displaying correctly - Serbian Cyrillic and Firefox

    I'm on LEAP 42.3 and I can both read and write cyrilic characters for example љњпшѓќ
    afaik the default Firefox font (Roboto) has full cyrilic support
    did you maybe change the default font used by Firefox, do you have the Roboto font installed ( it's packaged in google-roboto-fonts)
    Code:
    zypper se -si google-roboto-fonts
    if you don't have it installed install it
    Code:
    zypper in google-roboto-fonts
    I am using Firefox 57 if you're on 52 esr the default font might be different you can try installing google-roboto-fonts and setting roboto as the default font in Firefox from
    hamburger bar->Preferences->Language and Appearance->Fonts and Colors

  8. #8

    Default Re: Special characters not displaying correctly - Serbian Cyrillic and Firefox

    Quote Originally Posted by leen_meyer View Post
    Hi wavelike,



    In Firefox, did you try to uncheck "Allow pages to choose their own fonts, instead of your selections above"?

    (Preferences > General > Fonts & Colors > Advanced)

    Does that have any effect?
    Hi leen_meyer,

    That, actually, did the trick. I checked only one of the problematic pages, but that one works fine now.

    On the other hand, I am not sure if forcing all pages to use the fonts specified in my browser is something I would like to do all the time. But, this is a solution, even if temporary. Thanks a lot!
    Quote Originally Posted by leen_meyer View Post
    Also, could you please add a Twitter-url that uses those characters and shows them wrongly?

    Kind regards,

    Leen
    I don't have Twitter - it's OP who mentioned Twitter and Facebook. This is a bicycle forum that I visit regularly, and some people there prefer Cyrillic over Latin (Serbian language can use either), which is when problems arise. Here's the link to a post that shows this issue
    http://www.2bike.rs/forum/topic/10780-gračišće-i-još-ponešto/?p=228177
    The first sentence is
    "Никад нема планова док се не зна да ли ће бити буџета".
    The bold letter is my formatting, but it shows you the first problematic character. With that font option in Firefox checked, the sentence looks like this:
    "Никад нема планова док се не зна да ли те бити буџета". (I had to change the character as the incorrectly displayed character is corrected when copy/pasted into this editor)
    Then, second sentence, after smiley, there is the word "жеља" which is incorrectly displayed as "жела"... and so on.

  9. #9

    Default Re: Special characters not displaying correctly - Serbian Cyrillic and Firefox

    Quote Originally Posted by I_A View Post
    I'm on LEAP 42.3 and I can both read and write cyrilic characters for example љњпшѓќ
    afaik the default Firefox font (Roboto) has full cyrilic support
    did you maybe change the default font used by Firefox, do you have the Roboto font installed ( it's packaged in google-roboto-fonts)
    Code:
    zypper se -si google-roboto-fonts
    if you don't have it installed install it
    Code:
    zypper in google-roboto-fonts
    I am using Firefox 57 if you're on 52 esr the default font might be different you can try installing google-roboto-fonts and setting roboto as the default font in Firefox from
    hamburger bar->Preferences->Language and Appearance->Fonts and Colors
    Hi I_A,

    I do have google-roboto-fonts installed. I am running 42.3 Leap and 52.5.3 Firefox. Thanks

  10. #10

    Default Re: Special characters not displaying correctly - Serbian Cyrillic and Firefox

    I forgot to add that I did not make any changes in Firefox font settings.

    Sorry I couldn't edit my previous post to add this, it was too late.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •