Results 1 to 3 of 3

Thread: getbinaries: missing packages error for CentOS 6

  1. #1
    Join Date
    Nov 2015
    Location
    Townsville, Australia
    Posts
    270

    Default getbinaries: missing packages error for CentOS 6

    Hi,

    Today I've noticed (and yes, if you're wondering, this is not usually the case, usually the build goes without a hitch) that the CentOS 6 build target for my vim package has been returning the error (and hence getting the build state of 'failed'):

    Code:
    getbinaries: missing packages: acl attr bash coreutils diffutils filesystem glibc grep libacl libattr libgcc m4 ncurses pam file-libs db4 readline rpm tar zlib ncurses-libs libcap rpm-libs pcre info libselinux sqlite lua elfutils-libelf findutils neon openssl krb5-libs e2fsprogs-libs expat bzip2-libs libstdc++ setup libsepol perl policycoreutils nss nss-util nspr xz-libs nss-softokn-freebl nss-softokn shadow-utils util-linux-ng perl-libs device-mapper libblkid libuuid python-devel ncurses-devel gettext perl-devel libacl-devel autoconf file libselinux-devel ruby-devel ruby lua-devel desktop-file-utils gtk2-devel libSM-devel libXt-devel libXpm-devel automake binutils bzip2 gcc gdbm libtool rpm-build centos-release redhat-rpm-config gcc-c++ python-libs python pkgconfig libgomp perl-ExtUtils-MakeMaker db4-devel gdbm-devel perl-ExtUtils-ParseXS perl-ExtUtils-Embed openldap nfs-utils-lib libattr-devel libsepol-devel ruby-libs glib2 libX11 freetype fontconfig pango cairo gdk-pixbuf2 gtk2 atk libXext libXrender libXrandr libXi libXfixes libXinerama libXcursor libXdamage libX11-devel libXcomposite glib2-devel libpng-devel cairo-devel gdk-pixbuf2-devel libXext-devel pango-devel libXrandr-devel libXinerama-devel atk-devel libXcomposite-devel libXcursor-devel libXfixes-devel libXi-devel libSM xorg-x11-proto-devel libICE-devel libXt libXpm cloog-ppl glibc-common basesystem perl-version perl-Module-Pluggable perl-Pod-Simple curl db4-utils xz xz-lzma-compat elfutils gmp mpfr libstdc++-devel libffi ncurses-base libcom_err perl-Test-Harness glibc-headers db4-cxx perl-Test-Simple cyrus-sasl-lib nss-tools libgssglue nfs-utils compat-readline5 shared-mime-info gamin libxcb libX11-common libXft libthai libpng pixman libjpeg-turbo libtiff jasper-libs cups-libs hicolor-icon-theme libxcb-devel libXrender-devel fontconfig-devel freetype-devel pixman-devel libXft-devel libICE ppl tzdata perl-Pod-Escapes coreutils-libs libcurl libidn libssh2 elfutils-libs ca-certificates keyutils-libs audit-libs cracklib-dicts kernel-headers tcp_wrappers-libs libevent libtirpc rpcbind keyutils libxml2 libXau avahi-libs gnutls libXau-devel p11-kit p11-kit-trust nss-sysinit dbus-libs libgcrypt libtasn1 libgpg-error expat-devel bind-libs bind-utils bison cpio cpp cracklib cvs e2fsprogs flex gawk gettext-devel glibc-devel gpm groff gzip less make man module-init-tools net-tools patch procps psmisc rcs strace texinfo unzip zlib-devel initscripts bzip2-devel libproxy pakchois dbus-glib libsemanage checkpolicy libselinux-utils libss gettext-libs gpm-libs udev libutempter sysvinit-tools upstart libproxy-bin libproxy-python chkconfig ustr libusb hwdata MAKEDEV libnih
    for 32-bit and:

    Code:
    getbinaries: missing packages: acl attr bash coreutils diffutils filesystem glibc grep libacl libattr libgcc m4 ncurses pam file-libs db4 readline rpm tar zlib ncurses-libs libcap rpm-libs pcre info libselinux sqlite lua elfutils-libelf findutils neon openssl krb5-libs e2fsprogs-libs expat bzip2-libs libstdc++ setup libsepol perl policycoreutils nss nss-util nspr xz-libs nss-softokn-freebl nss-softokn shadow-utils util-linux-ng perl-libs device-mapper libblkid libuuid python-devel ncurses-devel gettext perl-devel libacl-devel autoconf file libselinux-devel ruby-devel ruby lua-devel desktop-file-utils gtk2-devel libSM-devel libXt-devel libXpm-devel automake binutils bzip2 gcc gdbm libtool rpm-build centos-release redhat-rpm-config gcc-c++ python-libs python pkgconfig libgomp perl-ExtUtils-MakeMaker db4-devel gdbm-devel perl-ExtUtils-ParseXS perl-ExtUtils-Embed openldap nfs-utils-lib libattr-devel libsepol-devel ruby-libs glib2 libX11 freetype fontconfig pango cairo gdk-pixbuf2 gtk2 atk libXext libXrender libXrandr libXi libX11-devel libXfixes libXinerama glib2-devel libXcursor libpng-devel cairo-devel gdk-pixbuf2-devel libXext-devel libXdamage pango-devel libXcomposite libXrandr-devel libXinerama-devel atk-devel libXcomposite-devel libXcursor-devel libXfixes-devel libXi-devel libSM xorg-x11-proto-devel libICE-devel libXt libXpm cloog-ppl glibc-common basesystem perl-version perl-Module-Pluggable perl-Pod-Simple curl db4-utils xz xz-lzma-compat elfutils gmp mpfr libstdc++-devel libffi ncurses-base libcom_err glibc-headers perl-Test-Harness db4-cxx perl-Test-Simple cyrus-sasl-lib nss-tools libgssglue nfs-utils compat-readline5 shared-mime-info gamin libxcb libX11-common libXft libthai libpng pixman libjpeg-turbo libtiff jasper-libs cups-libs hicolor-icon-theme libxcb-devel libXrender-devel fontconfig-devel freetype-devel pixman-devel libXft-devel libICE ppl tzdata perl-Pod-Escapes coreutils-libs libcurl libidn libssh2 elfutils-libs ca-certificates keyutils-libs audit-libs cracklib-dicts kernel-headers tcp_wrappers-libs libevent libtirpc rpcbind keyutils libxml2 libXau avahi-libs gnutls libXau-devel p11-kit p11-kit-trust nss-sysinit dbus-libs libgcrypt libtasn1 libgpg-error expat-devel bind-libs bind-utils bison cpio cpp cracklib cvs e2fsprogs flex gawk gettext-devel glibc-devel gpm groff gzip less make man module-init-tools net-tools patch procps psmisc rcs strace texinfo unzip zlib-devel initscripts bzip2-devel libproxy pakchois dbus-glib libsemanage checkpolicy libselinux-utils libss gettext-libs gpm-libs udev libutempter sysvinit-tools upstart libproxy-bin libproxy-python chkconfig ustr libusb hwdata MAKEDEV libnih
    for 64-bit. All other build targets are working perfectly fine for my vim package and none other of my packages are getting this bizarre error. Is this likely a temporary problem due to some fiddling by the OBS developers with the CentOS 6 repositories used by the OBS, or is it something I'm going to have to fix myself? I'm guessing it is the former, but I'd like a little reassurance.

    Thanks for your time,
    Brenton
    Brenton Horne: Linux enthusiast and writer of ​The Hornery.
    Five favourite distros: Arch Linux, Fedora, openSUSE Tumbleweed, Sabayon Linux and Ubuntu.

  2. #2
    Join Date
    Nov 2015
    Location
    Townsville, Australia
    Posts
    270

    Default Re: getbinaries: missing packages error for CentOS 6

    Adrian Schröter (adrianS on #opensuse-buildservice IRC) fixed this error for me. It seems that the OBS developers recently decided to switch the repos for the OBS (the ones used for satisfying build deps) from ones they kept to the upstream ones used by the actual distros the OBS packages for. Unfortunately CentOS 6 didn't have signed repos (which lead to this error), so for CentOS 6 they had to revert back.
    Brenton Horne: Linux enthusiast and writer of ​The Hornery.
    Five favourite distros: Arch Linux, Fedora, openSUSE Tumbleweed, Sabayon Linux and Ubuntu.

  3. #3

    Default Re: getbinaries: missing packages error for CentOS 6

    I have now this exact same problem. Cent6 builds worked a few weeks ago but now I get the same error message as in original post.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •