Results 1 to 6 of 6

Thread: Missing libboost in tumbleweed repository

  1. #1

    Default Missing libboost in tumbleweed repository

    I want to install RStudio, but it needs libboost_date-time. There is not tumbleweed version of this library, so I don't know how to install RStudio

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,232
    Blog Entries
    15

    Default Re: Missing libboost in tumbleweed repository

    Quote Originally Posted by amber102 View Post
    I want to install RStudio, but it needs libboost_date-time. There is not tumbleweed version of this library, so I don't know how to install RStudio
    Hi
    See https://lists.opensuse.org/opensuse-.../msg00024.html

    You need libboost_date_time1_63_0-devel.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3

    Default Re: Missing libboost in tumbleweed repository

    hallo,
    and thanks for answer but it did not solve the problem

    I found libboost_date_time1_63_0-devel and libboost_date_time1_63_0 and installed it. but yast still blames missing libboost_date_time.so.1.54.0

    (sorry for german localisation of yast output):
    #### YaST2 conflicts list - generated 2017-02-16 22:49:38 ####


    libboost_date_time.so.1.54.0 benötigt von rstudio-0.98.501-1.62.i586 wird nirgends zur Verfügung gestellt


    [ ] rstudio-0.98.501-1.62.i586 nicht installieren


    [ ] rstudio-0.98.501-1.62.i586 durch Ignorieren einiger Abhängigkeiten brechen








    #### YaST2 conflicts list END ###


    hm...?

  4. #4

    Default AW: Missing libboost in tumbleweed repository

    Your package was built against an older version of boost, so it will not work if that library is no longer present.

    You should go to openSUSE's bugzilla and write a bug report about this.

    AK

  5. #5

    Default AW: Missing libboost in tumbleweed repository

    Is this "rstudio" package from the "devel:languages:R:released" Repo?

    If so, forget it, this package hasn't been successfully built for more than two years, no wonder why it links against such old libs.

    https://build.opensuse.org/package/s...ackage=rstudio

    https://build.opensuse.org/package/b...USE_Tumbleweed

    That's one of the big disadvantages of OBS, old **** no longer building is not removed from repos automatically.

    AK

  6. #6

    Default Re: AW: Missing libboost in tumbleweed repository

    Quote Originally Posted by Akoellh View Post
    That's one of the big disadvantages of OBS, old **** no longer building is not removed from repos automatically.

    AK
    I hope there is a way to bring RStudio into the standard repositories, both Leap and Tumbleweed.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •