Results 1 to 6 of 6

Thread: dolphin: error while loading shared libraries: libKF5BalooWidgets.so.5

  1. #1

    Default dolphin: error while loading shared libraries: libKF5BalooWidgets.so.5

    on my Laptop=Dell latitude E6510, RAM=8Gb, GPU=GT218 NVS 3100M, CPU=i7 Q 720 @ 1.60GHz running opensuse leap 42.2, plasma 5.9.1, KDE frameworks 5.30.0, KDE applications 16.12.1, Kernel 4.4.46-11-default, nvidia drivers,
    when I launch dolphin it doesn't works, from the konsole it gives this error:
    dolphin: error while loading shared libraries: libKF5BalooWidgets.so.5: cannot open shared object file: No such file or directory
    ...well, maybe that after the last upgrade after the disappearing of KDE:Applications repo I made some mess....
    I disabled KDE:Applications and about KDE I have this repos:
    Code:
    opensuse.org/repositories/home:/wolfi323:/branches:/KDE:/Frameworks5_(beclock)
    opensuse.org/repositories/KDE:/Extra
    openSUSE:Leap:42.2:Update
    opensuse.org/repositories/KDE:/Frameworks5
    opensuse.org/repositories/KDE:/Qt5
    download.opensuse.org-non-oss
    download.opensuse.org-oss
    how can I get back a working dolphin??

  2. #2

    Default Re: dolphin: error while loading shared libraries: libKF5BalooWidgets.so.5

    Remove the home: repository and add this one instead: http://download.opensuse.org/reposit...USE_Leap_42.2/
    Then, run
    Code:
    zypper dup

  3. #3

    Default Re: dolphin: error while loading shared libraries: libKF5BalooWidgets.so.5

    Quote Originally Posted by backflip View Post
    Remove the home: repository and add this one instead: http://download.opensuse.org/reposit...USE_Leap_42.2/
    Then, run
    Code:
    zypper dup
    Or keep it and run "zypper dup --from xxx" (replace xxx with the name or number of this repo on your system).

    You likely installed dolphin from the standard repos, but that won't work with my Frameworks packages because they install the files to /opt/kf5/ (where they are not found normally).

    And do *not* add KDE:Applications, that's pointless if you use my repo (all packages from there are available in my repo anyway).

    There is another problem currently though: KDE:Frameworks5 is only partially published and currently contains a mixture of KF 5.30 and 5.31.
    This may cause conflicts.
    Feel free to ask for help if you encounter one.

  4. #4

    Default Re: dolphin: error while loading shared libraries: libKF5BalooWidgets.so.5

    Quote Originally Posted by wolfi323 View Post
    Or keep it and run "zypper dup --from xxx" (replace xxx with the name or number of this repo on your system).

    You likely installed dolphin from the standard repos, but that won't work with my Frameworks packages because they install the files to /opt/kf5/ (where they are not found normally).

    And do *not* add KDE:Applications, that's pointless if you use my repo (all packages from there are available in my repo anyway).

    There is another problem currently though: KDE:Frameworks5 is only partially published and currently contains a mixture of KF 5.30 and 5.31.
    This may cause conflicts.
    Feel free to ask for help if you encounter one.
    manythanks wolfi :-), KDE:Applications is currently disabled, I switched all packages to KDE:Frameworks5 but it doesn't works, the error reamain the same:
    I noted that baloo5-widgets (that yast say that it is the package that provide libKF5BalooWidgets.so.5) comes only from home:wolfi323:branches:KDE:Frameworks5 / openSUSE_Leap_42.2 version 16.12.2-62.1, or from the main repository download.opensuse.org-oss version 16.8.2-1.1
    but not from KDE:Frameworks5 / openSUSE_Leap_42.2

    the other baloo5-something* has also a version that comes from KDE:Frameworks5 / openSUSE_Leap_42.2 (so it seems that there isn't the version that do not install in /opt/kf5)

    dolphin comes from KDE:Applications / openSUSE_Leap_42.2 version 16.12.1-76.3 (is there the possibility to install it from download.opensuse.org-oss version 16.8.2-3.1 and from home:wolfi323:branches:KDE:Frameworks5 / openSUSE_Leap_42.2 version 15.4.3-16.95 ...why a so old version??...)
    (there is another that could be dolphin/kf5, libdolphinvcs5 - KDE File Manager that seems to have a better version from home:wolfi323:branches:KDE:Frameworks5 / openSUSE_Leap_42.2 version 16.12.2-170.2 )
    ...what I have to do to have a working dolphin?

  5. #5

    Default Re: dolphin: error while loading shared libraries: libKF5BalooWidgets.so.5

    Quote Originally Posted by pier_andreit View Post
    manythanks wolfi :-), KDE:Applications is currently disabled, I switched all packages to KDE:Frameworks5 but it doesn't works, the error reamain the same:
    You should switch all packages to *my* repo if you want to use my repo.

    I noted that baloo5-widgets (that yast say that it is the package that provide libKF5BalooWidgets.so.5) comes only from home:wolfi323:branches:KDE:Frameworks5 / openSUSE_Leap_42.2 version 16.12.2-62.1, or from the main repository download.opensuse.org-oss version 16.8.2-1.1
    but not from KDE:Frameworks5 / openSUSE_Leap_42.2
    Because it is part of KDE Applications.

    the other baloo5-something* has also a version that comes from KDE:Frameworks5 / openSUSE_Leap_42.2 (so it seems that there isn't the version that do not install in /opt/kf5)
    Your error message is about baloowidgets.
    And as I wrote, my version won't work with the standard dolphin. You need my dolphin5.

    dolphin comes from KDE:Applications / openSUSE_Leap_42.2 version 16.12.1-76.3 (is there the possibility to install it from download.opensuse.org-oss version 16.8.2-3.1 and from home:wolfi323:branches:KDE:Frameworks5 / openSUSE_Leap_42.2 version 15.4.3-16.95 ...why a so old version??...)
    Because it is the KDE4 version.
    The KF5 applications have a '5' in the package name to differentiate them from their KDE4 counterpart (if the package names were the same, it wouldn't be possible to install both at the same time, and the KF5 version would update/replace the KDE4 version).

    I thought you were using my repo for quite some time already?

    (there is another that could be dolphin/kf5, libdolphinvcs5 - KDE File Manager that seems to have a better version from home:wolfi323:branches:KDE:Frameworks5 / openSUSE_Leap_42.2 version 16.12.2-170.2 )
    ...what I have to do to have a working dolphin?
    Install dolphin5 from my repo.
    Or remove my repo completely and switch back to the standard versions.
    Last edited by wolfi323; 17-Feb-2017 at 04:54.

  6. #6

    Default Re: dolphin: error while loading shared libraries: libKF5BalooWidgets.so.5

    Quote Originally Posted by wolfi323 View Post
    You should switch all packages to *my* repo if you want to use my repo.
    Because it is part of KDE Applications.
    Your error message is about baloowidgets.
    And as I wrote, my version won't work with the standard dolphin. You need my dolphin5.
    Because it is the KDE4 version.
    The KF5 applications have a '5' in the package name to differentiate them from their KDE4 counterpart (if the package names were the same, it wouldn't be possible to install both at the same time, and the KF5 version would update/replace the KDE4 version).
    ok, I wasn't able to see dolphin5

    Quote Originally Posted by wolfi323 View Post
    I thought you were using my repo for quite some time already?
    yes, it is very good and useful, but from use to understand the leap is big , now I understood a little bit more, manythanks

    Quote Originally Posted by wolfi323 View Post
    Install dolphin5 from my repo.
    Or remove my repo completely and switch back to the standard versions.
    I installed dolphin5 from your repo and now everything is working, manythanks again

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •