Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Frameworks 5.30 and Plasma 5.9

  1. #1

    Default Frameworks 5.30 and Plasma 5.9

    Hello,

    I'd like to know if someone has already installed the latest KDE/KF on Leap 42.2 without any errors. When I try to upgrade, many packages must be removed.

    Thanks for feedback,
    Jérôme

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: Frameworks 5.30 and Plasma 5.9

    OK here
    You know about the repo changes? If you were using kde apps, you now want
    http://download.opensuse.org/reposit...USE_Leap_42.2/
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: Frameworks 5.30 and Plasma 5.9

    I have this repo but when I want to upgrade in Yast, I have too many changes from the previous installed KDE with many packages to remove or to be marked obsolete or some dependencies cant be provided.

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: Frameworks 5.30 and Plasma 5.9

    Use the expert mode to save the deps list to a file and post here
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5

    Default Re: Frameworks 5.30 and Plasma 5.9

    http://s000.tinyupload.com/?file_id=...55523331145061

    Here is the file; many errors inside.

  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: Frameworks 5.30 and Plasma 5.9

    Basically you need to allow the deinstallation of a whole list of stuff
    not limited to but including

    Code:
    désinstallation de libkf5kdegames6-16.08.2-1.1.x86_64désinstallation de marble-16.08.2-1.1.x86_64
    désinstallation de marble-kde-16.08.2-1.1.x86_64
    désinstallation de spectacle-16.08.2-1.1.x86_64
    désinstallation de yakuake-3.0.2-2.11.x86_64
    désinstallation de filelight-16.08.2-1.1.x86_64
    installation d'une version moins récente de k3b-2.9.90+git20161017.0443-7.45.x86_64 vers k3b-2.0.3-67.1.x86_64
    installer k3b-2.0.3-67.1.x86_64 (avec changement de fournisseur)
      http://packman.links2linux.de  -->  obs://build.opensuse.org/KDE:Extra
    désinstallation de kdenetwork4-filesharing-16.08.2-1.1.x86_64
    désinstallation de kdevplatform-5.0.1-1.1.x86_64
    désinstallation de konsole-part-16.08.2-6.1.x86_64
    désinstallation de libKF5AkonadiSearch-16.08.2-1.1.x86_64
    désinstallation de libKF5KMahjongglib5-16.08.2-1.1.x86_64
    désinstallation de kcron-16.08.2-1.1.x86_64
    désinstallation de libktorrent6-2.0.1-1.1.x86_64
    désinstallation de skanlite-1.1git-1.5.x86_64
    désinstallation de kdeconnect-kde-1.0.1-1.4.x86_64
    désinstallation de kwalletmanager5-16.08.2-3.1.x86_64
    désinstallation de kshutdown-4.0-3.1.x86_64
    désinstallation de showfoto-5.2.0-1.1.x86_64
    désinstallation de libkomparediff2-5-16.08.2-1.1.x86_64
    désinstallation de libKF5Kipi31_0_0-16.08.2-1.1.x86_64
    désinstallation de libKF5AkonadiWidgets5-16.08.2-2.1.x86_64
    désinstallation de kio_kamera-16.08.2-1.1.x86_64
    désinstallation de kcolorchooser-16.08.2-1.1.x86_64
    désinstallation de libKF5Sane5-16.08.2-1.1.x86_64
    désinstallation de libKF5CalendarCore5-16.08.2-1.1.x86_64
    désinstallation de kaccounts-integration-16.08.2-1.1.x86_64
    désinstallation de akonadi-search-16.08.2-1.1.x86_64
    désinstallation de diskmonitor-lang-0.3.1-3.1.noarch
    désinstallation de kdedésinstallation de libKF5ConfigGui5-5.26.0-1.2.x86_64
    désinstallation de akonadi-contact-16.08.2-1.1.x86_64
    désinstallation de ark-16.08.2-3.1.x86_64
    désinstallation de baloo5-widgets-16.08.2-1.1.x86_64
    désinstallation de diskmonitor-0.3.1-3.1.x86_64
    désinstallation de dolphin-16.08.2-3.1.x86_64
    désinstallation de dolphin-part-16.08.2-3.1.x86_64
    désinstallation de dragonplayer-16.08.2-1.1.x86_64
    désinstallation de kate-16.08.2-1.1.x86_64
    désinstallation de kate-plugins-16.08.2-1.1.x86_64
    désinstallation de kcalc-16.08.2-1.1.x86_64
    désinstallation de kcharselect-16.08.2-1.1.x86_64
    désinstallation de kde-print-manager-16.08.2-1.1.x86_64
    désinstallation de kdevelop5-5.0.1-1.1.x86_64
    désinstallation de kdf-16.08.2-1.1.x86_64
    désinstallation de kio-extras5-16.08.2-1.1.x86_64
    désinstallation de kipi-plugins-5.2.0-1.1.x86_64
    désinstallation de kmahjongg-16.08.2-1.1.x86_64
    désinstallation de kmines-16.08.2-1.1.x86_64
    désinstallation de kmix-16.08.2-1.1.x86_64
    désinstallation de kompare-16.08.2-1.1.x86_64
    désinstallation de konsole-16.08.2-6.1.x86_64
    désinstallation de konversation-1.6.2-1.17.x86_64
    désinstallation de kpat-16.08.2-1.1.x86_64
    désinstallation de krdc-16.08.2-1.1.x86_64
    désinstallation de krfb-16.08.2-1.1.x86_64
    désinstallation de kruler-16.08.2-1.1.x86_64
    désinstallation de kstars-16.08.2-1.1.x86_64
    désinstallation de ksystemlog-16.08.2-1.1.x86_64
    désinstallation de ktorrent-5.0.1-3.1.x86_64
    désinstallation de kwrite-16.08.2-1.1.x86_64
    désinstallation de libKF5AkonadiAgentBase5-16.08.2-2.1.x86_64
    désinstallation de libKF5AkonadiContact5-16.08.2-1.1.x86_64
    désinstallation de libKF5AkonadiMime5-16.08.2-1.1.x86_64
    désinstallation de libdigikamcore5-5.2.0-1.1.x86_64
    désinstallation de libkcddb16-16.07.0-5.2.x86_64
    désinstallation de libkdevplatform10-5.0.1-1.1.x86_64
    désinstallation de libkevelop5-lang-5.0.1-1.1.noarch
    désinstallation de digikam-5.2.0-1.1.x86_64
    désinstallation de kipi-plugins-lang-5.2.0-1.1.noarch
    désinstallation de konversation-lang-1.6.2-1.17.noarch
    désinstallation de ktorrent-lang-5.0.1-3.1.noarch
    désinstallation de marble-doc-16.08.2-1.1.noarch
    désinstallation de marble-data-16.08.2-1.1.noarch
    désinstallation de yakuake-lang-3.0.2-2.11.noarch
    installation d'une version moins récente de k3b-lang-2.9.90+git20161017.0443-7.45.noarch vers k3b-lang-2.0.3-67.1.noarch
    installer k3b-lang-2.0.3-67.1.noarch (avec changement de fournisseur)
      http://packman.links2linux.de  -->  obs://build.opensuse.org/KDE:Extra
    désinstallation de kdevplatform-lang-5.0.1-1.1.noarch
    désinstallation de libktorrent6-lang-2.0.1-1.1.noarch
    désinstallation de skanlite-doc-1.1git-1.5.x86_64
    désinstallation de kdeconnect-kde-lang-1.0.1-1.4.noarch
    désinstallation de kwalletmanager-15.04.3-9.1.x86_64
    désinstallation de kio_iso-2.5.0-6.1.x86_64
    désinstallation de libKF5KGeoMap10_0_0-16.08.2-2.1.x86_64
    désinstallation de kaccounts-providers-16.08.2-1.1.x86_64
    désinstallation de qupzilla-kwallet-2.0.1-1.1.x86_64
    désinstallation de libktpaccountskcminternal9-16.08.2-1.1.x86_64
    désinstallation de libKF5AkonadiCore5-16.08.2-2.1.x86_64
    désinstallation de digikam-lang-5.2.0-1.1.noarch
    désinstallation de libkgeomap-16.08.2-2.1.x86_64
    désinstallation de ktp-accounts-kcm-16.08.2-1.1.x86_64
    désinstallation de libKF5AkonadiXml5-16.08.2-2.1.x86_64
    désinstallation de NetworkManager-pptp-1.0.8-1.2.x86_64
    désinstallation de NetworkManager-openconnect-1.0.2-4.4.x86_64
    désinstallation de NetworkManager-vpnc-lang-1.0.8-4.1.noarch
    désinstallation de NetworkManager-pptp-lang-1.0.8-1.2.noarch
    désinstallation de NetworkManager-openconnect-lang-1.0.2-4.4.noarch
    These will all be replaced by the newer versions
    You may later wish to reapply the packman switch as some packages such as k3b will get toggled to the kde repo
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  7. #7

    Default Re: Frameworks 5.30 and Plasma 5.9

    I guess I should do it with zypper dup in init 3 runlevel?

  8. #8

    Default Re: Frameworks 5.30 and Plasma 5.9

    Quote Originally Posted by jnowe View Post
    I guess I should do it with zypper dup in init 3 runlevel?
    Your problem is that KDE:Frameworks5 also requires KDE:Qt5 (and Qt 5.8.0 from there), but you have additional stuff installed (e.g. LXQT) that *requires* Qt 5.6.1 from the standard repos.
    You either need to uninstall that, or stick to the standard Qt and KDE packages.

    You could use KDE:Frameworks5:LTS instead to get the latest Plasma 5.8.x LTS that is built against the standard Qt5 5.6.1 in 42.2.

  9. #9

    Default Re: Frameworks 5.30 and Plasma 5.9

    Quote Originally Posted by caf4926 View Post
    Basically you need to allow the deinstallation of a whole list of stuff
    not limited to but including

    These will all be replaced by the newer versions
    I don't think so.
    According to zypper's output they will be uninstalled, not replaced.

  10. #10

    Default Re: Frameworks 5.30 and Plasma 5.9

    This is why I've lost the taskbar and the menu? I only have the background picture.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •