Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: SUSE tumbleweed only GUI starts with nomodeset

  1. #1

    Post SUSE tumbleweed only GUI starts with nomodeset

    I've done fresh install of opensuse Tumbleweed and GUI wont start.
    I'm running it on laptop with AMD CPU with R3 graphics and AMD dedicated GPU (R5 M330),
    It seems that something is wrong with amdgpu kernel module, so I'm wondering how can i replace it with radeon module?

    Here is Xorg log: /var/log/Xorg.*.log

    Code:
    [    27.989] (--) Log file renamed from "/var/log/Xorg.pid-1260.log" to "/var/log/Xorg.0.log"[    28.035] 
    X.Org X Server 1.19.1
    Release Date: 2017-01-11
    [    28.035] X Protocol Version 11, Revision 0
    [    28.035] Build Operating System: openSUSE SUSE LINUX
    [    28.035] Current Operating System: Linux iSUSE 4.9.7-1-default #1 SMP PREEMPT Wed Feb 1 08:00:07 UTC 2017 (1680560) x86_64
    [    28.035] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.9.7-1-default root=UUID=85b1301f-d00f-45d8-9aea-d338aed7ee2d resume=/dev/disk/by-uuid/4c60fd18-6927-4d98-af88-1613bdbb4e55 splash=silent quiet showopts
    [    28.035] Build Date: 31 January 2017  12:08:16PM
    [    28.035]  
    [    28.035] Current version of pixman: 0.34.0
    [    28.035]     Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
    [    28.035] Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    [    28.035] (==) Log file: "/var/log/Xorg.0.log", Time: Wed Feb  8 15:56:22 2017
    [    28.063] (==) Using config directory: "/etc/X11/xorg.conf.d"
    [    28.063] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
    
    [    28.162] (==) Automatically adding GPU devices
    [    28.162] (==) Max clients allowed: 256, resource mask: 0x1fffff
    [    28.360] (WW) The directory "/usr/share/fonts/misc/sgi" does not exist.
    [    28.360]     Entry deleted from font path.
    
        built-ins[    28.376] (==) ModulePath set to "/usr/lib64/xorg/modules"
    [    28.376] (**) Extension "XFree86-DGA" is disabled
    [    28.376] (II) The server relies on udev to provide the list of input devices.
        If no devices become available, reconfigure udev or disable AutoAddDevices.
    [    28.376] (II) Loader magic: 0x825d20
    [    28.376] (II) Module ABI versions:
    [    28.376]     X.Org ANSI C Emulation: 0.4
    [    28.376]     X.Org Video Driver: 23.0
    [    28.376]     X.Org XInput driver : 24.1
    [    28.376]     X.Org Server Extension : 10.0
    [    28.377] (++) using VT number 7
    
    
    [    28.377] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
    [    28.378] (II) xfree86: Adding drm device (/dev/dri/card0)
    [    28.381] (--) PCI:*(0:0:1:0) 1002:9850:17aa:3810 rev 0, Mem @ 0xe0000000/268435456, 0xf0000000/8388608, 0xf0c00000/262144, I/O @ 0x00004000/256, BIOS @ 0x????????/131072
    [    28.382] (II) LoadModule: "glx"
    [    28.395] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
    [    28.589] (II) Module glx: vendor="X.Org Foundation"
    [    28.590]     compiled for 1.19.1, module version = 1.0.0
    [    28.590]     ABI class: X.Org Server Extension, version 10.0
    [    28.590] (II) Scanning /etc/X11/xorg_pci_ids directory for additional PCI ID's supported by the drivers
    [    28.608] (II) Scanning /etc/X11/xorg_pci_ids directory for additional PCI ID's supported by the drivers
    [    28.608] (==) Matched amdgpu as autoconfigured driver 0
    [    28.608] (==) Matched ati as autoconfigured driver 1
    [    28.608] (==) Matched amdgpu as autoconfigured driver 2
    [    28.608] (==) Matched ati as autoconfigured driver 3
    [    28.608] (==) Matched modesetting as autoconfigured driver 4
    [    28.608] (==) Matched fbdev as autoconfigured driver 5
    [    28.608] (==) Matched vesa as autoconfigured driver 6
    [    28.608] (==) Assigned the driver to the xf86ConfigLayout
    [    28.608] (II) LoadModule: "amdgpu"
    [    28.609] (II) Loading /usr/lib64/xorg/modules/drivers/amdgpu_drv.so
    [    28.656] (II) Module amdgpu: vendor="X.Org Foundation"
    [    28.656]     compiled for 1.19.1, module version = 1.2.0
    [    28.656]     Module class: X.Org Video Driver
    [    28.656]     ABI class: X.Org Video Driver, version 23.0
    [    28.656] (II) LoadModule: "ati"
    [    28.656] (II) Loading /usr/lib64/xorg/modules/drivers/ati_drv.so
    [    28.662] (II) Module ati: vendor="X.Org Foundation"
    [    28.662]     compiled for 1.19.0, module version = 7.8.0
    [    28.662]     Module class: X.Org Video Driver
    [    28.662]     ABI class: X.Org Video Driver, version 23.0
    [    28.662] (II) LoadModule: "radeon"
    [    28.662] (II) Loading /usr/lib64/xorg/modules/drivers/radeon_drv.so
    [    28.674] (II) Module radeon: vendor="X.Org Foundation"
    [    28.674]     compiled for 1.19.0, module version = 7.8.0
    [    28.674]     Module class: X.Org Video Driver
    [    28.674]     ABI class: X.Org Video Driver, version 23.0
    [    28.674] (II) LoadModule: "modesetting"
    [    28.675] (II) Loading /usr/lib64/xorg/modules/drivers/modesetting_drv.so
    [    28.690] (II) Module modesetting: vendor="X.Org Foundation"
    [    28.690]     compiled for 1.19.1, module version = 1.19.1
    [    28.690]     Module class: X.Org Video Driver
    [    28.690]     ABI class: X.Org Video Driver, version 23.0
    [    28.690] (II) LoadModule: "fbdev"
    [    28.691] (II) Loading /usr/lib64/xorg/modules/drivers/fbdev_drv.so
    [    28.691] (II) Module fbdev: vendor="X.Org Foundation"
    [    28.691]     compiled for 1.19.0, module version = 0.4.4
    [    28.691]     Module class: X.Org Video Driver
    [    28.691]     ABI class: X.Org Video Driver, version 23.0
    [    28.691] (II) LoadModule: "vesa"
    [    28.692] (II) Loading /usr/lib64/xorg/modules/drivers/vesa_drv.so
    [    28.692] (II) Module vesa: vendor="X.Org Foundation"
    [    28.692]     compiled for 1.19.0, module version = 2.3.4
    [    28.692]     Module class: X.Org Video Driver
    [    28.692]     ABI class: X.Org Video Driver, version 23.0
    [    28.692] (II) AMDGPU: Driver for AMD Radeon chipsets: OLAND, HAINAN, TAHITI,
        PITCAIRN, VERDE, BONAIRE, KABINI, MULLINS, KAVERI, HAWAII, TOPAZ,
        TONGA, CARRIZO, FIJI, STONEY, POLARIS11, POLARIS10
    [    28.693] (II) RADEON: Driver for ATI/AMD Radeon chipsets:
        .... FEW LINES DELETED, ATI Mobility Radeon Graphics, CEDAR, ATI FirePro 2270,
        ATI Radeon HD 5450, CAYMAN, AMD Radeon HD 6900 Series,
        AMD Radeon HD 6900M Series, Mobility Radeon HD 6000 Series, BARTS,
        AMD Radeon HD 6800 Series, AMD Radeon HD 6700 Series, TURKS, CAICOS,
        ARUBA, TAHITI, PITCAIRN, VERDE, OLAND, HAINAN, BONAIRE, KABINI,
        MULLINS, KAVERI, HAWAII
    [    28.700] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
    [    28.700] (II) FBDEV: driver for framebuffer: fbdev
    [    28.700] (II) VESA: driver for VESA chipsets: vesa
    [    28.711] (II) [KMS] Kernel modesetting enabled.
    [    28.712] (EE) AMDGPU(0): amdgpu_device_initialize failed
    [    28.713] (II) [KMS] Kernel modesetting enabled.
    [    28.713] (EE) AMDGPU(1): amdgpu_device_initialize failed
    [    28.715] (II) [KMS] Kernel modesetting enabled.
    [    28.716] (EE) AMDGPU(G0): amdgpu_device_initialize failed
    [    28.717] (II) [KMS] Kernel modesetting enabled.
    [    28.718] (EE) AMDGPU(2): amdgpu_device_initialize failed
    [    28.718] (II) [KMS] Kernel modesetting enabled.
    [    28.719] (EE) AMDGPU(3): amdgpu_device_initialize failed
    [    28.720] (II) [KMS] Kernel modesetting enabled.
    [    28.720] (WW) Falling back to old probe method for modesetting
    [    28.721] (WW) Falling back to old probe method for fbdev
    [    28.721] (II) Loading sub module "fbdevhw"
    [    28.721] (II) LoadModule: "fbdevhw"
    [    28.721] (II) Loading /usr/lib64/xorg/modules/libfbdevhw.so
    [    28.722] (II) Module fbdevhw: vendor="X.Org Foundation"
    [    28.722]     compiled for 1.19.1, module version = 0.0.2
    [    28.722]     ABI class: X.Org Video Driver, version 23.0
    [    28.722] (WW) Falling back to old probe method for vesa
    [    28.722] (EE) Screen 0 deleted because of no matching config section.
    [    28.722] (II) UnloadModule: "amdgpu"
    [    28.722] (EE) Screen 0 deleted because of no matching config section.
    [    28.722] (II) UnloadModule: "amdgpu"
    [    28.722] (EE) Screen 0 deleted because of no matching config section.
    [    28.722] (II) UnloadModule: "amdgpu"
    [    28.722] (EE) Screen 0 deleted because of no matching config section.
    [    28.722] (II) UnloadModule: "amdgpu"
    [    28.722] (EE) 
    [    28.722] (EE) Backtrace:
    [    28.722] (EE) 0: /usr/bin/X (xorg_backtrace+0x4a) [0x59b5ba]
    [    28.722] (EE) 1: /usr/bin/X (0x400000+0x19f349) [0x59f349]
    [    28.722] (EE) 2: /lib64/libpthread.so.0 (0x7f45343e9000+0x11080) [0x7f45343fa080]
    [    28.722] (EE) 3: /lib64/libc.so.6 (0x7f453404a000+0x7a1cc) [0x7f45340c41cc]
    [    28.722] (EE) 4: /lib64/libc.so.6 (__libc_calloc+0x27b) [0x7f45340c6e5b]
    [    28.722] (EE) 5: /usr/bin/X (XNFcallocarray+0x9) [0x5a1dd9]
    [    28.722] (EE) 6: /usr/bin/X (xf86GetEntityInfo+0x29) [0x4728c9]
    [    28.723] (EE) 7: /usr/lib64/xorg/modules/drivers/radeon_drv.so (0x7f452eb50000+0x4ba60) [0x7f452eb9ba60]
    [    28.723] (EE) 8: /usr/bin/X (InitOutput+0xa52) [0x480e82]
    [    28.723] (EE) 9: /usr/bin/X (0x400000+0x3e6f6) [0x43e6f6]
    [    28.723] (EE) 10: /lib64/libc.so.6 (__libc_start_main+0xf1) [0x7f453406a291]
    [    28.723] (EE) 11: /usr/bin/X (_start+0x2a) [0x4285ea]
    [    28.723] (EE) 
    [    28.723] (EE) Segmentation fault at address 0xf1fb
    [    28.723] (EE) 
    Fatal server error:
    [    28.723] (EE) Caught signal 11 (Segmentation fault). Server aborting
    [    28.723] (EE) 
    [    28.723] (EE) 
    Please consult the The X.Org Foundation support 
         at http://wiki.x.org
     for help. 
    [    28.723] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
    [    28.723] (EE) 
    [    28.741] (EE) Server terminated with error (1). Closing log file.

  2. #2

    Default Re: SUSE tumbleweed only GUI starts with nomodeset

    I too just installed Tumbleweed on an HP 355 G2 laptop. It is AMD based and probably has the same graphics chips as yours. Exact same problem. Live disk works fine. Install proceeds at typical SuSE glacial (hour+) pace but doesn't seem to throw hard errors. Reboot, menu comes up, OS starts, see a couple of flashes of something which looks like it might be a graphical splash, then nothing but terminal login. Trying startx from the command line spews a bunch of stuff both quickly and in poorly formatted manner, then ends with a "waiting for server" type message.

    I assume we have a busted video driver being installed.

    Any work arounds?

  3. #3
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    22,503
    Blog Entries
    15

    Default Re: SUSE tumbleweed only GUI starts with nomodeset

    Hi
    It would appear it's kernel changes with respect to amdgpu vs radeon fighting (Need to track down discussion from last year).

    If you create a /etc/modprobe.d/50-radeon.conf containing;
    Code:
    blacklist radeon
    Save and then rebuild initrd with mkinitrd it should start working....
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    openSUSE Leap 42.2 (x86_64) GNOME 3.20.2
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  4. #4
    Join Date
    Oct 2014
    Location
    Italy
    Posts
    1,071

    Default Re: SUSE tumbleweed only GUI starts with nomodeset

    Hi, quite a few users are getting troubles out of AMD chips with recent Tumbleweed... please see if the following helps:
    https://forums.opensuse.org/showthre...36#post2810836
    Main: Leap 42.2 Gnome on i7 4720HQ + Geforce GTX960M
    Test: Leap 42.2 (& others) on Core2Duo + GM965

  5. #5
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    22,503
    Blog Entries
    15

    Default Re: SUSE tumbleweed only GUI starts with nomodeset

    Quote Originally Posted by OrsoBruno View Post
    Hi, quite a few users are getting troubles out of AMD chips with recent Tumbleweed... please see if the following helps:
    https://forums.opensuse.org/showthre...36#post2810836
    Hi
    Transition time....

    I've found on my setup now I only need to blacklist radeon, have raised the issue on the factory ML and will see what happens...
    https://lists.opensuse.org/opensuse-.../msg00234.html
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    openSUSE Leap 42.2 (x86_64) GNOME 3.20.2
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  6. #6

    Default Re: SUSE tumbleweed only GUI starts with nomodeset

    Quote Originally Posted by malcolmlewis View Post
    Hi
    It would appear it's kernel changes with respect to amdgpu vs radeon fighting (Need to track down discussion from last year).

    If you create a /etc/modprobe.d/50-radeon.conf containing;
    Code:
    blacklist radeon
    Save and then rebuild initrd with mkinitrd it should start working....

    Hello, thanks for reply.
    That sort of worked. GUI is now starting without adding nomodeset in grub boot options and everything is running smoothly, but I also had to disable dedicated graphics card in BIOS settings.
    Is there any way I can get dedicated GPU working?

    Thank you all for your help.


    Here are steps to fix that problem for future readers who might be looking for answer (double quotation marks (") indicate that something is ready to be copied and isn't part of the command):

    1. when grub opens click letter e on your keyboard and add "nomodeset" after quiet splash
    2. run: "sudo echo 'blacklist radeon' >> /etc/modprobe.d/50-radeon.conf"
    3. run: "sudo mkinitrd"
    4. restart PC
    5. (if device GUI doesn't start at boot up) go to the BIOS and disable dedicated graphics controller.

  7. #7
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    22,503
    Blog Entries
    15

    Default Re: SUSE tumbleweed only GUI starts with nomodeset

    Quote Originally Posted by paupav View Post
    Hello, thanks for reply.
    That sort of worked. GUI is now starting without adding nomodeset in grub boot options and everything is running smoothly, but I also had to disable dedicated graphics card in BIOS settings.
    Is there any way I can get dedicated GPU working?

    Thank you all for your help.


    Here are steps to fix that problem for future readers who might be looking for answer (double quotation marks (") indicate that something is ready to be copied and isn't part of the command):

    1. when grub opens click letter e on your keyboard and add "nomodeset" after quiet splash
    2. run: "sudo echo 'blacklist radeon' >> /etc/modprobe.d/50-radeon.conf"
    3. run: "sudo mkinitrd"
    4. restart PC
    5. (if device GUI doesn't start at boot up) go to the BIOS and disable dedicated graphics controller.
    Hi
    So this is a desktop system or laptop with multi GPU's?

    What is the output from;
    Code:
    /sbin/lspci -nnk | egrep 'VGA|3D|Display' -A3
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    openSUSE Leap 42.2 (x86_64) GNOME 3.20.2
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  8. #8

    Default Re: SUSE tumbleweed only GUI starts with nomodeset

    Information you've requested:

    00:01.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Mullins [Radeon R3 Graphics] [1002:9850] Subsystem: Lenovo Device [17aa:3811]
    Kernel driver in use: amdgpu
    Kernel modules: radeon, amdgpu
    --
    01:00.0 Display controller [0380]: Advanced Micro Devices, Inc. [AMD/ATI] Sun XT [Radeon HD 8670A/8670M/8690M / R5 M330 / M430] [1002:6660] (rev 83)
    Subsystem: Lenovo Device [17aa:3811]
    Kernel driver in use: amdgpu
    Kernel modules: radeon, amdgpu
    This is obviously output when both GPUs are enabled.

  9. #9
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    22,503
    Blog Entries
    15

    Default Re: SUSE tumbleweed only GUI starts with nomodeset

    On Wed 08 Feb 2017 06:36:01 PM CST, paupav wrote:

    Information you've requested:
    Code:
    
    > 00:01.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc.
    > [AMD/ATI] Mullins [Radeon R3 Graphics] [1002:9850]    Subsystem:
    > Lenovo Device [17aa:3811]
    > Kernel driver in use: amdgpu
    > Kernel modules: radeon, amdgpu
    > --
    > 01:00.0 Display controller [0380]: Advanced Micro Devices, Inc.
    > [AMD/ATI] Sun XT [Radeon HD 8670A/8670M/8690M / R5 M330 / M430]
    > [1002:6660] (rev 83)
    > Subsystem: Lenovo Device [17aa:3811]
    > Kernel driver in use: amdgpu
    > Kernel modules: radeon, amdgpu
    This is obviously output when both GPUs are enabled.
    Hi
    So which one gets disabled the Mullins or XT?

    Sounds like in your case it may need a special xorg.conf file...

    --
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    openSUSE Leap 42.1|GNOME 3.16.2|4.1.36-44-default
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


  10. #10

    Default Re: SUSE tumbleweed only GUI starts with nomodeset

    Hi,
    Sun XT (R5 M330 gets disabled).
    This is laptop, forgot to mention it.

    Could installing amdgpu-pro solve this problem?

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •