Results 1 to 3 of 3

Thread: X crashes after latest update

  1. #1

    Question X crashes after latest update


    i just updated to the latest version of tumbleweed and after reboot x crashes and i only got the console. is this a driver issue?

    if anyone has any idea about what happened and how to solve the problem, i'd be very thankful.

    i added some info i thought could be relevant. if anything is missing, i'd be happy to provide more info.


    /var/log/Xorg.0.log: (link is valid for 1 year)

    lsmod | grep -E "radeon|amdgpu"
    amdgpu               1675264  0
    mfd_core               16384  2 lpc_ich,amdgpu
    radeon               1609728  1
    i2c_algo_bit           16384  2 amdgpu,radeon
    drm_kms_helper        172032  2 amdgpu,radeon
    ttm                   114688  2 amdgpu,radeon
    drm                   393216  5 amdgpu,radeon,ttm,drm_kms_helper
    01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Tobago PRO [Radeon R7 360 / R9 360 OEM] (rev 81)
    01:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Tobago HDMI Audio [Radeon R7 360 / R9 360 OEM]
    hwinfo --framebuffer:
    hwinfo --framebuffer
    02: None 00.0: 11001 VESA Framebuffer                           
      [Created at bios.459]
      Unique ID: rdCR.7QGH37b9CJD
      Hardware Class: framebuffer
      Model: "(C) 1988-2010, Advanced Micro Devices TOBAGO"
      Vendor: "(C) 1988-2010, Advanced Micro Devices, Inc."
      Device: "TOBAGO"
      SubVendor: "AMD ATOMBIOS"
      Revision: "01.00"
      Memory Size: 16 MB
      Memory Range: 0xe0000000-0xe0ffffff (rw)
      Mode 0x0300: 640x400 (+640), 8 bits
      Mode 0x0301: 640x480 (+640), 8 bits
      Mode 0x0303: 800x600 (+832), 8 bits
      Mode 0x0305: 1024x768 (+1024), 8 bits
      Mode 0x0307: 1280x1024 (+1280), 8 bits
      Mode 0x0310: 640x480 (+1280), 15 bits
      Mode 0x0311: 640x480 (+1280), 16 bits
      Mode 0x0313: 800x600 (+1664), 15 bits
      Mode 0x0314: 800x600 (+1664), 16 bits
      Mode 0x0316: 1024x768 (+2048), 15 bits
      Mode 0x0317: 1024x768 (+2048), 16 bits
      Mode 0x0319: 1280x1024 (+2560), 15 bits
      Mode 0x031a: 1280x1024 (+2560), 16 bits
      Mode 0x0363: 1280x960 (+1280), 8 bits
      Mode 0x0365: 1280x960 (+2560), 16 bits
      Mode 0x0366: 1280x960 (+5120), 24 bits
      Mode 0x0321: 640x480 (+2560), 24 bits
      Mode 0x0322: 800x600 (+3328), 24 bits
      Mode 0x0323: 1024x768 (+4096), 24 bits
      Mode 0x0324: 1280x1024 (+5120), 24 bits
      Mode 0x0343: 1400x1050 (+1408), 8 bits
      Mode 0x0345: 1400x1050 (+2816), 16 bits
      Mode 0x0346: 1400x1050 (+5632), 24 bits
      Mode 0x03d1: 1920x1080 (+1920), 8 bits
      Mode 0x03d2: 1920x1080 (+3840), 16 bits
      Mode 0x03d4: 1920x1080 (+7680), 24 bits
      Config Status: cfg=no, avail=yes, need=no, active=unknown
    hwinfo --gfxcard:
    23: PCI 100.0: 0300 VGA compatible controller (VGA)             
      [Created at pci.378]
      Unique ID: VCu0.Yfmhz3ebjP7
      Parent ID: vSkL.jcAfDPVAIZ6
      SysFS ID: /devices/pci0000:00/0000:00:01.0/0000:01:00.0
      SysFS BusID: 0000:01:00.0
      Hardware Class: graphics card
      Model: "XFX Pine Radeon R7 360"
      Vendor: pci 0x1002 "ATI Technologies Inc"
      Device: pci 0x665f "Tobago PRO [Radeon R7 360 / R9 360 OEM]"
      SubVendor: pci 0x1682 "XFX Pine Group Inc."
      SubDevice: pci 0x7360 "Radeon R7 360"
      Revision: 0x81
      Driver: "radeon"
      Driver Modules: "drm"
      Memory Range: 0xe0000000-0xefffffff (ro,non-prefetchable)
      Memory Range: 0xf0000000-0xf07fffff (ro,non-prefetchable)
      I/O Ports: 0xe000-0xefff (rw)
      Memory Range: 0xf7e00000-0xf7e3ffff (rw,non-prefetchable)
      Memory Range: 0x000c0000-0x000dffff (rw,non-prefetchable,disabled)
      IRQ: 36 (12 events)
      I/O Ports: 0x3c0-0x3df (rw)
      Module Alias: "pci:v00001002d0000665Fsv00001682sd00007360bc03sc00i00"
      Driver Info #0:
        Driver Status: radeon is active
        Driver Activation Cmd: "modprobe radeon"
      Driver Info #1:
        Driver Status: amdgpu is active
        Driver Activation Cmd: "modprobe amdgpu"
      Config Status: cfg=new, avail=yes, need=no, active=unknown
      Attached to: #21 (PCI bridge)]

  2. #2
    Join Date
    Jun 2008
    Blog Entries

    Default Re: X crashes after latest update

    Have a look at the suggestion I offered in this thread....
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3

    Lightbulb Re: X crashes after latest update

    thank you!

    blacklisting radeon solved my problem.

    i already tried this in /etc/modprobe.d/99-local.conf, but i didn't rebuild initrd.


Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts