Results 1 to 5 of 5

Thread: zypper ve showing package error that will not repair

  1. #1

    Question zypper ve showing package error that will not repair

    Opensuse upgraded me to plasma 5.9. I ran zypper up and I got this message:

    Code:
    The following package update will NOT be installed:
      kernel-default
    
    The following 3 applications are going to be REMOVED:
      Desktop "Grouping Plasmoid" "System Tray"
    Then I ran zypper ve and I get:

    Code:
    The following 21 applications are going to be REMOVED:
      "Activity Bar" "Analog Clock" "Application Menu" "Battery and Brightness" Calendar Clipboard "CPU Load Monitor" Desktop
      "Device Notifier" "Digital Clock" "Grouping Plasmoid" "Hard Disk I/O Monitor" "Hard Disk Space Usage" Icon Lock/Logout
      "Media Player" "Memory Status" "Network Monitor" Notifications "Panel Spacer" "System Tray"
    
    The following package is going to be reinstalled:
      plasma5-workspace
    
    1 package to reinstall.
    Overall download size: 5.5 MiB. Already cached: 0 B. No additional space will be used or freed after the operation.
    Some of the dependencies of installed packages are broken. In order to fix these dependencies, the following actions need to be taken:
    I'm not understanding what I'm being told, and it didn't look good to me, but I hit "y". Not much happened, a couple files downloaded and installed. But when I rebooted, I got the same message, so I did it again with the same results. I was wondering if anyone could tell me what's happened. Thank you much!

    Mike

  2. #2

    Default Re: zypper ve showing package error that will not repair

    I'm having the same experience.
    Code:
    # rpm --verify plasma5-workspace
    # echo $?
    0
    #

  3. #3

    Default Re: zypper ve showing package error that will not repair

    Ignore that.
    It's a flaw in the Appstream metadata.
    Problems like this are ongoing since ever zypper gained support for "applications" years ago.

    Note that the message says that the *applications* are removed, not any packages.

    In this particular case it seems to be a "bug" in the plasma5-workspace package which will hopefully be fixed soon.
    http://bugzilla.opensuse.org/show_bug.cgi?id=1024326
    Last edited by wolfi323; 10-Feb-2017 at 07:55.

  4. #4
    Join Date
    Feb 2016
    Location
    Berlin
    Posts
    357

    Default Re: zypper ve showing package error that will not repair

    in addition: "The following package update will NOT be installed" this is caused by only using zypper up. if your on tumbleweed sudo zypper dup --no-allow-vendor-change (that is, if you actually want it installing)

  5. #5

    Default Re: zypper ve showing package error that will not repair

    Quote Originally Posted by ndc33 View Post
    in addition: "The following package update will NOT be installed" this is caused by only using zypper up.
    No, I'm pretty sure this is *not* caused by using "zypper up".

    Again, it's a "bug" in the repo metadata. It misses the information that the plasma5-workspace package contains the mentioned "applications", so zypper thinks they will be removed when the package is updated.
    As this appdata is generated automatically, it's not straightforward to fix either.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •