Results 1 to 7 of 7

Thread: Very choppy playback of mkv files, no sound

  1. #1
    Join Date
    Nov 2013
    Location
    Ljubljana, Slovenia
    Posts
    465

    Default Very choppy playback of mkv files, no sound

    Hi guys,

    In Leap 42.2 VLC plays mkv files very choppy, the picture is chopped up, as is sound. What I have installed is: vlc and vlc-codecs from the packman repo (full vendor change), and the rest codecs i bought from fluendo (gstreamer and the likes). avi files play normally.

    Any ideas what I could do, as this is kind of a pain...

    Thanks.
    Running openSUSE Leap 42.3 + KDE

  2. #2
    Join Date
    Oct 2014
    Location
    Italy
    Posts
    1,674

    Default Re: Very choppy playback of mkv files, no sound

    Hi, just checked this http://divxtrailers.divx.com/GIJoeTh...DivXPlusHD.mkv without problems.
    Please check if another application is eating up your CPU (issue "top" in a terminal or use your favourite system monitor).
    I have the following installed from packman:
    Code:
    linux-xwi9:~ # zypper --no-refresh se -vi vlc
    Loading repository data...
    Reading installed packages...
    
    S | Name            | Type        | Version            | Arch   | Repository       
    --+-----------------+-------------+--------------------+--------+------------------
    i | VLC             | application |                    | noarch | (System Packages)
        name: application:VLC
    i | libvlc6         | package     | 3.0.0+git9358-1.28 | x86_64 | (System Packages)
        name: libvlc6
    i | libvlccore9     | package     | 3.0.0+git9358-1.28 | x86_64 | (System Packages)
        name: libvlccore9
    i | vlc-beta        | package     | 3.0.0+git9358-1.28 | x86_64 | (System Packages)
        name: vlc-beta
    i | vlc-beta-codecs | package     | 3.0.0+git9358-1.28 | x86_64 | (System Packages)
        name: vlc-beta-codecs
    i | vlc-beta-noX    | package     | 3.0.0+git9358-1.28 | x86_64 | (System Packages)
        name: vlc-beta-noX
    i | vlc-beta-qt     | package     | 3.0.0+git9358-1.28 | x86_64 | (System Packages)
        name: vlc-beta-qt
    linux-xwi9:~ #
    Main: Leap 15 Gnome on i7 4720HQ + Geforce GTX960M
    Test: Leap 42.3 (& others) on Core2Duo + GM965

  3. #3
    Join Date
    Nov 2013
    Location
    Ljubljana, Slovenia
    Posts
    465

    Default Re: Very choppy playback of mkv files, no sound

    Hi,

    Actually, nothing is eating up my CPU, it's steadily at 10%. I have everything installed the same, except my vlc isn't beta, but the regular version.
    Running openSUSE Leap 42.3 + KDE

  4. #4
    Join Date
    Oct 2014
    Location
    Italy
    Posts
    1,674

    Default Re: Very choppy playback of mkv files, no sound

    OK, installed the regular version with its dependencies: no problem here playing the referenced trailer, with CPU between 10 and 20%.
    Maybe you have some video acceleration feature that gets in the way? Please show the result of:
    Code:
    zypper --no-refresh se -i vaapi vdpau
    For reference, this is what vlc I used for testing:

    Code:
    LT_B:~ # zypper info vlc
    Loading repository data...
    Reading installed packages...
    
    
    Information for package vlc:
    ----------------------------
    Repository     : Packman Essentials           
    Name           : vlc                          
    Version        : 2.2.4-29.2                   
    Arch           : x86_64                       
    Vendor         : http://packman.links2linux.de
    Installed Size : 401.7 KiB                    
    Installed      : Yes                          
    Status         : up-to-date
    Main: Leap 15 Gnome on i7 4720HQ + Geforce GTX960M
    Test: Leap 42.3 (& others) on Core2Duo + GM965

  5. #5
    Join Date
    Nov 2013
    Location
    Ljubljana, Slovenia
    Posts
    465

    Default Re: Very choppy playback of mkv files, no sound

    Thanks again for your help. Here's vlc i use:

    Code:
    nenad@openSUSE:~> zypper info vlc
    Repository 'Packman Repository' is out-of-date. You can run 'zypper refresh' as root to update it.
    Loading repository data...
    Reading installed packages...
    
    
    Information for package vlc:
    ----------------------------
    Repository     : Packman Repository           
    Name           : vlc                          
    Version        : 2.2.4-29.2                   
    Arch           : x86_64                       
    Vendor         : http://packman.links2linux.de
    Installed Size : 401.7 KiB                    
    Installed      : Yes                          
    Status         : up-to-date                   
    Summary        : Graphical media player       
    Description    :                              
        VLC media player is a multimedia player for many
        audio and video files and formats (such as MPEG, DivX, mp3, ogg, ...)
        as well as DVDs, VCDs, and various streaming protocols.
        It can also be used as a server to stream in unicast or multicast
        in IPv4 or IPv6 on a high-bandwidth network.
    
    
        Note that the actual support is provided through ffmpeg and gstreamer
        libraries, which may not have all codecs enabled that were just named.

    and here is the upper output you requested:

    Code:
    nenad@openSUSE:~> zypper --no-refresh se -i vaapi vdpau
    Loading repository data...
    Reading installed packages...
    
    S | Name               | Summary                                    | Type   
    --+--------------------+--------------------------------------------+--------
    i | libvdpau1          | VDPAU wrapper library                      | package
    i | libvdpau_nouveau   | XVMC state tracker for Nouveau             | package
    i | libvdpau_va_gl1    | VDPAU driver with OpenGL/VAAPI backend     | package
    i | vaapi-dummy-driver | Video Acceleration (VA) API for Linux      | package
    i | vaapi-intel-driver | Intel Driver for Video Acceleration (VA)-> | package
    Hope this helps...
    Running openSUSE Leap 42.3 + KDE

  6. #6
    Join Date
    Nov 2013
    Location
    Ljubljana, Slovenia
    Posts
    465

    Default Re: Very choppy playback of mkv files, no sound

    Heureka!

    Finally stumbled on to this and this thread. What did the trick was:

    Verify that you don't have vdpau-video installed.

    If not, try to uninstall libvdpau_va_gl1, apparently that can cause problems with vlc on some (intel) systems.
    And it is not necessary anyway, as VLC supports VA-API too.
    By wolfi323

    VLC now plays normally mkv files. Could someone elaborate as to why exactly this error occurs? In layman terms? Would love to learn from the issue. Thanks.
    Running openSUSE Leap 42.3 + KDE

  7. #7
    Join Date
    Oct 2014
    Location
    Italy
    Posts
    1,674

    Default Re: Very choppy playback of mkv files, no sound

    Quote Originally Posted by holden87 View Post
    VLC now plays normally mkv files. Could someone elaborate as to why exactly this error occurs? In layman terms? Would love to learn from the issue. Thanks.
    Nice to read you are up and running again! So the problem seems HW related, since libvdpau_va_gl1 is doing no harm on my system.
    Leaving to wolfi323 to elaborate on that issue if he is reading this thread, what I can write in "layman terms" is the following.
    VDPAU is a video acceleration technology introduced by Nvidia.
    VAAPI is a video acceleration technology introduced for Intel chips.
    Then some libraries were developed to "mimic" VDPAU through the VA-API interface on Intel chips, but apparently some chips don't like those "tricks".
    Long story short, since I never had VDPAU working on openSUSE, I normally uninstall everything VDPAU-related: with modern CPUs you seldom really need any video acceleration (and certainly you don't need those that are NOT working...)
    Main: Leap 15 Gnome on i7 4720HQ + Geforce GTX960M
    Test: Leap 42.3 (& others) on Core2Duo + GM965

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •