Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Menubar button not shown

  1. #1
    Join Date
    Jan 2016
    Location
    Manchester, UK
    Posts
    279

    Default Menubar button not shown

    Since KDE Plasma 5.9 offers the Global Menu Bar option, I tried to use it as in "Title bar button" mode. But after enabling it and restarting some applications, the menu bars disappear as expected, but the "Title bar button" does not show up.

    I tried this in an updated TW in VM. It works. So it's not a bug but something wrong with my system.

    What I have done to try to bring the "Title bar button" back:
    1. Reset configurations of kwin;
      Commands,
      Code:
      $ mv ~/.config/kwinrc ~/.config/kwinrc-old && kwin_x11 --replace
      complain,
      Code:
      kf5.kcoreaddons.desktopparser: Could not locate service type file kservicetypes5/kwin-effect.desktop, tried ("/home/cnzhx/.local/share", "/usr/share")
    2. Rest configurations of Plasma;
    3. Change theme between Breeze Dark and Breeze.


    But all failed.

    Does anyone have any idea about this?

    TIA,
    CnZhx
    openSUSE Tumbleweed (usually the latest snapshot) w/ KDE Plasma 5

  2. #2
    Join Date
    Jan 2016
    Location
    Manchester, UK
    Posts
    279

    Default Re: Menubar button not shown

    Quote Originally Posted by cnzhx View Post
    1. Reset configurations of kwin;
      Commands,
      Code:
      $ mv ~/.config/kwinrc ~/.config/kwinrc-old && kwin_x11 --replace
      complain,
      Code:
      kf5.kcoreaddons.desktopparser: Could not locate service type file kservicetypes5/kwin-effect.desktop, tried ("/home/cnzhx/.local/share", "/usr/share")
    Now this problem is fixed in my system.

    After previous described "reset configurations of kwin", a reboot of the system brings me the menubar button. But I am now sure if deleting the cache helps on this issue.
    openSUSE Tumbleweed (usually the latest snapshot) w/ KDE Plasma 5

  3. #3
    Join Date
    Jun 2008
    Location
    wichita
    Posts
    921

    Default Re: Menubar button not shown

    I also was not able to get the titlebar button to show up. I followed the instructions from this article: http://fasterland.net/activate-globa...lasma-5-9.html

    After the final step, I just got another config panel at the top of my desktop just like the one on the bottom. Maybe it isn't supported in Tumbleweed's version of 5.9 yet?

  4. #4
    Join Date
    Jan 2016
    Location
    Manchester, UK
    Posts
    279

    Default Re: Menubar button not shown

    Quote Originally Posted by pilotgi View Post
    I also was not able to get the titlebar button to show up. I followed the instructions from this article: http://fasterland.net/activate-globa...lasma-5-9.html
    I was able to get the titlebar menu button by editing the buttons as suggested in the article after choosing "Title bar button" mode. To edit the buttons, just navigate to "System Settings" > "Application Style" > "Window Decorations" > "Buttons", and click-and-hold the "Application menu button" to drag it to the title bar above the buttons repository.

    This is just a workaround. Comparing to this, the "Title bar button" automatically appears in my VM installation of TW (without any modification of settings and no extra applications besides default installation).

    But later, I found that the "Title bar button" has some glitches. For example, when I click on it in order to select an action from the submenu, the dropdown menu folds back before I can click on some buttons. It happens frequently. So I am not using this feature for now. Hopefully, it will get more robust. Or I will do a fresh install of my system sometime.

    Quote Originally Posted by pilotgi View Post
    After the final step, I just got another config panel at the top of my desktop just like the one on the bottom. Maybe it isn't supported in Tumbleweed's version of 5.9 yet?
    This is another mode of global menu, named "Application menu widget". It doesn't attract me because the separated menu bar from application make me uncomfortable.
    openSUSE Tumbleweed (usually the latest snapshot) w/ KDE Plasma 5

  5. #5

    Default AW: Re: Menubar button not shown

    Quote Originally Posted by pilotgi View Post
    After the final step, I just got another config panel at the top of my desktop just like the one on the bottom. Maybe it isn't supported in Tumbleweed's version of 5.9 yet?
    It is supported.

    But you probably just created a new default panel on the top, which will of course look the same as the one on the bottom.

    You need to add a "Global Menu" plasmoid/widget somewhere, this can be in a panel or directly on the desktop.

    Haven't read the article you linked to, but I suppose the suggested thing to do would be to create an *empty* panel on the top of the screen and then add the "Global Menu" widget to it (right-click on the toolbox icon on the right edge and choose "Add Widgets"). This would give you a MacOS like application menu on the top of the screen, not hidden by windows.

  6. #6
    Join Date
    Jun 2008
    Location
    wichita
    Posts
    921

    Default Re: Menubar button not shown

    Quote Originally Posted by cnzhx View Post
    I was able to get the titlebar menu button by editing the buttons as suggested in the article after choosing "Title bar button" mode. To edit the buttons, just navigate to "System Settings" > "Application Style" > "Window Decorations" > "Buttons", and click-and-hold the "Application menu button" to drag it to the title bar above the buttons repository.
    I already did this after reading the article. Still no titlebar button for me.

  7. #7
    Join Date
    Jan 2016
    Location
    Manchester, UK
    Posts
    279

    Default Re: Menubar button not shown

    Quote Originally Posted by pilotgi View Post
    I already did this after reading the article. Still no titlebar button for me.
    In my case, the Title bar buttons will not show up for some of the applications, such as Dolphin, if they are resumed from a stored session, otherwise they are good. For those apps not worked currently, just to close and reopen might brings the buttons back. If your situations are different, then I am out of ideas.
    openSUSE Tumbleweed (usually the latest snapshot) w/ KDE Plasma 5

  8. #8

    Default Re: Menubar button not shown

    Quote Originally Posted by pilotgi View Post
    I already did this after reading the article. Still no titlebar button for me.
    Then check that the "Application menus daemon" is activated and running in systemsettings5->Startup and Shutdown->Background Services.

    Also, you need to set the Menubar style to "Application Menu widget" in systemsettings5->Application Appearance->Widget Style->Finetuning, but I suppose you did that anyway...

  9. #9
    Join Date
    Jan 2016
    Location
    Manchester, UK
    Posts
    279

    Default Re: Menubar button not shown

    Quote Originally Posted by wolfi323 View Post
    Also, you need to set the Menubar style to "Application Menu widget" in systemsettings5->Application Appearance->Widget Style->Finetuning
    Is "Application Menu widget" only for Application Menu "Panel" or "desktop widget", but not for "Title bar button"?
    openSUSE Tumbleweed (usually the latest snapshot) w/ KDE Plasma 5

  10. #10

    Default Re: Menubar button not shown

    Quote Originally Posted by cnzhx View Post
    Is "Application Menu widget" only for Application Menu "Panel" or "desktop widget", but not for "Title bar button"?
    Yes.
    For "Title bar button" you should set it to "Title bar button" obviously...

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •