Results 1 to 5 of 5

Thread: poor performance of KDE on Leap 42.2

  1. #1
    Join Date
    Nov 2009
    Location
    West Midlands
    Posts
    71

    Angry poor performance of KDE on Leap 42.2

    hi all, I have just got hold of a new PC; Kabylake i5 7600, four core 3.5Ghz, 8GB DDR4 ram SSD hardrive. Not super fast, but not a slouch either. I installed Leap 42.2 on the hardrive, there was no other OS installed, so a fresh install. It is running on the on-board graphics, which I think is Intel HD 630.

    So when I am logged in, everything feels slow, the graphics are sluggish, when I drag a window across the screen, the movement is jagged, not smooth. I went through the windows effects settings and turned off what I thought would be an issue. I turned off the Blur effect which helped a little, but not a lot overall.

    This is very frustrating and I am puzzled as to why it is running so slow on a modern PC.

    Any help or suggestions?
    Vas
    openSuse 42.2

  2. #2
    Join Date
    Apr 2015
    Location
    USA
    Posts
    41

    Default Re: poor performance of KDE on Leap 42.2

    It sounds like the indexer (akonadi).

    Iif this is your first time using KDE or have not used it in a long time, then the indexer runs like crazy for a bit. This of course uses quite a bit of CPU and will slow things down. You can test by "stopping" the service through ksysguard and see if it resolves the problem, if it does then restart akonadi so it can finish indexing. You could also leave the service alone, make a cup of tea or coffee enjoy a nice snack and check back to see if its done.

    Ref: https://userbase.kde.org/Akonadi

  3. #3
    Join Date
    Oct 2014
    Location
    Italy
    Posts
    1,669

    Default Re: poor performance of KDE on Leap 42.2

    Hi, others have reported video problems with the new Kabylake chips. You may try to boot adding the i915.preliminary_hw_support=1 option to the kernel boot line.
    (Just press "E" at the GRUB menu screen and look for a line beginning with "linuxefi", then append to it).
    Or you may add the "nomodeset" boot option to see if changing the video driver has any effect.
    Or you might need a newer kernel like a 4.9.x from the kernel:stable repo.
    Main: Leap 15 Gnome on i7 4720HQ + Geforce GTX960M
    Test: Leap 42.3 (& others) on Core2Duo + GM965

  4. #4
    Join Date
    Nov 2009
    Location
    West Midlands
    Posts
    71

    Default Re: poor performance of KDE on Leap 42.2

    Thanks guys, I'll give both a go and come back
    Vas
    openSuse 42.2

  5. #5
    Join Date
    Nov 2009
    Location
    West Midlands
    Posts
    71

    Default Re: poor performance of KDE on Leap 42.2

    Hi, I looked at akonadi and that is not the problem. I looked at the processes and saw that at idle, everything is fine, as soon as I move a window about, X rocketed all four CPU cores to about 90% usage.

    I did a search for Kabylake issues on the forum and noticed that a few people had the same issue as you (OrsoBruno) mentioned. I added the tumbleweed kernel repo and upgraded to the latest version 4.9.xxx. That did the trick, mostly. The monitor resolution was correctly found and used, the performance issue was also gone.

    I now have a problem with tearing of the window graphics when I resize a window. I did notice something in those posts I found earlier about this, so I'll have a re-read and try something else.
    Vas
    openSuse 42.2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •