Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Clock in the TaskBar shows wrong time

  1. #1
    Join Date
    Aug 2013
    Location
    Jundiai, São Paulo, Brazil
    Posts
    464

    Default Clock in the TaskBar shows wrong time

    I am using openSUSE 13.2 (Harlequin) (i586) and KDE

    The time displayed on the taskbar is two hours more.
    If I right-click and choose "Set date and time" a frame will appear with the right time. Nothing to do.
    If I try to set the time for YaST, then the time is right. Nothing to do either.
    The Time Zone is set correctly for Brazil and I am using UTC.

    See below an image with the window of adjustment and clock in the taskbar

    What should I do to make the taskbar clock shows the correct time?



  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,853

    Default Re: Clock in the TaskBar shows wrong time

    Check:
    Code:
    ls -l /etc/localtime
    and
    Code:
    echo $TZ
    Henk van Velden

  3. #3
    Join Date
    Aug 2013
    Location
    Jundiai, São Paulo, Brazil
    Posts
    464

    Default Re: Clock in the TaskBar shows wrong time

    Quote Originally Posted by hcvv View Post
    Check:
    Code:
    ls -l /etc/localtime
    and
    Code:
    echo $TZ
    That's the results
    sergio@linux-xgwm:~> ls -l /etc/localtime
    lrwxrwxrwx 1 root root 37 Fev 3 07:03 /etc/localtime -> /usr/share/zoneinfo/America/Sao_Paulo
    sergio@linux-xgwm:~> echo $TZ

    sergio@linux-xgwm:~>
    echo $TZ returns nothing

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,853

    Default Re: Clock in the TaskBar shows wrong time

    Quote Originally Posted by sergelli View Post
    That's the results

    echo $TZ returns nothing
    As you posted everything correctly between CODE tags. I see what it returns. And the last command does return an empty line, which is NOT the same as "nothing" (remember this is about computers, thus preciseness is all important)

    May be I should explain a bit. The TZ environment variable may contain a time zone. E.g. a user may want to live in another timezone then the default onee of the system (remote login from around the globe). When it is empty or non existent (as here), the symlink of /etc/timezone is what counts.

    So no surprises here.

    Maybe you can also check what the time/timezone of your session at that moment is by just displaying it:
    Code:
    date
    BTW, I have to shutdown and leave in about an hour. I hope others will join to help you.
    Henk van Velden

  5. #5
    Join Date
    Aug 2013
    Location
    Jundiai, São Paulo, Brazil
    Posts
    464

    Default Re: Clock in the TaskBar shows wrong time

    The result of "date" is correct. But the clock in taskBar continues with two hours advanced

    Code:
    sergio@linux-xgwm:~> date
    Sex Fev  3 10:17:17 BRST 2017
    sergio@linux-xgwm:~>

  6. #6

    Default Re: Clock in the TaskBar shows wrong time

    On 02/03/2017 07:46 AM, sergelli wrote:
    >
    > The result of "date" is correct. But the clock in taskBar continues with
    > two hours advanced
    >
    >
    > Code:
    > --------------------
    >
    > sergio@linux-xgwm:~> date
    > Sex Fev 3 10:17:17 BRST 2017
    > sergio@linux-xgwm:~>
    >
    >
    > --------------------
    >
    >

    Make sure you don't have a different time set within the clock widget
    itself.

    --
    Ken
    linux since 1994
    S.u.S.E./openSUSE since 1996

  7. #7
    Join Date
    Feb 2016
    Location
    Berlin
    Posts
    357

    Default Re: Clock in the TaskBar shows wrong time

    the others will diagnose problems, but i had a run around for months changing time zone using the clock dialogue. Eventually realised you have to set the time and zone using YAST!

  8. #8
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,853

    Default Re: Clock in the TaskBar shows wrong time

    Quote Originally Posted by sergelli View Post
    The result of "date" is correct. But the clock in taskBar continues with two hours advanced

    Code:
    sergio@linux-xgwm:~> date
    Sex Fev  3 10:17:17 BRST 2017
    sergio@linux-xgwm:~>
    That also looks fine. It seems that all applications then get the correct settings. Thus the widget seems to be incorrect. I do not know the widget, thus I can only recommend @kench' suggestion.
    Henk van Velden

  9. #9
    Join Date
    Aug 2013
    Location
    Jundiai, São Paulo, Brazil
    Posts
    464

    Default Re: Clock in the TaskBar shows wrong time

    Quote Originally Posted by hcvv View Post
    That also looks fine. It seems that all applications then get the correct settings. Thus the widget seems to be incorrect. I do not know the widget, thus I can only recommend @kench' suggestion.

    How do I make sure that I do not have a different time set in the clock widget?

    If that means clicking with the right button on the taskbar clock and adjusting the parameters offered, then I already showed in the image above that there is nothing to adjust.

  10. #10
    Join Date
    Aug 2013
    Location
    Jundiai, São Paulo, Brazil
    Posts
    464

    Default Re: Clock in the TaskBar shows wrong time

    This is a mystery.
    I clicked "Bold" in the configuration window below and
    1-As expected, the source into clock is turned to "Bold"
    2-Instead of showing "UTC", now started to show the date
    3-The time was correct.

    I do not understand why this happened, but the problem is solved.

    Thank you all.


Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •