Results 1 to 3 of 3

Thread: How to adjust Perl @INC so that Perl(Archive::Extract) is found by Unix RuneScape Client?

  1. #1
    Join Date
    Nov 2015
    Location
    Townsville, Australia
    Posts
    271

    Default How to adjust Perl @INC so that Perl(Archive::Extract) is found by Unix RuneScape Client?

    Hi,

    I build a package for the RSU client of RuneScape and while this package works fine on Fedora it does not work so seemlessly on openSUSE as whenever I try to launch it, it gives the error:

    Code:
    Can't locate Archive/Extract.pm in @INC (you may need to install the Archive::Extract module) (@INC contains: /usr/lib/perl5/site_perl/5.24.0/x86_64-linux-thread-multi /usr/lib/perl5/site_perl/5.24.0 /usr/lib/perl5/vendor_perl/5.24.0/x86_64-linux-thread-multi /usr/lib/perl5/vendor_perl/5.24.0 /usr/lib/perl5/5.24.0/x86_64-linux-thread-multi /usr/lib/perl5/5.24.0 /usr/lib/perl5/site_perl .) at /opt/runescape/rsu/rsu-query line 11.
    BEGIN failed--compilation aborted at /opt/runescape/rsu/rsu-query line 11.
    I know that the .pm module of Perl(Archive::Extract) for openSUSE Tumbleweed is located at /usr/lib/perl5/vendor_perl/5.24.0/Archive/Zip/Archive.pm. Is there a way to adjust @INC so that RSU finds this module?

    Thanks for your time,
    Brenton
    Brenton Horne: Linux enthusiast and writer of ​The Hornery.
    Five favourite distros: Arch Linux, Fedora, openSUSE Tumbleweed, Sabayon Linux and Ubuntu.

  2. #2
    Join Date
    Nov 2015
    Location
    Townsville, Australia
    Posts
    271

    Default Re: How to adjust Perl @INC so that Perl(Archive::Extract) is found by Unix RuneScape Client?

    Btw running:

    Code:
    PERL5LIB=$PERL5LIB:/usr/lib/perl5/vendor_perl/5.24.0/Archive/Zip/ /usr/bin/runescape
    returns the exact same error.
    Brenton Horne: Linux enthusiast and writer of ​The Hornery.
    Five favourite distros: Arch Linux, Fedora, openSUSE Tumbleweed, Sabayon Linux and Ubuntu.

  3. #3
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    23,341
    Blog Entries
    15

    Default Re: How to adjust Perl @INC so that Perl(Archive::Extract) is foundby Unix RuneScape Client?

    On Thu 02 Feb 2017 03:36:01 PM CST, fusion809 wrote:

    Hi,

    I build a package for the RSU client of RuneScape and while this package
    works fine on Fedora it does not work so seemlessly on openSUSE as
    whenever I try to launch it, it gives the error:


    Code:
    --------------------

    Can't locate Archive/Extract.pm in @INC (you may need to install the
    Archive::Extract module) (@INC
    contains: /usr/lib/perl5/site_perl/5.24.0/x86_64-linux-thread-multi /usr/lib/perl5/site_perl/5.24.0 /usr/lib/perl5/vendor_perl/5.24.0/x86_64-linux-thread-multi /usr/lib/perl5/vendor_perl/5.24.0 /usr/lib/perl5/5.24.0/x86_64-linux-thread-multi /usr/lib/perl5/5.24.0 /usr/lib/perl5/site_perl .)
    at /opt/runescape/rsu/rsu-query line 11. BEGIN failed--compilation
    aborted at /opt/runescape/rsu/rsu-query line 11. --------------------


    I know that the .pm module of Perl(Archive::Extract) for openSUSE
    Tumbleweed is located at
    /usr/lib/perl5/vendor_perl/5.24.0/Archive/Zip/Archive.pm. Is there a way
    to adjust @INC so that RSU finds this module?

    Thanks for your time,
    Brenton


    Hi
    Use %perl_sitearch macro by the looks...
    https://en.opensuse.org/openSUSEackaging_Perl

    --
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    openSUSE Leap 42.1|GNOME 3.16.2|4.1.36-44-default
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •